fix detection of C++11 atomic header

This commit is contained in:
Dan Horák 2012-04-23 20:05:08 +02:00
parent 50e073a68a
commit ba92463cc7
2 changed files with 58 additions and 1 deletions

51
ceph-gxx-atomic.patch Normal file
View File

@ -0,0 +1,51 @@
diff -up ceph-0.45/src/leveldb/configure.ac.atomic ceph-0.45/src/leveldb/configure.ac
--- ceph-0.45/src/leveldb/configure.ac.atomic 2012-04-23 18:56:15.000000000 +0200
+++ ceph-0.45/src/leveldb/configure.ac 2012-04-23 19:33:27.000000000 +0200
@@ -10,11 +10,11 @@ AC_CONFIG_FILES([
])
AC_PROG_RANLIB
-AC_MSG_CHECKING(whether compiler supports C++11 cstdatomic)
+AC_MSG_CHECKING(whether compiler supports C++11 atomic)
OLD_CXXFLAGS="$CXXFLAGS"
CXXFLAGS="$CXXFLAGS -std=c++0x"
AC_COMPILE_IFELSE([AC_LANG_SOURCE([
-#include <cstdatomic>
+#include <atomic>
int main() {}
])], [
AC_MSG_RESULT(yes)
diff -up ceph-0.45/src/leveldb/configure.atomic ceph-0.45/src/leveldb/configure
--- ceph-0.45/src/leveldb/configure.atomic 2012-04-23 18:56:19.000000000 +0200
+++ ceph-0.45/src/leveldb/configure 2012-04-23 18:56:43.000000000 +0200
@@ -3885,15 +3885,15 @@ else
fi
-{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether compiler supports C++11 cstdatomic" >&5
-$as_echo_n "checking whether compiler supports C++11 cstdatomic... " >&6; }
+{ $as_echo "$as_me:${as_lineno-$LINENO}: checking whether compiler supports C++11 atomic" >&5
+$as_echo_n "checking whether compiler supports C++11 atomic... " >&6; }
OLD_CXXFLAGS="$CXXFLAGS"
CXXFLAGS="$CXXFLAGS -std=c++0x"
cat confdefs.h - <<_ACEOF >conftest.$ac_ext
/* end confdefs.h. */
-#include <cstdatomic>
+#include <atomic>
int main() {}
_ACEOF
diff -up ceph-0.45/src/leveldb/port/atomic_pointer.h.atomic ceph-0.45/src/leveldb/port/atomic_pointer.h
--- ceph-0.45/src/leveldb/port/atomic_pointer.h.atomic 2012-04-23 18:56:54.000000000 +0200
+++ ceph-0.45/src/leveldb/port/atomic_pointer.h 2012-04-23 18:57:00.000000000 +0200
@@ -21,7 +21,7 @@
#include <stdint.h>
#ifdef LEVELDB_CSTDATOMIC_PRESENT
-#include <cstdatomic>
+#include <atomic>
#endif
#ifdef OS_WIN
#include <windows.h>

View File

@ -1,6 +1,6 @@
Name: ceph
Version: 0.45
Release: 1%{?dist}
Release: 2%{?dist}
Summary: User space components of the Ceph file system
License: LGPLv2
Group: System Environment/Base
@ -9,6 +9,8 @@ URL: http://ceph.newdream.net/
Source: http://ceph.newdream.net/download/%{name}-%{version}.tar.bz2
Patch0: ceph-init-fix.patch
Patch1: ceph.logrotate.patch
# http://tracker.newdream.net/issues/2329
Patch2: ceph-gxx-atomic.patch
BuildRequires: fuse-devel, libtool, libtool-ltdl-devel, boost-devel,
BuildRequires: libedit-devel, fuse-devel, git, perl, gdbm, libaio-devel,
@ -81,6 +83,7 @@ file system.
%setup -q
%patch0 -p1 -b .init
%patch1 -p0
%patch2 -p1 -b .atomic
%build
./autogen.sh
@ -249,6 +252,9 @@ fi
%{_bindir}/boto_tool
%changelog
* Mon Apr 23 2012 Dan Horák <dan[at]danny.cz> - 0.45-2
- fix detection of C++11 atomic header
* Thu Apr 12 2012 Josef Bacik <josef@toxicpanda.com> - 0.45-1
- updating to upstream 0.45