New version (1:10.2.5-1)

- hack: do not check for libxfs, assume it is present
This commit is contained in:
Boris Ranto 2017-01-13 01:01:19 +01:00
parent 7fc18b8c1c
commit a2502bdf58
4 changed files with 41 additions and 47 deletions

View File

@ -0,0 +1,33 @@
From 69e888fa5c103588ee9f23ac4cec4bfc2285eb08 Mon Sep 17 00:00:00 2001
From: Boris Ranto <branto@redhat.com>
Date: Fri, 13 Jan 2017 01:15:42 +0100
Subject: [PATCH] hack: do not test for libxfs, assume it is present
---
configure.ac | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 32e273f..050e754 100644
--- a/configure.ac
+++ b/configure.ac
@@ -882,7 +882,7 @@ AC_ARG_WITH([libxfs],
[AS_HELP_STRING([--without-libxfs], [disable libxfs use by FileStore])],
[],
[with_libxfs=yes])
-AS_IF([test "x$with_libxfs" != "xno"], [
+AS_IF([test "x$with_libxfs" = "hack..."], [
# xfs/xfs.h presence and XFS_XFLAG_EXTSIZE define
AC_CHECK_HEADER([xfs/xfs.h], [], AC_MSG_ERROR(
[xfs/xfs.h not found (--without-libxfs to disable)]))
@@ -900,6 +900,7 @@ AS_IF([test "x$with_libxfs" != "xno"], [
AC_MSG_ERROR([XFS_XFLAG_EXTSIZE not found (--without-libxfs to disable)])
])
])
+AC_DEFINE([HAVE_LIBXFS], [1], [Define to 1 if you have libxfs])
AM_CONDITIONAL(WITH_LIBXFS, [test "x$with_libxfs" != "xno"])
# use libzfs
--
2.7.4

View File

@ -1,43 +0,0 @@
From f7abffec751e454d119df273dc6e49e5f7106078 Mon Sep 17 00:00:00 2001
From: Sage Weil <sage@redhat.com>
Date: Wed, 7 Dec 2016 18:25:55 -0600
Subject: [PATCH] msg/simple/Pipe: avoid returning 0 on poll timeout
If poll times out it will return 0 (no data to read on socket). In
165e5abdbf6311974d4001e43982b83d06f9e0cc we changed tcp_read_wait from
returning -1 to returning -errno, which means we return 0 instead of -1
in this case.
This makes tcp_read() get into an infinite loop by repeatedly trying to
read from the socket and getting EAGAIN.
Fix by explicitly checking for a 0 return from poll(2) and returning
EAGAIN in that case.
Fixes: http://tracker.ceph.com/issues/18184
Signed-off-by: Sage Weil <sage@redhat.com>
(cherry picked from commit 6c3d015c6854a12cda40673848813d968ff6afae)
---
src/msg/simple/Pipe.cc | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)
diff --git a/src/msg/simple/Pipe.cc b/src/msg/simple/Pipe.cc
index 80b948d..cfb1986 100644
--- a/src/msg/simple/Pipe.cc
+++ b/src/msg/simple/Pipe.cc
@@ -2500,8 +2500,11 @@ int Pipe::tcp_read_wait()
if (has_pending_data())
return 0;
- if (poll(&pfd, 1, msgr->timeout) <= 0)
+ int r = poll(&pfd, 1, msgr->timeout);
+ if (r < 0)
return -errno;
+ if (r == 0)
+ return -EAGAIN;
evmask = POLLERR | POLLHUP | POLLNVAL;
#if defined(__linux__)
--
2.7.4

View File

@ -56,8 +56,8 @@
# common
#################################################################################
Name: ceph
Version: 10.2.4
Release: 2%{?dist}
Version: 10.2.5
Release: 1%{?dist}
Epoch: 1
Summary: User space components of the Ceph file system
License: LGPL-2.1 and CC-BY-SA-1.0 and GPL-2.0 and BSL-1.0 and GPL-2.0-with-autoconf-exception and BSD-3-Clause and MIT
@ -67,7 +67,7 @@ Group: System/Filesystems
URL: http://ceph.com/
Source0: http://ceph.com/download/%{name}-%{version}.tar.gz
Patch1: 0001-Disable-erasure_codelib-neon-build.patch
Patch2: 0002-msg-simple-Pipe-avoid-returning-0-on-poll-timeout.patch
Patch2: 0002-hack-do-not-test-for-libxfs-assume-it-is-present.patch
%if 0%{?suse_version}
%if 0%{?is_opensuse}
ExclusiveArch: x86_64 aarch64 ppc64 ppc64le
@ -1552,6 +1552,10 @@ exit 0
%changelog
* Fri Jan 13 2017 Boris Ranto <branto@redhat.com> - 1:10.2.5-1
- New release (1:10.2.5-1)
- hack: do not test for libxfs, assume it is present
* Wed Dec 14 2016 Boris Ranto <branto@redhat.com> - 1:10.2.4-2
- New version (1:10.2.4-2)
- This syncs up with the upstream 10.2.5

View File

@ -1 +1 @@
ae84a14d93d0b7cc4fa59bac0c79746f ceph-10.2.4.tar.gz
SHA512 (ceph-10.2.5.tar.gz) = 4889aff38c8af781c2e3dce8f4ee51864db0a27c6294774345d2c1b047588ec31354ad41f799e2f0d0a966dc372d76c9bdbfb93f30a0718ea9d7c2b7a645d0f8