ceph-17.2.5, rebuild with gcc-13

Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
This commit is contained in:
Kaleb S. KEITHLEY 2023-01-17 16:00:06 -05:00
parent f6485b3ab1
commit 945dc70d29
2 changed files with 97 additions and 1 deletions

92
0024-gcc-13.patch Normal file
View File

@ -0,0 +1,92 @@
--- ceph-17.2.5/src/common/subsys_types.h.orig 2023-01-17 05:29:55.711592884 -0500
+++ ceph-17.2.5/src/common/subsys_types.h 2023-01-17 05:31:05.759282197 -0500
@@ -53,7 +53,7 @@
#undef DEFAULT_SUBSYS
}
-constexpr static std::uint8_t
+constexpr static uint8_t
ceph_subsys_get_max_default_level(const std::size_t subidx) {
const auto item = ceph_subsys_get_as_array()[subidx];
return std::max(item.log_level, item.gather_level);
--- ceph-17.2.5/src/msg/async/compression_onwire.h.orig 2023-01-17 07:34:31.923701878 -0500
+++ ceph-17.2.5/src/msg/async/compression_onwire.h 2023-01-17 07:35:04.493093534 -0500
@@ -44,7 +44,7 @@
class TxHandler final : private Handler {
public:
- TxHandler(CephContext* const cct, CompressorRef compressor, int mode, std::uint64_t min_size)
+ TxHandler(CephContext* const cct, CompressorRef compressor, int mode, uint64_t min_size)
: Handler(cct, compressor),
m_min_size(min_size),
m_mode(static_cast<Compressor::CompressionMode>(mode))
@@ -97,7 +97,7 @@
static rxtx_t create_handler_pair(
CephContext* ctx,
const CompConnectionMeta& comp_meta,
- std::uint64_t compress_min_size);
+ uint64_t compress_min_size);
};
}
--- ceph-17.2.5/src/msg/async/crypto_onwire.h.orig 2023-01-17 07:35:35.535513714 -0500
+++ ceph-17.2.5/src/msg/async/crypto_onwire.h 2023-01-17 07:35:46.578307452 -0500
@@ -95,7 +95,7 @@
// Transmitter can append extra bytes of ciphertext at the -final step.
// This method return how much was added, and thus let client translate
// plaintext size into ciphertext size to grab from wire.
- virtual std::uint32_t get_extra_size_at_final() = 0;
+ virtual uint32_t get_extra_size_at_final() = 0;
// Instance of RxHandler must be reset before doing any decrypt-update
// step. This applies also to situation when decrypt-final was already
--- ceph-17.2.5/src/common/Cycles.h.orig 2023-01-17 07:56:19.787662012 -0500
+++ ceph-17.2.5/src/common/Cycles.h 2023-01-17 07:56:57.852980655 -0500
@@ -29,8 +29,9 @@
*/
-#ifndef CEPH_CYCLES_H
-#define CEPH_CYCLES_H
+#pragma once
+
+#include <cstdint>
/**
* This class provides static methods that read the fine-grain CPU
@@ -112,4 +113,3 @@
}
};
-#endif // CEPH_CYCLES_H
--- ceph-17.2.5/src/test/librados/op_speed.cc.orig 2023-01-17 08:57:37.078531022 -0500
+++ ceph-17.2.5/src/test/librados/op_speed.cc 2023-01-17 08:57:58.259139439 -0500
@@ -9,7 +9,7 @@
for (int i = 0; i < to_create; ++i) {
librados::ObjectReadOperation op;
bufferlist bl;
- std::uint64_t sz;
+ uint64_t sz;
struct timespec tm;
std::map<std::string, ceph::buffer::list> xattrs;
std::map<std::string, ceph::buffer::list> omap;
--- ceph-17.2.5/src/test/mon/test_log_rss_usage.cc.orig 2023-01-17 10:14:37.552820230 -0500
+++ ceph-17.2.5/src/test/mon/test_log_rss_usage.cc 2023-01-17 10:15:12.319202506 -0500
@@ -5,6 +5,7 @@
#include <string>
#include <iostream>
#include <fstream>
+#include <cstdint>
#include <stdlib.h>
#include <stdio.h>
#include <unistd.h>
--- ceph-17.2.5/src/librbd/api/PoolMetadata.h.orig 2023-01-17 13:07:44.701750744 -0500
+++ ceph-17.2.5/src/librbd/api/PoolMetadata.h 2023-01-17 13:08:10.300301845 -0500
@@ -9,6 +9,7 @@
#include <map>
#include <string>
+#include <cstdint>
namespace librbd {

View File

@ -162,7 +162,7 @@
#################################################################################
Name: ceph
Version: 17.2.5
Release: 2%{?dist}
Release: 3%{?dist}
%if 0%{?fedora} || 0%{?rhel}
Epoch: 2
%endif
@ -192,6 +192,7 @@ Patch0018: 0018-src-rgw-store-dbstore-CMakeLists.txt.patch
Patch0019: 0019-cmake-modules-CheckCxxAtomic.cmake.patch
Patch0020: 0020-src-arrow-cpp-cmake_modules-ThirdpartyToolchain.cmake.patch
Patch0023: 0023-src-s3select-include-s3select_parquet_intrf.h.patch
Patch0024: 0024-gcc-13.patch
# ceph 14.0.1 does not support 32-bit architectures, bugs #1727788, #1727787
ExcludeArch: i686 armv7hl
%if 0%{?suse_version}
@ -2624,6 +2625,9 @@ exit 0
%config %{_sysconfdir}/prometheus/ceph/ceph_default_alerts.yml
%changelog
* Tue Jan 17 2023 Kaleb S. KEITHLEY <kkeithle[at]redhat.com> - 2:17.2.5-3
- ceph-17.2.5, rebuild with gcc-13
* Thu Dec 1 2022 Kaleb S. KEITHLEY <kkeithle[at]redhat.com> - 2:17.2.5-2
- ceph-17.2.5, rebuild with libarrow-10