0.41 + build fixes
This commit is contained in:
parent
c0a0a52a8b
commit
9097f5d573
1
.gitignore
vendored
1
.gitignore
vendored
@ -5,3 +5,4 @@ ceph-0.20.tar.gz
|
||||
/ceph-0.31.tar.gz
|
||||
/ceph-0.37.tar.gz
|
||||
/ceph-0.39.tar.gz
|
||||
/ceph-0.41.tar.bz2
|
||||
|
33
ceph-0.39-comment-out-unused-code-in-dump_pop_map.patch
Normal file
33
ceph-0.39-comment-out-unused-code-in-dump_pop_map.patch
Normal file
@ -0,0 +1,33 @@
|
||||
diff -up ceph-0.39/src/mds/MDBalancer.cc.fix ceph-0.39/src/mds/MDBalancer.cc
|
||||
--- ceph-0.39/src/mds/MDBalancer.cc.fix 2012-02-16 12:23:26.582302711 -0500
|
||||
+++ ceph-0.39/src/mds/MDBalancer.cc 2012-02-16 12:31:44.386396603 -0500
|
||||
@@ -1155,6 +1155,7 @@ void MDBalancer::dump_pop_map()
|
||||
{
|
||||
return; // this is dumb
|
||||
|
||||
+/*
|
||||
|
||||
char fn[32];
|
||||
snprintf(fn, sizeof(fn), "popdump.%d.mds%d", beat_epoch, mds->get_nodeid());
|
||||
@@ -1174,10 +1175,9 @@ void MDBalancer::dump_pop_map()
|
||||
iq.pop_front();
|
||||
|
||||
// pop stats
|
||||
- /*for (int a=0; a<MDS_NPOP; a++)
|
||||
- for (int b=0; b<META_NPOP; b++)
|
||||
- myfile << in->popularity[a].pop[b].get(now) << "\t";
|
||||
- */
|
||||
+ //for (int a=0; a<MDS_NPOP; a++)
|
||||
+ // for (int b=0; b<META_NPOP; b++)
|
||||
+ // myfile << in->popularity[a].pop[b].get(now) << "\t";
|
||||
|
||||
// recurse, depth-first.
|
||||
if (in->is_dir()) {
|
||||
@@ -1214,6 +1214,7 @@ void MDBalancer::dump_pop_map()
|
||||
}
|
||||
|
||||
myfile.close();
|
||||
+*/
|
||||
}
|
||||
|
||||
|
67
ceph-0.41-compile-fixes.patch
Normal file
67
ceph-0.41-compile-fixes.patch
Normal file
@ -0,0 +1,67 @@
|
||||
diff -up ceph-0.41/src/cephfs.cc.compilefix ceph-0.41/src/cephfs.cc
|
||||
--- ceph-0.41/src/cephfs.cc.compilefix 2012-02-16 21:08:19.983652818 -0500
|
||||
+++ ceph-0.41/src/cephfs.cc 2012-02-16 21:08:31.917550083 -0500
|
||||
@@ -24,6 +24,7 @@
|
||||
#include <sys/stat.h>
|
||||
#include <fcntl.h>
|
||||
#include <stdlib.h>
|
||||
+#include <unistd.h>
|
||||
#include "client/ioctl.h"
|
||||
|
||||
using namespace std;
|
||||
diff -up ceph-0.41/src/common/safe_io.h.compilefix ceph-0.41/src/common/safe_io.h
|
||||
--- ceph-0.41/src/common/safe_io.h.compilefix 2012-02-16 12:53:31.456514774 -0500
|
||||
+++ ceph-0.41/src/common/safe_io.h 2012-02-16 12:54:00.045233017 -0500
|
||||
@@ -16,6 +16,7 @@
|
||||
#define CEPH_SAFE_IO
|
||||
|
||||
#include "common/compiler_extensions.h"
|
||||
+#include <sys/types.h>
|
||||
|
||||
#ifdef __cplusplus
|
||||
extern "C" {
|
||||
diff -up ceph-0.41/src/osd/PG.cc.compilefix ceph-0.41/src/osd/PG.cc
|
||||
--- ceph-0.41/src/osd/PG.cc.compilefix 2012-02-16 20:58:21.039559849 -0500
|
||||
+++ ceph-0.41/src/osd/PG.cc 2012-02-16 20:59:07.920149937 -0500
|
||||
@@ -4830,13 +4830,13 @@ bool PG::PriorSet::affected_by_map(const
|
||||
}
|
||||
|
||||
// did a down osd in cur get (re)marked as lost?
|
||||
- map<int,epoch_t>::const_iterator p = blocked_by.find(o);
|
||||
- if (p != blocked_by.end()) {
|
||||
+ map<int,epoch_t>::const_iterator r = blocked_by.find(o);
|
||||
+ if (r != blocked_by.end()) {
|
||||
if (!osdmap->exists(o)) {
|
||||
dout(10) << "affected_by_map osd." << o << " no longer exists" << dendl;
|
||||
return true;
|
||||
}
|
||||
- if (osdmap->get_info(o).lost_at != p->second) {
|
||||
+ if (osdmap->get_info(o).lost_at != r->second) {
|
||||
dout(10) << "affected_by_map osd." << o << " (re)marked as lost" << dendl;
|
||||
return true;
|
||||
}
|
||||
diff -up ceph-0.41/src/osd/ReplicatedPG.cc.compilefix ceph-0.41/src/osd/ReplicatedPG.cc
|
||||
--- ceph-0.41/src/osd/ReplicatedPG.cc.compilefix 2012-02-16 21:03:26.140892128 -0500
|
||||
+++ ceph-0.41/src/osd/ReplicatedPG.cc 2012-02-16 21:04:45.190200945 -0500
|
||||
@@ -5436,8 +5436,8 @@ int ReplicatedPG::recover_replicas(int m
|
||||
}
|
||||
|
||||
dout(10) << __func__ << ": recover_object_replicas(" << soid << ")" << dendl;
|
||||
- map<hobject_t,Missing::item>::const_iterator p = m.missing.find(soid);
|
||||
- started += recover_object_replicas(soid, p->second.need);
|
||||
+ map<hobject_t,Missing::item>::const_iterator r = m.missing.find(soid);
|
||||
+ started += recover_object_replicas(soid, r->second.need);
|
||||
}
|
||||
}
|
||||
|
||||
diff -up ceph-0.41/src/test/system/systest_runnable.cc.compilefix ceph-0.41/src/test/system/systest_runnable.cc
|
||||
--- ceph-0.41/src/test/system/systest_runnable.cc.compilefix 2012-02-16 12:54:35.430884275 -0500
|
||||
+++ ceph-0.41/src/test/system/systest_runnable.cc 2012-02-16 12:54:45.923780862 -0500
|
||||
@@ -28,6 +28,7 @@
|
||||
#include <sys/syscall.h>
|
||||
#include <sys/types.h>
|
||||
#include <sys/wait.h>
|
||||
+#include <unistd.h>
|
||||
#include <vector>
|
||||
|
||||
#if defined(__FreeBSD__)
|
@ -1,5 +1,6 @@
|
||||
--- ceph-0.21.1/src/init-ceph.in.orig 2010-07-29 15:16:49.000000000 -0500
|
||||
+++ ceph-0.21.1/src/init-ceph.in 2010-08-26 14:58:25.328581937 -0500
|
||||
diff -up ceph-0.41/src/init-ceph.in.init ceph-0.41/src/init-ceph.in
|
||||
--- ceph-0.41/src/init-ceph.in.init 2012-01-17 15:33:20.000000000 -0500
|
||||
+++ ceph-0.41/src/init-ceph.in 2012-02-16 12:48:50.887279921 -0500
|
||||
@@ -1,11 +1,11 @@
|
||||
#!/bin/sh
|
||||
# Start/stop ceph daemons
|
||||
@ -8,10 +9,10 @@
|
||||
|
||||
### BEGIN INIT INFO
|
||||
# Provides: ceph
|
||||
-# Default-Start: 2 3 4 5
|
||||
-# Default-Start: 2 3 5
|
||||
-# Default-Stop: 0 1 6
|
||||
+# Default-Start:
|
||||
+# Default-Stop:
|
||||
+# Default-Start:
|
||||
+# Default-Stop:
|
||||
# Required-Start: $remote_fs $named $network $time
|
||||
# Required-Stop: $remote_fs $named $network $time
|
||||
# Short-Description: Start Ceph distributed file system daemons at boot time
|
||||
|
15
ceph.spec
15
ceph.spec
@ -1,19 +1,21 @@
|
||||
Name: ceph
|
||||
Version: 0.39
|
||||
Version: 0.41
|
||||
Release: 1%{?dist}
|
||||
Summary: User space components of the Ceph file system
|
||||
License: LGPLv2
|
||||
Group: System Environment/Base
|
||||
URL: http://ceph.newdream.net/
|
||||
|
||||
Source: http://ceph.newdream.net/download/%{name}-%{version}.tar.gz
|
||||
Source: http://ceph.newdream.net/download/%{name}-%{version}.tar.bz2
|
||||
Patch0: ceph-init-fix.patch
|
||||
Patch1: ceph.logrotate.patch
|
||||
Patch2: ceph-0.39-comment-out-unused-code-in-dump_pop_map.patch
|
||||
Patch3: ceph-0.41-compile-fixes.patch
|
||||
BuildRequires: fuse-devel, libtool, libtool-ltdl-devel, boost-devel,
|
||||
BuildRequires: libedit-devel, fuse-devel, git, perl, gdbm,
|
||||
# google-perftools is not available on these:
|
||||
%ifnarch ppc64 s390 s390x
|
||||
BuildRequires: google-perftools-devel
|
||||
BuildRequires: gperftools-devel
|
||||
%endif
|
||||
BuildRequires: cryptopp-devel, libatomic_ops-devel, gcc-c++
|
||||
BuildRequires: pkgconfig, libcurl-devel, keyutils-libs-devel
|
||||
@ -80,6 +82,8 @@ file system.
|
||||
%setup -q
|
||||
%patch0 -p1 -b .init
|
||||
%patch1 -p0
|
||||
%patch2 -p1 -b .unusedfix
|
||||
%patch3 -p1 -b .compilefix
|
||||
|
||||
%build
|
||||
./autogen.sh
|
||||
@ -235,6 +239,11 @@ fi
|
||||
%{_bindir}/boto_tool
|
||||
|
||||
%changelog
|
||||
* Thu Feb 16 2012 Tom Callaway <spot@fedoraproject.org> 0.41-1
|
||||
- update to 0.41
|
||||
- fix issues preventing build
|
||||
- rebuild against gperftools
|
||||
|
||||
* Sat Dec 03 2011 David Nalley <david@gnsa.us> 0.38-1
|
||||
- updating to upstream 0.39
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user