New version (1:0.94.7-1)

- Disable erasure_codelib neon build
- init-ceph.in: Allow custom cluster names during startup.
- Apply 'ceph-0.94.1-tcmalloc.patch'
- Apply 'init-ceph.in-fedora.patch'
This commit is contained in:
Boris Ranto 2016-05-16 15:45:52 +02:00
parent c124767d87
commit 8c6c0bc84b
8 changed files with 82 additions and 46 deletions

View File

@ -1,4 +1,4 @@
From 8b0b78dc06ae1ed1c5f3c7a13271e7037091d0be Mon Sep 17 00:00:00 2001
From 8ac49f54ad774324c1de344cd18620df7fa52256 Mon Sep 17 00:00:00 2001
From: Boris Ranto <branto@redhat.com>
Date: Wed, 15 Apr 2015 14:06:24 +0200
Subject: [PATCH] Disable erasure_codelib neon build
@ -25,5 +25,5 @@ index 9ca4fbb..147d57e 100644
libec_jerasure_sse3_la_SOURCES = ${jerasure_sources}
libec_jerasure_sse3_la_CFLAGS = ${AM_CFLAGS} \
--
2.1.0
2.5.5

View File

@ -1,4 +1,4 @@
From 344856455c5452d573dd06eb26c52963dfa3105e Mon Sep 17 00:00:00 2001
From 726127dbd6d51c97495e73c3216c27dd38a31ed3 Mon Sep 17 00:00:00 2001
From: Anthony Alba <ascanio.alba7@gmail.com>
Date: Mon, 30 Nov 2015 16:44:31 +0800
Subject: [PATCH] init-ceph.in: Allow custom cluster names during startup.
@ -9,10 +9,10 @@ Signed-off-by: Richard Chan <richard@treeboxsolutions.com>
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/src/init-ceph.in b/src/init-ceph.in
index 2ff98c7..245068a 100644
index e4cea7e..1f19ffa 100644
--- a/src/init-ceph.in
+++ b/src/init-ceph.in
@@ -282,7 +286,7 @@ for name in $what; do
@@ -288,7 +288,7 @@ for name in $what; do
lockfile=""
fi
@ -21,7 +21,7 @@ index 2ff98c7..245068a 100644
case "$command" in
start)
@@ -395,8 +399,8 @@ for name in $what; do
@@ -404,8 +404,8 @@ for name in $what; do
# these keys. it's also true for legacy installs
# via mkcephfs, which is fine too; there is no harm
# in creating these keys.
@ -33,5 +33,5 @@ index 2ff98c7..245068a 100644
cmd2="$SBINDIR/ceph-create-keys --cluster $cluster -i $id 2> /dev/null &"
do_cmd "$cmd2"
--
2.1.0
2.5.5

View File

@ -0,0 +1,26 @@
From ebff005e9998122c9e89052fbca06f4962180240 Mon Sep 17 00:00:00 2001
From: Boris Ranto <branto@redhat.com>
Date: Mon, 16 May 2016 15:47:20 +0200
Subject: [PATCH] Apply 'ceph-0.94.1-tcmalloc.patch'
Signed-off-by: Boris Ranto <branto@redhat.com>
---
src/rocksdb/configure.ac | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/rocksdb/configure.ac b/src/rocksdb/configure.ac
index 855c6a8..fe914aa 100644
--- a/src/rocksdb/configure.ac
+++ b/src/rocksdb/configure.ac
@@ -19,7 +19,7 @@ AC_CHECK_LIB([snappy], [snappy_compress], [HAVE_LIBSNAPPY=yes], [AC_MSG_FAILURE(
AC_CHECK_LIB([z], [gzread], [HAVE_LIBZ=yes], [AC_MSG_FAILURE([libz not found])])
AC_CHECK_LIB([bz2], [BZ2_bzCompressInit], [HAVE_LIBBZ2=yes], [AC_MSG_FAILURE([libbz2 not found])])
AC_CHECK_LIB([rt], [clock_gettime], [HAVE_LIBRT=yes], [AC_MSG_FAILURE([librt not found])])
-AC_CHECK_LIB([tcmalloc], [malloc], [HAVE_LIBTCMALLOC=yes],[AC_MSG_FAILURE([no tcmalloc found ])])
+AC_CHECK_LIB([tcmalloc], [malloc], [HAVE_LIBTCMALLOC=yes],[AC_MSG_RESULT([no tcmalloc found ])])
OLD_CXXFLAGS="$CXXFLAGS"
CXXFLAGS="$CXXFLAGS -std=c++11"
--
2.5.5

View File

@ -0,0 +1,32 @@
From ecc0e801e378310dbb0e60ae7eb1f19179bd3e9e Mon Sep 17 00:00:00 2001
From: Boris Ranto <branto@redhat.com>
Date: Mon, 16 May 2016 15:48:23 +0200
Subject: [PATCH] Apply 'init-ceph.in-fedora.patch'
Signed-off-by: Boris Ranto <branto@redhat.com>
---
src/init-ceph.in | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/src/init-ceph.in b/src/init-ceph.in
index 1f19ffa..78eaf97 100644
--- a/src/init-ceph.in
+++ b/src/init-ceph.in
@@ -1,11 +1,11 @@
#!/bin/sh
# Start/stop ceph daemons
-# chkconfig: 2345 60 80
+# chkconfig: - 60 80
### BEGIN INIT INFO
# Provides: ceph
-# Default-Start: 2 3 4 5
-# Default-Stop: 0 1 6
+# Default-Start:
+# Default-Stop:
# Required-Start: $remote_fs $named $network $time
# Required-Stop: $remote_fs $named $network $time
# Short-Description: Start Ceph distributed file system daemons at boot time
--
2.5.5

View File

@ -1,12 +0,0 @@
diff -up ceph-0.94.1/src/rocksdb/configure.ac.tcmalloc ceph-0.94.1/src/rocksdb/configure.ac
--- ceph-0.94.1/src/rocksdb/configure.ac.tcmalloc 2015-06-08 14:03:27.000000000 +0200
+++ ceph-0.94.1/src/rocksdb/configure.ac 2015-06-08 14:03:41.000000000 +0200
@@ -19,7 +19,7 @@ AC_CHECK_LIB([snappy], [snappy_compress]
AC_CHECK_LIB([z], [gzread], [HAVE_LIBZ=yes], [AC_MSG_FAILURE([libz not found])])
AC_CHECK_LIB([bz2], [BZ2_bzCompressInit], [HAVE_LIBBZ2=yes], [AC_MSG_FAILURE([libbz2 not found])])
AC_CHECK_LIB([rt], [clock_gettime], [HAVE_LIBRT=yes], [AC_MSG_FAILURE([librt not found])])
-AC_CHECK_LIB([tcmalloc], [malloc], [HAVE_LIBTCMALLOC=yes],[AC_MSG_FAILURE([no tcmalloc found ])])
+AC_CHECK_LIB([tcmalloc], [malloc], [HAVE_LIBTCMALLOC=yes],[AC_MSG_RESULT([no tcmalloc found ])])
OLD_CXXFLAGS="$CXXFLAGS"
CXXFLAGS="$CXXFLAGS -std=c++11"

View File

@ -11,7 +11,7 @@
# common
#################################################################################
Name: ceph
Version: 0.94.6
Version: 0.94.7
Release: 1%{?dist}
Epoch: 1
Summary: User space components of the Ceph file system
@ -19,14 +19,14 @@ License: GPLv2
Group: System Environment/Base
URL: http://ceph.com/
Source0: http://ceph.com/download/%{name}-%{version}.tar.gz
Patch1: 0001-Disable-erasure_codelib-neon-build.patch
Patch2: 0002-init-ceph.in-Allow-custom-cluster-names-during-start.patch
Patch3: 0003-Apply-ceph-0.94.1-tcmalloc.patch.patch
Patch4: 0004-Apply-init-ceph.in-fedora.patch.patch
%if 0%{?fedora} || 0%{?centos} || 0%{?rhel}
Patch0000: init-ceph.in-fedora.patch
%endif
Patch0001: 0001-Disable-erasure_codelib-neon-build.patch
Patch0002: 0002-init-ceph.in-Allow-custom-cluster-names-during-start.patch
# fix build without tcmalloc
# https://github.com/ceph/rocksdb/pull/5
Patch0010: ceph-0.94.1-tcmalloc.patch
Requires: librbd1 = %{epoch}:%{version}-%{release}
Requires: librados2 = %{epoch}:%{version}-%{release}
Requires: libcephfs1 = %{epoch}:%{version}-%{release}
@ -426,12 +426,12 @@ python-cephfs instead.
#################################################################################
%prep
%setup -q
%if 0%{?fedora} || 0%{?rhel} || 0%{?centos}
%patch0 -p1 -b .init
%endif
%patch1 -p1
%patch2 -p1
%patch10 -p1 -b .tcmalloc
%patch3 -p1
%patch4 -p1
%if 0%{?fedora} || 0%{?rhel} || 0%{?centos}
%endif
%build
# Find jni.h
@ -935,6 +935,13 @@ ln -sf %{_libdir}/librbd.so.1 /usr/lib64/qemu/librbd.so.1
# actually build this meta package.
%changelog
* Mon May 16 2016 Boris Ranto <branto@redhat.com> - 1:0.94.7-1
- New version (1:0.94.7-1)
- Disable erasure_codelib neon build
- init-ceph.in: Allow custom cluster names during startup.
- Apply 'ceph-0.94.1-tcmalloc.patch'
- Apply 'init-ceph.in-fedora.patch'
* Tue Feb 23 2016 Boris Ranto <branto@redhat.com> - 0.94.6-1
- Rebase to version 0.94.6

View File

@ -1,18 +0,0 @@
diff -up ceph-0.46/src/init-ceph.in.orig ceph-0.46/src/init-ceph.in
--- ceph-0.46/src/init-ceph.in.orig 2012-04-24 16:06:39.000000000 -0400
+++ ceph-0.46/src/init-ceph.in 2012-05-09 16:41:36.500004052 -0400
@@ -1,11 +1,11 @@
#!/bin/sh
# Start/stop ceph daemons
-# chkconfig: 2345 60 80
+# chkconfig: - 60 80
### BEGIN INIT INFO
# Provides: ceph
-# Default-Start: 2 3 4 5
-# Default-Stop: 0 1 6
+# Default-Start:
+# Default-Stop:
# Required-Start: $remote_fs $named $network $time
# Required-Stop: $remote_fs $named $network $time
# Short-Description: Start Ceph distributed file system daemons at boot time

View File

@ -1,2 +1,3 @@
e7c35581f8d36d34f7cde16a862e54fb ceph-0.94.5.tar.bz2
566cdeae80ee639dcb265ac284a59b48 ceph-0.94.6.tar.gz
a8fd1046805551e301cb835f418ade72 ceph-0.94.7.tar.gz