rebuilt with system Boost

Signed-off-by: Kaleb S KEITHLEY <kkeithle@redhat.com>
This commit is contained in:
Kaleb S KEITHLEY 2021-01-25 18:14:45 -05:00
parent 9e63d61879
commit 501243427a
3 changed files with 21 additions and 6 deletions

View File

@ -1,6 +1,6 @@
--- ceph-15.2.8/src/CMakeLists.txt.orig 2021-01-03 12:47:00.275274985 -0500
+++ ceph-15.2.8/src/CMakeLists.txt 2021-01-03 12:51:17.957185433 -0500
@@ -23,10 +23,15 @@
--- ceph-15.2.8/src/CMakeLists.txt.orig 2021-01-25 13:34:31.122206146 -0500
+++ ceph-15.2.8/src/CMakeLists.txt 2021-01-25 13:37:12.863612216 -0500
@@ -23,10 +23,16 @@
set(datadir ${CEPH_INSTALL_DATADIR})
set(prefix ${CMAKE_INSTALL_PREFIX})
@ -12,7 +12,8 @@
+ -D_THREAD_SAFE
+ -D__STDC_FORMAT_MACROS
+ -D_FILE_OFFSET_BITS=64
+ -DBOOST_ASIO_DISABLE_THREAD_KEYWORD_EXTENSION)
+ -DBOOST_ASIO_DISABLE_THREAD_KEYWORD_EXTENSION
+ -DBOOST_ASIO_USE_TS_EXECUTOR_AS_DEFAULT)
if(LINUX)
- add_definitions("-D_GNU_SOURCE")
+ add_definitions(-D_GNU_SOURCE)

View File

@ -0,0 +1,10 @@
--- ceph-15.2.8/src/tools/rbd/action/Bench.cc.orig 2021-01-25 17:08:06.189223814 -0500
+++ ceph-15.2.8/src/tools/rbd/action/Bench.cc 2021-01-25 17:08:27.297805754 -0500
@@ -10,6 +10,7 @@
#include "include/types.h"
#include "global/signal_handler.h"
#include <iostream>
+#include <atomic>
#include <boost/accumulators/accumulators.hpp>
#include <boost/accumulators/statistics/stats.hpp>
#include <boost/accumulators/statistics/rolling_sum.hpp>

View File

@ -101,7 +101,7 @@
#################################################################################
Name: ceph
Version: 15.2.8
Release: 5%{?dist}
Release: 6%{?dist}
%if 0%{?fedora} || 0%{?rhel}
Epoch: 2
%endif
@ -124,6 +124,7 @@ Patch0003: 0003-src-common-bitstr.h.patch
Patch0004: 0004-src-common-ceph-time.h.patch
Patch0005: 0005-src-CMakeLists.txt.patch
Patch0006: 0006-src-rgw-rgw_asio_frontend.cc.patch
Patch0007: 0007-src-tools-rbd-action-Bench.cc.patch
Source1: cmake-modules-BuildBoost.cmake.noautopatch
# ceph 14.0.1 does not support 32-bit architectures, bugs #1727788, #1727787
ExcludeArch: i686 armv7hl
@ -1241,7 +1242,7 @@ cd build
-DWITH_OCF=ON \
%endif
-DWITH_REENTRANT_STRSIGNAL=ON \
-DWITH_SYSTEM_BOOST=OFF \
-DWITH_SYSTEM_BOOST=ON \
%ifarch aarch64 armv7hl mips mipsel ppc ppc64 ppc64le %{ix86} x86_64
-DWITH_BOOST_CONTEXT=ON \
%else
@ -2381,6 +2382,9 @@ exit 0
%config %{_sysconfdir}/prometheus/ceph/ceph_default_alerts.yml
%changelog
* Mon Jan 25 2021 Kaleb S. KEITHLEY <kkeithle[at]redhat.com> - 2:15.2.8-6
- rebuilt with system Boost
* Fri Jan 22 2021 Kaleb S. KEITHLEY <kkeithle[at]redhat.com> - 2:15.2.8-5
- rebuilt with bundled Boost