Merge remote-tracking branch 'origin' into el6

This commit is contained in:
Kaleb S. KEITHLEY 2014-05-13 21:02:23 -04:00
commit 4e33e003a1
5 changed files with 95 additions and 62 deletions

2
.gitignore vendored
View File

@ -15,3 +15,5 @@ ceph-0.20.tar.gz
/ceph-0.56.4.tar.bz2
/ceph-0.61.7.tar.bz2
/ceph-0.67.3.tar.bz2
/ceph-0.72.2.tar.bz2
/ceph-0.80.1.tar.bz2

View File

@ -1,12 +1,31 @@
diff -up ceph-0.67.3/src/Makefile.am.sbin-fix ceph-0.67.3/src/Makefile.am
--- ceph-0.67.3/src/Makefile.am.sbin-fix 2013-09-11 13:46:40.061851086 -0400
+++ ceph-0.67.3/src/Makefile.am 2013-09-11 13:46:51.531735427 -0400
@@ -28,7 +28,7 @@ bin_PROGRAMS =
bin_DEBUGPROGRAMS =
sbin_PROGRAMS =
From 69baa8948f2d922554e815c572d8339a4a197306 Mon Sep 17 00:00:00 2001
From: Ken Dreyer <ken.dreyer@inktank.com>
Date: Tue, 7 Jan 2014 21:51:14 -0700
Subject: [PATCH] Fedora only: fix sbin path
On Fedora, /sbin is a symbolic link to /usr/sbin. Install all the sbin
binaries into the /usr/sbin location.
Signed-off-by: Ken Dreyer <ken.dreyer@inktank.com>
---
src/Makefile-env.am | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/Makefile-env.am b/src/Makefile-env.am
index 9bc6ee7..d02f034 100644
--- a/src/Makefile-env.am
+++ b/src/Makefile-env.am
@@ -26,8 +26,8 @@ bin_DEBUGPROGRAMS =
# like sbin_SCRIPTS but can be used to install to e.g. /usr/sbin
-ceph_sbindir = $(exec_prefix)$(sbindir)
+ceph_sbindir = $(sbindir)
ceph_sbin_SCRIPTS = \
ceph-disk \
ceph-disk-prepare \
ceph_sbindir = $(sbindir)
-# certain things go straight into /sbin, though!
-su_sbindir = /sbin
+# On Fedora these things also go into /usr/sbin
+su_sbindir = $(sbindir)
# C/C++ tests to build will be appended to this
check_PROGRAMS =
--
1.8.3.1

View File

@ -1,23 +0,0 @@
diff -up ceph-0.67.3/src/common/crc32c-intel.c.secondary ceph-0.67.3/src/common/crc32c-intel.c
--- ceph-0.67.3/src/common/crc32c-intel.c.secondary 2013-10-07 10:15:22.000000000 +0200
+++ ceph-0.67.3/src/common/crc32c-intel.c 2013-10-07 10:16:00.000000000 +0200
@@ -7,8 +7,8 @@
#include <sys/wait.h>
-/* this probably isn't specific enough for x86_64? fix me someday */
-#ifdef __LP64__
+/* this probably is specific enough for x86_64 */
+#ifdef __x86_64__
/*
* * Based on a posting to lkml by Austin Zhang <austin.zhang@intel.com>
@@ -98,7 +98,7 @@ int ceph_have_crc32c_intel(void)
return 0;
}
-#else /* __LP64__ */
+#else /* __x86_64__ */
uint32_t ceph_crc32c_le_intel(uint32_t crc, unsigned char const *data, unsigned length)
{

View File

@ -1,27 +1,30 @@
%global _hardened_build 1
Name: ceph
Version: 0.67.3
Release: 2%{?dist}
Version: 0.80.1
Release: 1%{?dist}
Summary: User space components of the Ceph file system
License: LGPLv2
Group: System Environment/Base
URL: http://ceph.com/
URL: https://ceph.com/
Source: http://ceph.com/download/%{name}-%{version}.tar.bz2
Source: https://ceph.com/download/%{name}-%{version}.tar.bz2
Patch0: ceph-init-fix.patch
Patch1: ceph-build-support-for-automake-1.12.patch
Patch2: ceph-fix-sbin-target.patch
Patch3: ceph-non-x86_64.patch
# https://github.com/ceph/ceph/pull/1051
Patch1: ceph-fix-sbin-target.patch
BuildRequires: fuse-devel, libtool, libtool-ltdl-devel, boost-devel,
BuildRequires: fuse-devel, libtool, libtool-ltdl-devel, boost-devel,
BuildRequires: libedit-devel, fuse-devel, git, perl, gdbm, libaio-devel,
# google-perftools is not available on these:
%ifnarch ppc ppc64 s390 s390x
%ifnarch ppc ppc64 s390 s390x aarch64
BuildRequires: gperftools-devel
%endif
BuildRequires: cryptopp-devel, libatomic_ops-static, gcc-c++
BuildRequires: pkgconfig, libcurl-devel, keyutils-libs-devel
BuildRequires: gtkmm24-devel, gtk2-devel, libuuid, libuuid-devel
BuildRequires: leveldb-devel, snappy-devel
BuildRequires: leveldb-devel, snappy-devel, libblkid-devel
BuildRequires: xfsprogs-devel
Requires(post): chkconfig, binutils, libedit
Requires(preun): chkconfig
@ -77,8 +80,6 @@ conjunction with any FastCGI capable web server.
%setup -q
%patch0 -p1 -b .init
%patch1 -p1
%patch2 -p1
%patch3 -p1 -b .non-x86_64
%build
./autogen.sh
@ -92,7 +93,7 @@ EXTRA_LDFLAGS="-pthread"
%{configure} --prefix=%{_prefix} --sbindir=%{_sbindir} \
--localstatedir=%{_localstatedir} --sysconfdir=%{_sysconfdir} \
%ifarch ppc ppc64 s390 s390x
%ifarch ppc ppc64 s390 s390x aarch64
--without-tcmalloc \
%endif
--with-system-leveldb --without-hadoop --with-radosgw --with-gtk2 \
@ -143,10 +144,13 @@ fi
%{_bindir}/cephfs
%{_bindir}/ceph-conf
%{_bindir}/ceph-clsinfo
%{_bindir}/ceph_filestore_tool
%{_bindir}/crushtool
%{_bindir}/monmaptool
%{_bindir}/osdmaptool
%{_bindir}/ceph-authtool
%{_bindir}/ceph-brag
%{_bindir}/ceph-crush-location
%{_bindir}/ceph-syn
%{_bindir}/ceph-run
%{_bindir}/ceph-mon
@ -214,16 +218,33 @@ fi
%doc COPYING
%{_libdir}/librados.so.*
%{_libdir}/librbd.so.*
%dir %{_libdir}/ceph/erasure-code
# Warning to future maintainers: Note that the libec_ and libcls_ unversioned
# shared objects are included here in the libs subpackage. These files are
# plugins that Ceph loads with dlopen(). They belong here in -libs, not
# -devel.
# N.B. in 0.80.1 the `make install` installs the erasure-code shared objects
# in usr/lib*/ceph/erasure-code/...
%{_libdir}/ceph/erasure-code/libec_example.so*
%{_libdir}/ceph/erasure-code/libec_fail_to_initialize.so*
%{_libdir}/ceph/erasure-code/libec_fail_to_register.so*
%{_libdir}/ceph/erasure-code/libec_hangs.so*
%{_libdir}/ceph/erasure-code/libec_jerasure.so*
%{_libdir}/ceph/erasure-code/libec_missing_entry_point.so*
%dir %{_libdir}/rados-classes
# See warning note above about unversioned shared objects here. These belong
# here in -libs (not -devel).
%{_libdir}/rados-classes/libcls_hello.so*
%{_libdir}/rados-classes/libcls_rbd.so*
%{_libdir}/rados-classes/libcls_rgw.so*
%{_libdir}/rados-classes/libcls_lock*
%{_libdir}/rados-classes/libcls_kvs*
%{_libdir}/rados-classes/libcls_refcount*
%{_libdir}/rados-classes/libcls_log*
%{_libdir}/rados-classes/libcls_replica_log*
%{_libdir}/rados-classes/libcls_statelog*
%{_libdir}/rados-classes/libcls_version*
%{_libdir}/rados-classes/libcls_lock.so*
%{_libdir}/rados-classes/libcls_kvs.so*
%{_libdir}/rados-classes/libcls_refcount.so*
%{_libdir}/rados-classes/libcls_log.so*
%{_libdir}/rados-classes/libcls_replica_log.so*
%{_libdir}/rados-classes/libcls_statelog.so*
%{_libdir}/rados-classes/libcls_version.so*
%{_libdir}/rados-classes/libcls_user.so*
%files libcephfs
%doc COPYING
@ -241,12 +262,8 @@ fi
%doc COPYING
%dir %{_includedir}/cephfs
%{_includedir}/cephfs/libcephfs.h
#%dir %{_includedir}/crush
#%{_includedir}/crush/crush.h
#%{_includedir}/crush/hash.h
#%{_includedir}/crush/mapper.h
#%{_includedir}/crush/types.h
%dir %{_includedir}/rados
%{_includedir}/rados/memory.h
%{_includedir}/rados/librados.h
%{_includedir}/rados/librados.hpp
%{_includedir}/rados/rados_types.h
@ -254,14 +271,12 @@ fi
%{_includedir}/rados/buffer.h
%{_includedir}/rados/page.h
%{_includedir}/rados/crc32c.h
#%{_includedir}/rados/librgw.h
%dir %{_includedir}/rbd
%{_includedir}/rbd/librbd.h
%{_includedir}/rbd/librbd.hpp
%{_includedir}/rbd/features.h
%{_libdir}/libcephfs.so
%{_libdir}/librados.so
#%{_libdir}/librgw.so
%{_libdir}/librbd.so
%{_bindir}/librados-config
%{_mandir}/man8/librados-config.8*
@ -273,6 +288,26 @@ fi
%{_sysconfdir}/bash_completion.d/radosgw-admin
%changelog
* Tue May 13 2014 Kaleb S. KEITHLEY <kkeithle[at]redhat.com> - 0.80.1-1
- Update to latest stable upstream release, BZ 1095201
- PIE, _hardened_build, BZ 955174
* Thu Feb 06 2014 Ken Dreyer <ken.dreyer@inktank.com> - 0.72.2-2
- Move plugins from -devel into -libs package (#891993). Thanks Michael
Schwendt.
* Mon Jan 06 2014 Ken Dreyer <ken.dreyer@inktank.com> 0.72.2-1
- Update to latest stable upstream release
- Use HTTPS for URLs
- Submit Automake 1.12 patch upstream
- Move unversioned shared libs from ceph-libs into ceph-devel
* Wed Dec 18 2013 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> 0.67.3-4
- build without tcmalloc on aarch64 (no gperftools)
* Sat Nov 30 2013 Peter Robinson <pbrobinson@fedoraproject.org> 0.67.3-3
- gperftools not currently available on aarch64
* Mon Oct 07 2013 Dan Horák <dan[at]danny.cz> - 0.67.3-2
- fix build on non-x86_64 64-bit arches

View File

@ -1 +1 @@
1d7f697c17cb6f4233994063598d6d6f ceph-0.67.3.tar.bz2
8a37b0affc0aa5c23112eaa89250f836 ceph-0.80.1.tar.bz2