Rebuild for Apache Arrow (libarrow) 14.0.0

Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
This commit is contained in:
Kaleb S. KEITHLEY 2023-11-01 14:40:24 -04:00
parent dae4d4a3ac
commit 1add7973a9
1 changed files with 10 additions and 2 deletions

View File

@ -1,5 +1,5 @@
--- a/src/CMakeLists.txt.orig 2023-11-01 11:53:53.618167190 -0400
+++ b/src/CMakeLists.txt 2023-11-01 11:55:16.944749427 -0400
--- ceph/src/CMakeLists.txt.orig 2023-11-01 11:53:53.618167190 -0400
+++ ceph/src/CMakeLists.txt 2023-11-01 13:52:51.292643490 -0400
@@ -625,6 +625,7 @@
add_subdirectory(perfglue)
@ -8,3 +8,11 @@
option(WITH_LIBRADOSSTRIPER "build with libradosstriper support" ON)
@@ -881,6 +882,7 @@
add_library(krbd STATIC krbd.cc
$<TARGET_OBJECTS:parse_secret_objs>)
target_link_libraries(krbd keyutils::keyutils)
+ add_dependencies(krbd legacy-option-headers)
endif()
add_subdirectory(librbd)
if(WITH_FUSE)