Update to 2.13.5 upstream release
This commit is contained in:
parent
771d2791c9
commit
eac15b0110
1
.gitignore
vendored
1
.gitignore
vendored
@ -47,3 +47,4 @@
|
||||
/catch-2.10.2.tar.gz
|
||||
/catch-2.11.0.tar.gz
|
||||
/catch-2.13.4.tar.gz
|
||||
/catch-2.13.5.tar.gz
|
||||
|
@ -1,32 +0,0 @@
|
||||
commit 5739779a8feb097402e00cb78b9cd7c82b5ed3f1
|
||||
Author: Tom Hughes <tom@compton.nu>
|
||||
Date: Fri Feb 19 10:35:07 2021 +0000
|
||||
|
||||
Patch for non-constant MINSIGSTKSZ
|
||||
|
||||
diff --git a/include/internal/catch_fatal_condition.cpp b/include/internal/catch_fatal_condition.cpp
|
||||
index 1eb6bb87..9ea22537 100644
|
||||
--- a/include/internal/catch_fatal_condition.cpp
|
||||
+++ b/include/internal/catch_fatal_condition.cpp
|
||||
@@ -97,7 +97,7 @@ namespace Catch {
|
||||
|
||||
// 32kb for the alternate stack seems to be sufficient. However, this value
|
||||
// is experimentally determined, so that's not guaranteed.
|
||||
- static constexpr std::size_t sigStackSize = 32768 >= MINSIGSTKSZ ? 32768 : MINSIGSTKSZ;
|
||||
+ static constexpr std::size_t sigStackSize = 32768;
|
||||
|
||||
static SignalDefs signalDefs[] = {
|
||||
{ SIGINT, "SIGINT - Terminal interrupt signal" },
|
||||
diff --git a/single_include/catch2/catch.hpp b/single_include/catch2/catch.hpp
|
||||
index 0384171a..6897dae0 100644
|
||||
--- a/single_include/catch2/catch.hpp
|
||||
+++ b/single_include/catch2/catch.hpp
|
||||
@@ -10819,7 +10819,7 @@ namespace Catch {
|
||||
|
||||
// 32kb for the alternate stack seems to be sufficient. However, this value
|
||||
// is experimentally determined, so that's not guaranteed.
|
||||
- static constexpr std::size_t sigStackSize = 32768 >= MINSIGSTKSZ ? 32768 : MINSIGSTKSZ;
|
||||
+ static constexpr std::size_t sigStackSize = 32768;
|
||||
|
||||
static SignalDefs signalDefs[] = {
|
||||
{ SIGINT, "SIGINT - Terminal interrupt signal" },
|
10
catch.spec
10
catch.spec
@ -1,15 +1,13 @@
|
||||
%global debug_package %{nil}
|
||||
|
||||
Name: catch
|
||||
Version: 2.13.4
|
||||
Release: 3%{?dist}
|
||||
Version: 2.13.5
|
||||
Release: 1%{?dist}
|
||||
Summary: Modern, C++-native, header-only, framework for unit-tests, TDD and BDD
|
||||
|
||||
License: Boost
|
||||
URL: https://github.com/catchorg/Catch2
|
||||
Source0: https://github.com/catchorg/Catch2/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||
# https://github.com/catchorg/Catch2/issues/2178
|
||||
Patch0: catch-minsigstksz.patch
|
||||
|
||||
BuildRequires: cmake make gcc-c++ python3
|
||||
|
||||
@ -55,13 +53,15 @@ rm -rf %{buildroot}/%{_docdir}
|
||||
%doc README.md CODE_OF_CONDUCT.md docs
|
||||
%license LICENSE.txt
|
||||
%{_includedir}/catch2/
|
||||
%{_libdir}/libCatch2WithMain.a
|
||||
%{_datadir}/Catch2/
|
||||
%{_datadir}/pkgconfig/catch2.pc
|
||||
%{_libdir}/cmake/Catch2/
|
||||
|
||||
|
||||
%changelog
|
||||
* Sun Apr 11 2021 Tom Hughes <tom@compton.nu> - 2.13.5-1
|
||||
- Update to 2.13.5 upstream release
|
||||
|
||||
* Fri Feb 19 2021 Tom Hughes <tom@compton.nu> - 2.13.4-3
|
||||
- Add patch for non-constant MINSIGSTKSZ
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (catch-2.13.4.tar.gz) = eac081d750e65d4d8d8d5f32b53bd963c6566caabaff424c479fe080416f59b5387adbdf6dbac30fe265243cb5ed184baf6f8a9625052bd498c098b83463390d
|
||||
SHA512 (catch-2.13.5.tar.gz) = 19283dcf036ea4aa58dcc103b310f110f3a4c176ae2538507d2c3eae48e9460fab9b4d49b6e4929d35301c81f7cdb7905e1da322d56f51bc5869819241b66d41
|
||||
|
Loading…
x
Reference in New Issue
Block a user