Update to 2.1.1 upstream release
This commit is contained in:
parent
bf154f8fac
commit
76c07d117f
1
.gitignore
vendored
1
.gitignore
vendored
@ -24,3 +24,4 @@
|
||||
/catch-1.11.0.tar.gz
|
||||
/catch-1.12.0.tar.gz
|
||||
/catch-2.1.0.tar.gz
|
||||
/catch-2.1.1.tar.gz
|
||||
|
@ -1,21 +0,0 @@
|
||||
commit f0909dfe02df36e70c4c95ed00d53cb3eacf0262
|
||||
Author: Martin Hořeňovský <martin.horenovsky@gmail.com>
|
||||
Date: Sun Jan 14 17:04:36 2018 +0100
|
||||
|
||||
Add yet another expansion of INF macro
|
||||
|
||||
Closes #1151
|
||||
|
||||
diff --git a/scripts/approvalTests.py b/scripts/approvalTests.py
|
||||
index e16f7140..a2ab5d5a 100755
|
||||
--- a/scripts/approvalTests.py
|
||||
+++ b/scripts/approvalTests.py
|
||||
@@ -50,6 +50,8 @@ infParser = re.compile(r'''
|
||||
|
|
||||
\(__builtin_inff\(\)\) # Linux (ubuntu) INFINITY macro
|
||||
|
|
||||
+ \(__builtin_inff\ \(\)\) # Fedora INFINITY macro
|
||||
+ |
|
||||
__builtin_huge_valf\(\) # OSX macro
|
||||
''', re.VERBOSE)
|
||||
nanParser = re.compile(r'''
|
@ -1,44 +0,0 @@
|
||||
commit 07c84adfbaac181560ed79576848fda82da6311b
|
||||
Author: Martin Hořeňovský <martin.horenovsky@gmail.com>
|
||||
Date: Sun Jan 14 18:14:11 2018 +0100
|
||||
|
||||
Allow disabling -Werror in CMake
|
||||
|
||||
Related to #1152
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 0fa91501..e0b2fc19 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -5,6 +5,7 @@ project(CatchSelfTest)
|
||||
option(USE_VALGRIND "Perform SelfTests with Valgrind" OFF)
|
||||
option(BUILD_EXAMPLES "Build documentation examples" OFF)
|
||||
option(ENABLE_COVERAGE "Generate coverage for codecov.io" OFF)
|
||||
+option(DISABLE_WERROR "Do not enable warnings as errors" OFF)
|
||||
|
||||
set_property(GLOBAL PROPERTY USE_FOLDERS ON)
|
||||
|
||||
@@ -309,7 +310,10 @@ if (NOT NO_SELFTEST)
|
||||
|
||||
# Add desired warnings
|
||||
if ( CMAKE_CXX_COMPILER_ID MATCHES "Clang|AppleClang|GNU" )
|
||||
- target_compile_options( SelfTest PRIVATE -Wall -Wextra -Wunreachable-code -Werror )
|
||||
+ target_compile_options( SelfTest PRIVATE -Wall -Wextra -Wunreachable-code )
|
||||
+ if (NOT DISABLE_WERROR)
|
||||
+ target_compile_options( SelfTest PRIVATE -Werror)
|
||||
+ endif()
|
||||
endif()
|
||||
# Clang specific warning go here
|
||||
if ( CMAKE_CXX_COMPILER_ID MATCHES "Clang" )
|
||||
@@ -318,7 +322,10 @@ if (NOT NO_SELFTEST)
|
||||
endif()
|
||||
if ( CMAKE_CXX_COMPILER_ID MATCHES "MSVC" )
|
||||
STRING(REGEX REPLACE "/W[0-9]" "/W4" CMAKE_CXX_FLAGS ${CMAKE_CXX_FLAGS}) # override default warning level
|
||||
- target_compile_options( SelfTest PRIVATE /w44265 /WX /w44061 /w44062 )
|
||||
+ target_compile_options( SelfTest PRIVATE /w44265 /w44061 /w44062 )
|
||||
+ if (NOT DISABLE_WERROR)
|
||||
+ target_compile_options( SelfTest PRIVATE /WX)
|
||||
+ endif()
|
||||
endif()
|
||||
|
||||
|
10
catch.spec
10
catch.spec
@ -1,17 +1,13 @@
|
||||
%global debug_package %{nil}
|
||||
|
||||
Name: catch
|
||||
Version: 2.1.0
|
||||
Version: 2.1.1
|
||||
Release: 1%{?dist}
|
||||
Summary: A modern, C++-native, header-only, framework for unit-tests, TDD and BDD
|
||||
|
||||
License: Boost
|
||||
URL: https://github.com/philsquared/Catch
|
||||
Source0: https://github.com/philsquared/Catch/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||
# https://github.com/catchorg/Catch2/commit/f0909dfe02df36e70c4c95ed00d53cb3eacf0262
|
||||
Patch1: catch-inf.patch
|
||||
# https://github.com/catchorg/Catch2/commit/07c84adfbaac181560ed79576848fda82da6311b
|
||||
Patch2: catch-werror.patch
|
||||
|
||||
BuildRequires: cmake make gcc-c++ python3
|
||||
|
||||
@ -46,6 +42,7 @@ sed -i -e "s|COMMAND python |COMMAND python3 |" CMakeLists.txt
|
||||
|
||||
%install
|
||||
%make_install -Cbuild
|
||||
rm -rf %{buildroot}/%{_docdir}
|
||||
|
||||
|
||||
%check
|
||||
@ -61,6 +58,9 @@ ctest -V %{?_smp_mflags}
|
||||
|
||||
|
||||
%changelog
|
||||
* Sat Jan 27 2018 Tom Hughes <tom@compton.nu> - 2.1.1-1
|
||||
- Update to 2.1.1 upstream release
|
||||
|
||||
* Sun Jan 14 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 2.1.0-1
|
||||
- Update to 2.1.0
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (catch-2.1.0.tar.gz) = 1fa0d1cb607fcb8dec37437fa788868324b0ded8e929138f4167d57bafa567b64955546142699a3e3bd2aeb7d36b7c2c7c426aaf3d68b94bddd43b2f78026fc8
|
||||
SHA512 (catch-2.1.1.tar.gz) = 64947672e614301a45efd812eb3eef98d871c9719005a441b6f6bb1dc26820bd9643ba285bcc0eaef9b212c5ab6ada4a875433c47a020ce436bcc411cdc8ad72
|
||||
|
Loading…
Reference in New Issue
Block a user