This commit is contained in:
Tom Callaway 2012-05-02 10:17:45 -04:00
parent dd6af9b4cb
commit ab2c75f35b
4 changed files with 58 additions and 6 deletions

1
.gitignore vendored
View File

@ -1,3 +1,4 @@
c-ares-1.7.3.tar.gz
/c-ares-1.7.4.tar.gz
/c-ares-1.7.5.tar.gz
/c-ares-1.8.0.tar.gz

View File

@ -0,0 +1,48 @@
--- ares_build.h.in
+++ ares_build.h.in
@@ -96,7 +96,14 @@
#endif
/* The size of `long', as computed by sizeof. */
-#undef CARES_SIZEOF_LONG
+#include <bits/wordsize.h>
+#if __WORDSIZE == 32
+#define CARES_SIZEOF_LONG 4
+#elif __WORDSIZE == 64
+#define CARES_SIZEOF_LONG 8
+#else
+#error "Unknown word size"
+#endif
/* Integral data type used for ares_socklen_t. */
#undef CARES_TYPEOF_ARES_SOCKLEN_T
--- configure.ac
+++ configure.ac
@@ -468,7 +468,6 @@ AC_CHECK_SIZEOF(size_t)
AC_CHECK_SIZEOF(long)
AC_CHECK_SIZEOF(int)
AC_CHECK_SIZEOF(short)
-CARES_CONFIGURE_LONG
AC_CHECK_SIZEOF(time_t)
AC_CHECK_TYPE(long long,
--- configure
+++ configure
@@ -18096,17 +18096,6 @@
_ACEOF
-
- if test -z "$ac_cv_sizeof_long" ||
- test "$ac_cv_sizeof_long" -eq "0"; then
- as_fn_error "cannot find out size of long." "$LINENO" 5
- fi
-
-cat >>confdefs.h <<_EOF
-#define CARES_SIZEOF_LONG $ac_cv_sizeof_long
-_EOF
-
-
# The cast to long int works around a bug in the HP C Compiler
# version HP92453-01 B.11.11.23709.GP, which incorrectly rejects
# declarations like `int a3[[(sizeof (unsigned char)) >= 0]];'.

View File

@ -1,14 +1,14 @@
Summary: A library that performs asynchronous DNS operations
Name: c-ares
Version: 1.7.5
Release: 2%{?dist}
Version: 1.8.0
Release: 1%{?dist}
License: MIT
Group: System Environment/Libraries
URL: http://c-ares.haxx.se/
Source0: http://c-ares.haxx.se/download/%{name}-%{version}.tar.gz
Source1: LICENSE
Patch0: %{name}-1.7.5-optflags.patch
Patch1: c-ares-multilib.patch
Patch1: c-ares-1.8.0-multilib.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -30,7 +30,7 @@ compile applications or shared objects that use c-ares.
%prep
%setup -q
%patch0 -p1 -b .optflags
%patch1 -p1 -b .multilib
%patch1 -p0 -b .multilib
cp %{SOURCE1} .
f=CHANGES ; iconv -f iso-8859-1 -t utf-8 $f -o $f.utf8 ; mv $f.utf8 $f
@ -67,6 +67,10 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man3/ares_*
%changelog
* Sat Apr 28 2012 Tom Callaway <spot@fedoraproject.org> - 1.8.0-1
- update to 1.8.0
- fix multilib patch (thanks to Paul Howarth)
* Thu Jan 12 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.5-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild

View File

@ -1,2 +1 @@
dd71e8f07d9f3c837e12a5416d1b7f73 c-ares-1.7.4.tar.gz
800875fc23cd8e1924d8af9172ed33e7 c-ares-1.7.5.tar.gz
2936494add5663ecc57147cc3c9697f9 c-ares-1.8.0.tar.gz