Update to v0.12.0

This update includes a major restructuring which breaks build2 into a library, libbuild2, and its bundled build module libraries, libbuild-{bash,bin,c,cc,cxx,in,version}. Thus, this also adds libbuild2{,-devel,-static} subpackages and moves some runtime requirements from build2 to the libbuild2 package.

 * .gitignore, build2.spec, sources: Update to v0.12.0
 * build2-libbuild2-buildfile-host_config-config.install.chroot-remove.patch: Upstream patch removing confit.install.chroot from libbuild2 host configuration. This prevents $RPM_BUILD_ROOT from appearing in libbuild2.
This commit is contained in:
Matthew Krupcale 2019-11-20 06:43:16 -05:00
parent b4d4e4f59b
commit 78e723f604
4 changed files with 179 additions and 33 deletions

14
.gitignore vendored
View File

@ -1,7 +1,7 @@
/build2-0.11.0.tar.gz
/libbutl-0.11.0.tar.gz
/libbpkg-0.11.0.tar.gz
/bpkg-0.11.0.tar.gz
/bdep-0.11.0.tar.gz
/libodb-2.5.0-b.15.tar.gz
/libodb-sqlite-2.5.0-b.15.tar.gz
/build2-0.12.0.tar.gz
/libbutl-0.12.0.tar.gz
/libbpkg-0.12.0.tar.gz
/bpkg-0.12.0.tar.gz
/bdep-0.12.0.tar.gz
/libodb-2.5.0-b.17.tar.gz
/libodb-sqlite-2.5.0-b.17.tar.gz

View File

@ -0,0 +1,31 @@
From 0e9bf64dadc029bdf3e97ffb982d297eee0499e4 Mon Sep 17 00:00:00 2001
From: Boris Kolpackov <boris@codesynthesis.com>
Date: Fri, 22 Nov 2019 08:34:19 +0200
Subject: Filter out config.install.chroot from default host configuration
---
libbuild2/buildfile | 8 +++++++-
1 file changed, 7 insertions(+), 1 deletion(-)
diff --git a/libbuild2/buildfile b/libbuild2/buildfile
index 539e4e6..97b9f26 100644
--- a/libbuild2/buildfile
+++ b/libbuild2/buildfile
@@ -52,7 +52,13 @@ config/cxx{host-config}: config/in{host-config}
# Remove comment lines which could be confused with preprocessor directives
# by some lesser compilers.
#
- host_config = $regex.replace_lines($config.save(), '^ *#.*$', [null], return_lines)
+ # Also filter out config.install.chroot -- we definitely don't want it
+ # carried through.
+ #
+ host_config = $regex.replace_lines($config.save(), \
+ '^ *(#|config.install.chroot).*$', \
+ [null], \
+ return_lines)
}
libul{build2}: dist/{hxx ixx txx cxx}{** -**.test...}
--
cgit v0.12

View File

@ -5,8 +5,8 @@
%bcond_with static
Name: build2
Version: 0.11.0
Release: 2%{?dist}
Version: 0.12.0
Release: 1%{?dist}
Summary: Cross-platform build toolchain for developing and packaging C++ code
License: MIT
@ -20,11 +20,14 @@ Source5: macros.%{name}
# The latest official release of libodb is not compatible with build2
%if %{with bundle_libodb}
%global libodb_bundle_version 2.5.0-b.15
%global libodb_bundle_version 2.5.0-b.17
Source100: https://pkg.cppget.org/1/beta/odb/libodb-%{libodb_bundle_version}.tar.gz
Source101: https://pkg.cppget.org/1/beta/odb/libodb-sqlite-%{libodb_bundle_version}.tar.gz
%endif
# Upstream https://git.build2.org/cgit/build2/commit/?id=0e9bf64dadc029bdf3e97ffb982d297eee0499e4
Patch0000: build2-libbuild2-buildfile-host_config-config.install.chroot-remove.patch
BuildRequires: gcc-c++
BuildRequires: libpkgconf-devel
%if %{with bootstrap}
@ -35,34 +38,27 @@ BuildRequires: %{name}
BuildRequires: %{name}-rpm-macros
%endif
%if %{with check}
# build2, bpkg
# libbuild2, bpkg
BuildRequires: bzip2
# install: build2; sha256sum: build2, bpkg, bdep
# install: libbuild2; readlink: libbuild2; sha256sum: bpkg, bdep
BuildRequires: coreutils
# libbutl, build2
# libbuild2, libbutl
BuildRequires: diffutils
%if %{with network_checks}
# libbutl, bpkg, bdep
BuildRequires: curl
%endif
# build2, bpkg, bdep
# libbuild2, bpkg, bdep
BuildRequires: git
# build2, bpkg
# libbuild2, bpkg
BuildRequires: gzip
# libbutl, bpkg
BuildRequires: openssl
# build2, bpkg
# libbuild2, bpkg
BuildRequires: tar
# build2, bpkg
# libbuild2, bpkg
BuildRequires: xz
%endif
Requires: bzip2
Requires: coreutils
Requires: diffutils
Requires: git
Requires: gzip
Requires: tar
Requires: xz
Recommends: %{name}-rpm-macros
%description
@ -86,6 +82,45 @@ BuildArch: noarch
%description -n %{name}-doc
This package contains the %{name} documentation.
%package -n lib%{name}
Summary: %{name} library
# libbuild2-dist
Requires: bzip2
# install: libbuild2-install; readlink: libbuild2-bash
Requires: coreutils
# libbuild2-test
Requires: diffutils
# libbuild2-version
Requires: git
# libbuild2-dist
Requires: gzip
# libbuild2-dist
Requires: tar
# libbuild2-dist
Requires: xz
%description -n lib%{name}
This package contains the %{name} library.
%package -n lib%{name}-devel
Summary: Development files for %{name} library
Requires: lib%{name}%{?_isa} = %{version}-%{release}
Requires: pkgconfig
%description -n lib%{name}-devel
The lib%{name}-devel package contains libraries and header files for
developing applications that use lib%{name}.
%if %{with static}
%package -n lib%{name}-static
Summary: Static libraries for %{name} library
Requires: lib%{name}-devel%{?_isa} = %{version}-%{release}
%description -n lib%{name}-static
The lib%{name}-static package contains static libraries for developing
applications that use lib%{name}.
%endif
%package -n libbutl
Summary: %{name} utility library
# BSD-2 clause:
@ -220,6 +255,9 @@ This package contains the %{name} RPM macros.
%else
%setup -q -c -n %{name}-toolchain-%{version} -a 1 -a 2 -a 3 -a 4 -a 100 -a 101
%endif
pushd build2-%{version}
%patch -p 1 -P 0000
popd
mv libbutl-%{version} %{name}-%{version}
%build
@ -253,6 +291,14 @@ mv libbutl-%{version} %{name}-%{version}
CXX=g++
CXXFLAGS="${CXXFLAGS:-%{build_cxxflags}}"
LDFLAGS="${LDFLAGS:-%{build_ldflags}}"
export LD_LIBRARY_PATH=$PWD/%{name}-%{version}/lib%{name}:${LD_LIBRARY_PATH}
export LD_LIBRARY_PATH=$PWD/%{name}-%{version}/lib%{name}/bash:${LD_LIBRARY_PATH}
export LD_LIBRARY_PATH=$PWD/%{name}-%{version}/lib%{name}/bin:${LD_LIBRARY_PATH}
export LD_LIBRARY_PATH=$PWD/%{name}-%{version}/lib%{name}/c:${LD_LIBRARY_PATH}
export LD_LIBRARY_PATH=$PWD/%{name}-%{version}/lib%{name}/cc:${LD_LIBRARY_PATH}
export LD_LIBRARY_PATH=$PWD/%{name}-%{version}/lib%{name}/cxx:${LD_LIBRARY_PATH}
export LD_LIBRARY_PATH=$PWD/%{name}-%{version}/lib%{name}/in:${LD_LIBRARY_PATH}
export LD_LIBRARY_PATH=$PWD/%{name}-%{version}/lib%{name}/version:${LD_LIBRARY_PATH}
export LD_LIBRARY_PATH=$PWD/%{name}-%{version}/libbutl-%{version}/libbutl:${LD_LIBRARY_PATH}
pushd %{name}-%{version}
# bootstrap, phase 1: minimal build system
@ -368,6 +414,8 @@ for p in %{name} libbutl libbpkg bpkg bdep; do
mkdir -p %{buildroot}%{_defaultlicensedir}/${p}
mv %{buildroot}%{_docdir}/${p}/LICENSE %{buildroot}%{_defaultlicensedir}/${p}
done
mkdir -p %{buildroot}%{_defaultlicensedir}/lib%{name}
cp %{buildroot}%{_defaultlicensedir}/%{name}/LICENSE %{buildroot}%{_defaultlicensedir}/lib%{name}
install -Dpm0644 %{SOURCE5} %{buildroot}%{_rpmmacrodir}/macros.%{name}
%check
@ -375,6 +423,14 @@ install -Dpm0644 %{SOURCE5} %{buildroot}%{_rpmmacrodir}/macros.%{name}
export PATH=$PWD/bpkg-%{version}/bpkg:$PATH
export PATH=$PWD/%{name}-%{version}/build2:$PATH
export LD_LIBRARY_PATH=$PWD/libbpkg-%{version}/libbpkg:${LD_LIBRARY_PATH}
export LD_LIBRARY_PATH=$PWD/%{name}-%{version}/lib%{name}:${LD_LIBRARY_PATH}
export LD_LIBRARY_PATH=$PWD/%{name}-%{version}/lib%{name}/bash:${LD_LIBRARY_PATH}
export LD_LIBRARY_PATH=$PWD/%{name}-%{version}/lib%{name}/bin:${LD_LIBRARY_PATH}
export LD_LIBRARY_PATH=$PWD/%{name}-%{version}/lib%{name}/c:${LD_LIBRARY_PATH}
export LD_LIBRARY_PATH=$PWD/%{name}-%{version}/lib%{name}/cc:${LD_LIBRARY_PATH}
export LD_LIBRARY_PATH=$PWD/%{name}-%{version}/lib%{name}/cxx:${LD_LIBRARY_PATH}
export LD_LIBRARY_PATH=$PWD/%{name}-%{version}/lib%{name}/in:${LD_LIBRARY_PATH}
export LD_LIBRARY_PATH=$PWD/%{name}-%{version}/lib%{name}/version:${LD_LIBRARY_PATH}
export LD_LIBRARY_PATH=$PWD/%{name}-%{version}/libbutl-%{version}/libbutl:${LD_LIBRARY_PATH}
b test: \
%{name}-%{version}/libbutl-%{version}/ \
@ -391,6 +447,7 @@ b test:
%dir %{_defaultlicensedir}/%{name}
%dir %{_docdir}/%{name}
%license %{_defaultlicensedir}/%{name}/LICENSE
%doc %{_docdir}/%{name}/CONTRIBUTING.md
%doc %{_docdir}/%{name}/NEWS
%doc %{_docdir}/%{name}/README
%{_bindir}/b
@ -402,14 +459,66 @@ b test:
%doc %{_docdir}/%{name}/b.xhtml
%doc %{_docdir}/%{name}/manifest
%files -n lib%{name}
%dir %{_defaultlicensedir}/lib%{name}
%license %{_defaultlicensedir}/lib%{name}/LICENSE
%{_libdir}/lib%{name}-0.12.so
%{_libdir}/lib%{name}-bash-0.12-0.12.so
%{_libdir}/lib%{name}-bin-0.12-0.12.so
%{_libdir}/lib%{name}-c-0.12-0.12.so
%{_libdir}/lib%{name}-cc-0.12-0.12.so
%{_libdir}/lib%{name}-cxx-0.12-0.12.so
%{_libdir}/lib%{name}-in-0.12-0.12.so
%{_libdir}/lib%{name}-version-0.12-0.12.so
%files -n lib%{name}-devel
%{_includedir}/lib%{name}
%{_libdir}/lib%{name}.so
%{_libdir}/lib%{name}-bash{,-0.12}.so
%{_libdir}/lib%{name}-bin{,-0.12}.so
%{_libdir}/lib%{name}-c{,-0.12}.so
%{_libdir}/lib%{name}-cc{,-0.12}.so
%{_libdir}/lib%{name}-cxx{,-0.12}.so
%{_libdir}/lib%{name}-in{,-0.12}.so
%{_libdir}/lib%{name}-version{,-0.12}.so
%{_libdir}/pkgconfig/lib%{name}.shared.pc
%{_libdir}/pkgconfig/lib%{name}-bash.shared.pc
%{_libdir}/pkgconfig/lib%{name}-bin.shared.pc
%{_libdir}/pkgconfig/lib%{name}-c.shared.pc
%{_libdir}/pkgconfig/lib%{name}-cc.shared.pc
%{_libdir}/pkgconfig/lib%{name}-cxx.shared.pc
%{_libdir}/pkgconfig/lib%{name}-in.shared.pc
%{_libdir}/pkgconfig/lib%{name}-version.shared.pc
%if %{with static}
%files -n lib%{name}-static
%{_libdir}/lib%{name}.a
%{_libdir}/lib%{name}-bash.a
%{_libdir}/lib%{name}-bin.a
%{_libdir}/lib%{name}-c.a
%{_libdir}/lib%{name}-cc.a
%{_libdir}/lib%{name}-cxx.a
%{_libdir}/lib%{name}-in.a
%{_libdir}/lib%{name}-version.a
%{_libdir}/pkgconfig/lib%{name}.static.pc
%{_libdir}/pkgconfig/lib%{name}-bash.static.pc
%{_libdir}/pkgconfig/lib%{name}-bin.static.pc
%{_libdir}/pkgconfig/lib%{name}-c.static.pc
%{_libdir}/pkgconfig/lib%{name}-cc.static.pc
%{_libdir}/pkgconfig/lib%{name}-cxx.static.pc
%{_libdir}/pkgconfig/lib%{name}-in.static.pc
%{_libdir}/pkgconfig/lib%{name}-version.static.pc
%endif
%files -n libbutl
%dir %{_defaultlicensedir}/libbutl
%license %{_defaultlicensedir}/libbutl/LICENSE
%{_libdir}/libbutl-0.11.so
%{_libdir}/libbutl-0.12.so
%files -n libbutl-devel
%dir %{_docdir}/libbutl
%doc %{_docdir}/libbutl/manifest
%doc %{_docdir}/libbutl/CONTRIBUTING.md
%doc %{_docdir}/libbutl/NEWS
%doc %{_docdir}/libbutl/README
%{_includedir}/libbutl
@ -425,11 +534,12 @@ b test:
%files -n libbpkg
%dir %{_defaultlicensedir}/libbpkg
%license %{_defaultlicensedir}/libbpkg/LICENSE
%{_libdir}/libbpkg-0.11.so
%{_libdir}/libbpkg-0.12.so
%files -n libbpkg-devel
%dir %{_docdir}/libbpkg
%doc %{_docdir}/libbpkg/manifest
%doc %{_docdir}/libbpkg/CONTRIBUTING.md
%doc %{_docdir}/libbpkg/NEWS
%doc %{_docdir}/libbpkg/README
%{_includedir}/libbpkg
@ -446,6 +556,7 @@ b test:
%dir %{_defaultlicensedir}/bpkg
%dir %{_docdir}/bpkg
%license %{_defaultlicensedir}/bpkg/LICENSE
%doc %{_docdir}/bpkg/CONTRIBUTING.md
%doc %{_docdir}/bpkg/NEWS
%doc %{_docdir}/bpkg/README
%{_bindir}/bpkg
@ -462,6 +573,7 @@ b test:
%dir %{_defaultlicensedir}/bdep
%dir %{_docdir}/bdep
%license %{_defaultlicensedir}/bdep/LICENSE
%doc %{_docdir}/bdep/CONTRIBUTING.md
%doc %{_docdir}/bdep/NEWS
%doc %{_docdir}/bdep/README
%{_bindir}/bdep
@ -477,6 +589,9 @@ b test:
%{_rpmmacrodir}/macros.%{name}
%changelog
* Wed Nov 20 2019 Matthew Krupcale <mkrupcale@matthewkrupcale.com> - 0.12.0-1
- Update to v0.12.0
* Wed Jul 24 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.11.0-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild

14
sources
View File

@ -1,7 +1,7 @@
SHA512 (build2-0.11.0.tar.gz) = e84ad21f318cb34c86c148164ba873f14c7cce9f5efca89d45dd8198af752eaebc4f3b702ba38757d7312f00285da21681b7820a0bab7a9028b074fe508f93e7
SHA512 (libbutl-0.11.0.tar.gz) = c954a317d3eb5c57ccf7d86a52a0f4548b142d319ea6b27d45af8de6211487854e8e61e6a45ddcf940b87332c0478e5b550dcadb2fbca85e4d59cea8510a07b3
SHA512 (libbpkg-0.11.0.tar.gz) = 1a85edad2016db67c7ea4d37fc5c01cd0d346a464154d2459f5c078d6cddf8ad520e64ae830db2cd131b86787e1e8a0ff526677c573524db74d9dbe1c63fb0b3
SHA512 (bpkg-0.11.0.tar.gz) = bb11d602f67a9876655ff4c03ad7c221032f0c0ca979f35cc4e5ec1a3561fc9b705f23e9190b9564edd09dc34b1be3a8be4bbe94b9d979b470006ae1a72997c5
SHA512 (bdep-0.11.0.tar.gz) = 5a89eac0338e1903208a55e6e7dcf5c3fd4baaa57fa9a02fd51cfd8ef21ba8d5267d61d7b5b411bb9179c69e58467894bab1406717fdd4e8af529aa3d5d9fcb9
SHA512 (libodb-2.5.0-b.15.tar.gz) = 658e8c1e820ed720a515e9b1486384284f3ae031bf1166d1a36cc78c6224db3d1e789bb20ea26ed21524c552d61292c21743b80aee51acf789fd8477edf7decc
SHA512 (libodb-sqlite-2.5.0-b.15.tar.gz) = 62f1956325f412cc28dad28945f6428ed2803487c8071e8243c169c9ef134bbfe4e55a601e22500bbef1fb4efad7bf318b7b2587ec31dcfc9f514b8da0f018c5
SHA512 (build2-0.12.0.tar.gz) = e5542d7662a09ec54fcab77a5533d777b785db7286d6c6380dc3229d3e2e234ac3292c5584990cde69378470014f629d8c2f5245804735bb11e828fdd6ef8f79
SHA512 (libbutl-0.12.0.tar.gz) = edc2764ad0e8eb9c502016a84c58348617b987b66464a4f4190732baeab80eec8d1631d005560733dcac10c1e9edec7079b70e296e5121875af3fe13dbaefa07
SHA512 (libbpkg-0.12.0.tar.gz) = 1a863e78f0cdeda0790b0ff4d4c466795e5489f47a873e9b33c14e132344ea67d36b7f809f89c57498d72ff4cf2dc85f9b85d332f1988387838a3ee6d30e019b
SHA512 (bpkg-0.12.0.tar.gz) = 107de755a2fa0a6e1cafd5fea94d680a716610c01bb9793ac6bea795d1a3f086be0af950ad2c74333748c34ec87cbb12ff32a5749a4598bff191862dd638b02f
SHA512 (bdep-0.12.0.tar.gz) = 767ae0f1fbf398712aaef2be1dd126413ad5805991873f2845a7633ca7c14d05e47cb4e4c504b4aeaa9f1904e0f4dbf30b7572a251f69321356a457e04a82e71
SHA512 (libodb-2.5.0-b.17.tar.gz) = f1b414e7271a8a7fe83de8894584b2f347818695d40437500e8f6dca6fc7c8ec098619d4d825bd2680fe0987439fe01a0ab6787c64d233ed0a94bf3222f1fb4f
SHA512 (libodb-sqlite-2.5.0-b.17.tar.gz) = eb447b7833a1ee3f6db337ceac3e0b40da60e2f9b93b1f4d4bd3d67a8165830bb0394d96d41a89622799cfdc8072ba68d17a859186a9bb1e167053a8355fd170