Updating to version 2.0.1

- New recipes
- Bugfixes that may or may not be logged upstream,
- Improved recipe creation logic
- SQL backend option
This commit is contained in:
Pete Travis 2013-08-03 14:10:14 -06:00
parent 0f19c2dfad
commit 407a99b709
6 changed files with 20 additions and 47 deletions

2
.gitignore vendored
View File

@ -1 +1,3 @@
/brewtarget_1.2.5.orig.tar.gz
/brewtarget_2.0.1.orig.tar.gz
/0001-unversioned-docdirs.patch

View File

@ -1,9 +0,0 @@
--- brewtarget-1.2.5/brewtarget.desktop.in.orig 2012-07-14 11:49:41.000000000 -0600
+++ brewtarget-1.2.5/brewtarget.desktop.in 2012-11-12 18:09:36.665509887 -0700
@@ -1,5 +1,5 @@
[Desktop Entry]
-Categories=Qt;KDE;Education;Utility;Engineering
+Categories=Qt;KDE;Education;Utility;Engineering;
Exec=brewtarget
Name=Brewtarget
GenericName=Beer calculator

View File

@ -1,11 +0,0 @@
--- brewtarget-1.2.5/CMakeLists.txt.orig 2012-07-14 11:49:41.000000000 -0600
+++ brewtarget-1.2.5/CMakeLists.txt 2012-11-12 17:56:52.131360768 -0700
@@ -139,7 +139,7 @@
IF( UNIX AND NOT APPLE )
SET( DATAPATH "${DATAROOTDIR}/${CMAKE_PROJECT_NAME}" )
SET( TARGETPATH ${BINDIR} )
- SET( DOCPATH ${DOCDIR} )
+ SET( DOCPATH ${DOCDIR}-${brewtarget_VERSION_STRING} )
ELSEIF( WIN32 )
# Works for regular "make install", but not CPack/NSIS installer.
#SET( CMAKE_INSTALL_PREFIX "C:/Program Files/brewtarget-${brewtarget_VERSION_STRING}" )

View File

@ -1,13 +0,0 @@
--- brewtarget-1.2.5/src/brewtarget.cpp.orig 2012-11-12 23:00:51.379511289 -0700
+++ brewtarget-1.2.5/src/brewtarget.cpp 2012-11-12 23:01:45.379472819 -0700
@@ -112,8 +112,8 @@
{
QMessageBox::information(0,
QObject::tr("Directory Problem"),
- QObject::tr("\"%1\" cannot be read.").arg(dir.path()));
- return false;
+ QObject::tr("\"%1\" cannot be read. Manual will not be available.").arg(dir.path()));
+ return true;
}
dir.setPath(getConfigDir(&success));

View File

@ -1,24 +1,20 @@
Name: brewtarget
Version: 1.2.5
Release: 6%{?dist}
Version: 2.0.1
Release: 2%{?dist}
Summary: An open source beer recipe creation tool
Group: Applications/Productivity
License: GPLv3 and WTFPL and LGPLv2
URL: http://www.brewtarget.org
Source0: http://sourceforge.net/projects/brewtarget/files/brewtarget/1.2/%{version}/brewtarget_%{version}.orig.tar.gz
# Reported upstream at https://sourceforge.net/tracker/?func=detail&aid=3586479&group_id=249733&atid=1126483
Patch0: brewtarget.desktopsemicolon.patch
# Reported upstream at https://sourceforge.net/tracker/?func=detail&aid=3586539&group_id=249733&atid=1126483
Patch1: brewtarget.docdirfix.patch
# emailed upstream Nov 12 2012
Patch2: brewtarget.functionwithoutdocs.patch
Source0: https://launchpad.net/brewtarget/trunk/%{version}/+download/brewtarget_%{version}.orig.tar.gz
%if 0%{?fedora} && 0%{?fedora} >= 20
Patch0: https://gitorious.org/~immanetize/brewtarget/immanetizes-brewtarget-redhat-packaging/blobs/raw/master/0001-unversioned-docdirs.patch
%endif
BuildRequires: cmake
BuildRequires: qt-devel
BuildRequires: qt-webkit-devel
BuildRequires: phonon-devel
BuildRequires: desktop-file-utils
BuildRequires: sqlite
%description
Brewtarget is an open source beer recipe creation tool. It automatically
calculates color, bitterness, and other parameters for you while you drag and
@ -28,9 +24,11 @@ It also can export and import recipes in BeerXML.
%prep
%setup -q
%if 0%{?fedora} && 0%{?fedora} >= 20
%patch0 -p1
%patch1 -p1
%patch2 -p1
%endif
#%patch1 -p1
#%patch2 -p1
%build
%cmake -DDO_RELEASE_BUILD:BOOL=ON
@ -53,6 +51,11 @@ desktop-file-validate %buildroot%{_datadir}/applications/%{name}.desktop
%changelog
* Sat Aug 03 2013 Pete Travis <immanetize@fedoraproject.org> - 2.0.1-2
- Update to version 2.0.1
- Removing patches where integrated upstream
- patch for unversioned docdirs on Fedora releases >= 20
* Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.5-6
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild

View File

@ -1 +1,2 @@
6122f2358beda23f1da4fbe2f4909b24 brewtarget_1.2.5.orig.tar.gz
a956fd28fe80583d72d60004e156b511 brewtarget_2.0.1.orig.tar.gz
494db2a5161a3b76936a9350a56edc89 0001-unversioned-docdirs.patch