Update to 0.2.4

This commit is contained in:
Davide Cavalca 2023-08-23 13:14:04 -07:00
parent 4a58e4dc1c
commit cc7636b870
4 changed files with 66 additions and 60 deletions

1
.gitignore vendored
View File

@ -1 +1,2 @@
/box64-0.2.2.tar.gz
/box64-0.2.4.tar.gz

View File

@ -1,56 +0,0 @@
From 6ff68849f88cbec622fe7a485e301111319ab8d6 Mon Sep 17 00:00:00 2001
From: ptitSeb <sebastien.chev@gmail.com>
Date: Sun, 26 Mar 2023 10:13:45 +0200
Subject: [PATCH] |CMAKE] Added NO_LIB_INSTALL to not install x86_64 libs (they
will probably need to be installed by some other mean)
---
CMakeLists.txt | 14 ++++++++++----
1 file changed, 10 insertions(+), 4 deletions(-)
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4b131d097..433c29ed8 100755
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -75,6 +75,7 @@ option(PAGE8K "Set to ON if host device have PageSize of 8K (instead of 4K)" ${P
option(PAGE16K "Set to ON if host device have PageSize of 16K (instead of 4K)" ${PAGE16K})
option(PAGE64K "Set to ON if host device have PageSize of 64K (instead of 4K)" ${PAGE64K})
option(STATICBUILD "Set to ON to have a static build (Warning, not working)" ${STATICBUILD})
+option(NO_LIB_INSTALL "Set ON to not install a few x86_64 libs that are used by many program" ${NO_LIB_INSTALL})
if(${CMAKE_VERSION} VERSION_LESS "3.12.2")
find_package(PythonInterp 3)
@@ -716,6 +717,7 @@ endif()
string(COMPARE EQUAL "${CMAKE_HOST_SYSTEM_PROCESSOR}" "i686" _x86)
string(COMPARE EQUAL "${CMAKE_HOST_SYSTEM_PROCESSOR}" "x86_64" _x86_64)
string(COMPARE EQUAL "${CMAKE_HOST_SYSTEM_PROCESSOR}" "aarch64" _aarch64)
+string(COMPARE EQUAL "${CMAKE_HOST_SYSTEM_PROCESSOR}" "riscv64" _riscv64)
if(_x86_64 OR _aarch64)
add_definitions(-DCONFIG_64BIT)
@@ -726,10 +728,12 @@ if(NOT _x86 AND NOT _x86_64)
RUNTIME DESTINATION bin)
configure_file(system/box64.conf.cmake system/box64.conf)
install(FILES ${CMAKE_BINARY_DIR}/system/box64.conf DESTINATION /etc/binfmt.d/)
- install(FILES ${CMAKE_SOURCE_DIR}/x64lib/libstdc++.so.5 DESTINATION /usr/lib/x86_64-linux-gnu/)
- install(FILES ${CMAKE_SOURCE_DIR}/x64lib/libstdc++.so.6 DESTINATION /usr/lib/x86_64-linux-gnu/)
- install(FILES ${CMAKE_SOURCE_DIR}/x64lib/libgcc_s.so.1 DESTINATION /usr/lib/x86_64-linux-gnu/)
- install(FILES ${CMAKE_SOURCE_DIR}/x64lib/libpng12.so.0 DESTINATION /usr/lib/x86_64-linux-gnu/)
+ if(NOT NO_LIB_INSTALL)
+ install(FILES ${CMAKE_SOURCE_DIR}/x64lib/libstdc++.so.5 DESTINATION /usr/lib/x86_64-linux-gnu/)
+ install(FILES ${CMAKE_SOURCE_DIR}/x64lib/libstdc++.so.6 DESTINATION /usr/lib/x86_64-linux-gnu/)
+ install(FILES ${CMAKE_SOURCE_DIR}/x64lib/libgcc_s.so.1 DESTINATION /usr/lib/x86_64-linux-gnu/)
+ install(FILES ${CMAKE_SOURCE_DIR}/x64lib/libpng12.so.0 DESTINATION /usr/lib/x86_64-linux-gnu/)
+ endif()
install(FILES ${CMAKE_SOURCE_DIR}/system/box64.box64rc DESTINATION /etc/)
endif()
@@ -764,6 +768,8 @@ set(CPACK_PACKAGE_VERSION_PATCH ${BOX64_REVISION})
set(CPACK_DEBIAN_PACKAGE_CONTROL_EXTRA "${CMAKE_CURRENT_SOURCE_DIR}/postinst")
if(_aarch64)
set(CPACK_DEBIAN_PACKAGE_ARCHITECTURE "arm64")
+elseif(__riscv64)
+ set(CPACK_DEBIAN_PACKAGE_ARCHITECTURE "riscv64")
elseif(_x86_64)
set(CPACK_DEBIAN_PACKAGE_ARCHITECTURE "x86_64")
else()

View File

@ -8,15 +8,13 @@ Box64 lets you run x86_64 Linux programs (such as games) on non-x86_64 Linux
systems, like ARM (host system needs to be 64-bit little-endian).}
Name: box64
Version: 0.2.2
Version: 0.2.4
Release: %autorelease
Summary: Linux userspace x86_64 emulator with a twist, targeted at ARM64
License: MIT
URL: https://box86.org
Source: %{forgeurl}/archive/v%{version}/%{name}-%{version}.tar.gz
# cmake: Added NO_LIB_INSTALL to not install x86_64 libs
Patch: %{forgeurl}/commit/6ff68849f88cbec622fe7a485e301111319ab8d6.patch
BuildRequires: cmake
BuildRequires: gcc
@ -75,6 +73,17 @@ Requires(postun): %{_sbindir}/update-alternatives
This package contains a version of box64 targeting ODROID-N2/N2+ systems.
%package rk3326
Summary: %{summary}
Requires: %{name}-data = %{version}-%{release}
Requires(post): %{_sbindir}/update-alternatives
Requires(postun): %{_sbindir}/update-alternatives
%description rk3326 %{common_description}
This package contains a version of box64 targeting Rockchip RK3326 systems.
%package rk3399
Summary: %{summary}
@ -132,6 +141,18 @@ Requires(postun): %{_sbindir}/update-alternatives
This package contains a version of box64 targeting Qualcomm Snapdragon 845
systems.
%package sd888
Summary: %{summary}
Requires: %{name}-data = %{version}-%{release}
Requires(post): %{_sbindir}/update-alternatives
Requires(postun): %{_sbindir}/update-alternatives
%description sd888 %{common_description}
This package contains a version of box64 targeting Qualcomm Snapdragon 888
systems.
%package tegrax1
Summary: %{summary}
@ -178,6 +199,12 @@ rm -r %{__cmake_builddir}
cp -p %{__cmake_builddir}/%{name} %{name}.odroidn2
rm -r %{__cmake_builddir}
# Rockchip RK3326
%cmake %{common_flags} -DRK3326=ON
%cmake_build
cp -p %{__cmake_builddir}/%{name} %{name}.rk3326
rm -r %{__cmake_builddir}
# Rockchip RK3399
%cmake %{common_flags} -DRK3399=ON
%cmake_build
@ -208,6 +235,12 @@ rm -r %{__cmake_builddir}
cp -p %{__cmake_builddir}/%{name} %{name}.sd845
rm -r %{__cmake_builddir}
# Qualcomm Snapdragon 888
%cmake %{common_flags} -DSD888=ON
%cmake_build
cp -p %{__cmake_builddir}/%{name} %{name}.sd888
rm -r %{__cmake_builddir}
# Nvidia Tegra X1
%cmake %{common_flags} -DTEGRAX1=ON
%cmake_build
@ -249,11 +282,13 @@ install -Dpm0755 -t %{buildroot}%{_bindir} \
%{name}.asahi \
%{name}.lx2160a \
%{name}.odroidn2 \
%{name}.rk3326 \
%{name}.rk3399 \
%{name}.rk3588 \
%{name}.rpi3 \
%{name}.rpi4 \
%{name}.sd845 \
%{name}.sd888 \
%{name}.tegrax1
%post
@ -292,6 +327,15 @@ if [ $1 -eq 0 ] ; then
%{_sbindir}/update-alternatives --remove %{name} %{_bindir}/%{name}.odroidn2
fi
%post rk3326
%{_sbindir}/update-alternatives --install %{_bindir}/%{name} \
%{name} %{_bindir}/%{name}.rk3326 10
%postun rk3326
if [ $1 -eq 0 ] ; then
%{_sbindir}/update-alternatives --remove %{name} %{_bindir}/%{name}.rk3326
fi
%post rk3399
%{_sbindir}/update-alternatives --install %{_bindir}/%{name} \
%{name} %{_bindir}/%{name}.rk3399 10
@ -337,6 +381,15 @@ if [ $1 -eq 0 ] ; then
%{_sbindir}/update-alternatives --remove %{name} %{_bindir}/%{name}.sd845
fi
%post sd888
%{_sbindir}/update-alternatives --install %{_bindir}/%{name} \
%{name} %{_bindir}/%{name}.sd888 10
%postun sd888
if [ $1 -eq 0 ] ; then
%{_sbindir}/update-alternatives --remove %{name} %{_bindir}/%{name}.sd888
fi
%post tegrax1
%{_sbindir}/update-alternatives --install %{_bindir}/%{name} \
%{name} %{_bindir}/%{name}.tegrax1 10
@ -373,6 +426,10 @@ fi
%ghost %{_bindir}/%{name}
%{_bindir}/%{name}.odroidn2
%files rk3326
%ghost %{_bindir}/%{name}
%{_bindir}/%{name}.rk3326
%files rk3399
%ghost %{_bindir}/%{name}
%{_bindir}/%{name}.rk3399
@ -393,6 +450,10 @@ fi
%ghost %{_bindir}/%{name}
%{_bindir}/%{name}.sd845
%files sd888
%ghost %{_bindir}/%{name}
%{_bindir}/%{name}.sd888
%files tegrax1
%ghost %{_bindir}/%{name}
%{_bindir}/%{name}.tegrax1

View File

@ -1 +1 @@
SHA512 (box64-0.2.2.tar.gz) = 3213e112aad44118209733960523d459bf74a07b7a1cc1b1b86d5938af2052fc298c8d2b28237cd7186751bdfcf791741a82fdf461c02b58f7e98461b794ef95
SHA512 (box64-0.2.4.tar.gz) = 8811497934dbc9ea64bae1f26ebea35be2f2d32fbbe14376f689398c80dab77691e9f9ab931382be2501c97acf6d468089803c39845d91bc3d976deef2ea0dd4