Fix FTBFS on F35 and later.
This commit is contained in:
parent
acb4309eee
commit
e3ac435d6f
38
botan-1.10.17-doc-conf-2to3.patch
Normal file
38
botan-1.10.17-doc-conf-2to3.patch
Normal file
@ -0,0 +1,38 @@
|
|||||||
|
diff -up Botan-1.10.17/doc/conf.py.orig Botan-1.10.17/doc/conf.py
|
||||||
|
--- Botan-1.10.17/doc/conf.py.orig 2017-10-02 08:00:00.000000000 +0200
|
||||||
|
+++ Botan-1.10.17/doc/conf.py 2021-09-11 17:57:38.159934955 +0200
|
||||||
|
@@ -40,10 +40,10 @@ version.
|
||||||
|
def check_sphinx_version():
|
||||||
|
import sphinx
|
||||||
|
|
||||||
|
- version = map(int, sphinx.__version__.split('.'))
|
||||||
|
+ version = list(map(int, sphinx.__version__.split('.')))
|
||||||
|
if version[0] == 1 and version[1] == 0 and version[2] < 7:
|
||||||
|
# Exit rather than throwing to avoid a confusing backtrace
|
||||||
|
- print "This Sphinx is too old - upgrade to at least 1.0.7"
|
||||||
|
+ print("This Sphinx is too old - upgrade to at least 1.0.7")
|
||||||
|
import sys
|
||||||
|
sys.exit(1)
|
||||||
|
|
||||||
|
@@ -66,8 +66,8 @@ source_suffix = '.txt'
|
||||||
|
master_doc = 'contents'
|
||||||
|
|
||||||
|
# General information about the project.
|
||||||
|
-project = u'botan'
|
||||||
|
-copyright = u'2000-2011, Jack Lloyd'
|
||||||
|
+project = 'botan'
|
||||||
|
+copyright = '2000-2011, Jack Lloyd'
|
||||||
|
|
||||||
|
# The version info for the project you're documenting, acts as replacement for
|
||||||
|
# |version| and |release|, also used in various other places throughout the
|
||||||
|
@@ -214,8 +214,8 @@ htmlhelp_basename = 'botandoc'
|
||||||
|
# Grouping the document tree into LaTeX files. List of tuples
|
||||||
|
# (source start file, target name, title, author, documentclass [howto/manual]).
|
||||||
|
latex_documents = [
|
||||||
|
- ('contents', 'botan.tex', u'botan Reference Manual',
|
||||||
|
- u'Jack Lloyd', 'manual'),
|
||||||
|
+ ('contents', 'botan.tex', 'botan Reference Manual',
|
||||||
|
+ 'Jack Lloyd', 'manual'),
|
||||||
|
]
|
||||||
|
|
||||||
|
# The name of an image file (relative to this directory) to place at the top of
|
13
botan.spec
13
botan.spec
@ -2,7 +2,7 @@
|
|||||||
|
|
||||||
Name: botan
|
Name: botan
|
||||||
Version: %{major_version}.17
|
Version: %{major_version}.17
|
||||||
Release: 27%{?dist}
|
Release: 28%{?dist}
|
||||||
Summary: Crypto library written in C++
|
Summary: Crypto library written in C++
|
||||||
|
|
||||||
License: BSD
|
License: BSD
|
||||||
@ -17,6 +17,8 @@ Patch0: botan-1.10.5-ecc-fix.patch
|
|||||||
Patch1: botan-boost_python.patch
|
Patch1: botan-boost_python.patch
|
||||||
# Fix wrong path
|
# Fix wrong path
|
||||||
Patch2: botan-1.10.13-python-init.patch
|
Patch2: botan-1.10.13-python-init.patch
|
||||||
|
# 2to3 doc/conf.py
|
||||||
|
Patch3: botan-1.10.17-doc-conf-2to3.patch
|
||||||
|
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
BuildRequires: python3
|
BuildRequires: python3
|
||||||
@ -25,7 +27,7 @@ BuildRequires: python3-sphinx
|
|||||||
BuildRequires: boost-python3-devel
|
BuildRequires: boost-python3-devel
|
||||||
BuildRequires: bzip2-devel
|
BuildRequires: bzip2-devel
|
||||||
BuildRequires: zlib-devel
|
BuildRequires: zlib-devel
|
||||||
BuildRequires: make
|
BuildRequires: make
|
||||||
|
|
||||||
# do not check .so files in the python_sitelib directories
|
# do not check .so files in the python_sitelib directories
|
||||||
%global __provides_exclude_from ^(%{python3_sitearch}/.*\\.so)$
|
%global __provides_exclude_from ^(%{python3_sitearch}/.*\\.so)$
|
||||||
@ -78,9 +80,7 @@ interfaces may change in the future.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n Botan-%{version}
|
%setup -q -n Botan-%{version}
|
||||||
%patch0 -p1 -b .eccfix
|
%autosetup -p1 -n Botan-%{version}
|
||||||
%patch1 -p1
|
|
||||||
%patch2 -p1
|
|
||||||
|
|
||||||
# These tests will fail.
|
# These tests will fail.
|
||||||
rm -rf checks/ec_tests.cpp
|
rm -rf checks/ec_tests.cpp
|
||||||
@ -193,6 +193,9 @@ LD_LIBRARY_PATH=%{buildroot}%{_libdir} ./check --validate
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Sep 11 2021 Thomas Moschny <thomas.moschny@gmx.de> - 1.10.17-28
|
||||||
|
- Fix FTBFS on F35 and later.
|
||||||
|
|
||||||
* Fri Aug 06 2021 Jonathan Wakely <jwakely@redhat.com> - 1.10.17-27
|
* Fri Aug 06 2021 Jonathan Wakely <jwakely@redhat.com> - 1.10.17-27
|
||||||
- Rebuilt for Boost 1.76
|
- Rebuilt for Boost 1.76
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user