Update to 1.10.16.
This commit is contained in:
parent
1b5794187d
commit
c5907002c3
16
botan-avoid-gcc7-miscompilation.patch
Normal file
16
botan-avoid-gcc7-miscompilation.patch
Normal file
@ -0,0 +1,16 @@
|
||||
diff -up Botan-1.10.16/src/hash/gost_3411/gost_3411.cpp.orig Botan-1.10.16/src/hash/gost_3411/gost_3411.cpp
|
||||
--- Botan-1.10.16/src/hash/gost_3411/gost_3411.cpp.orig 2017-04-05 03:06:45.000000000 +0200
|
||||
+++ Botan-1.10.16/src/hash/gost_3411/gost_3411.cpp 2017-08-13 16:29:34.720567939 +0200
|
||||
@@ -90,8 +90,11 @@ void GOST_34_11::compress_n(const byte i
|
||||
|
||||
// P transformation
|
||||
for(size_t k = 0; k != 4; ++k)
|
||||
+ {
|
||||
+ const uint64_t UVk = U[k] ^ V[k];
|
||||
for(size_t l = 0; l != 8; ++l)
|
||||
- key[4*l+k] = get_byte(l, U[k]) ^ get_byte(l, V[k]);
|
||||
+ key[4*l+k] = get_byte(l, UVk);
|
||||
+ }
|
||||
|
||||
cipher.set_key(key, 32);
|
||||
cipher.encrypt(&hash[8*j], S + 8*j);
|
12
botan.spec
12
botan.spec
@ -5,8 +5,8 @@
|
||||
%endif
|
||||
|
||||
Name: botan
|
||||
Version: %{major_version}.14
|
||||
Release: 10%{?dist}
|
||||
Version: %{major_version}.16
|
||||
Release: 1%{?dist}
|
||||
Summary: Crypto library written in C++
|
||||
|
||||
Group: System Environment/Libraries
|
||||
@ -24,6 +24,8 @@ Patch2: botan-1.10.5-ecc-fix.patch
|
||||
Patch3: botan-boost_python.patch
|
||||
# Fix wrong path
|
||||
Patch4: botan-1.10.13-python-init.patch
|
||||
# See https://github.com/randombit/botan/issues/882
|
||||
Patch5: botan-avoid-gcc7-miscompilation.patch
|
||||
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: python2
|
||||
@ -35,7 +37,7 @@ BuildRequires: python3-devel
|
||||
BuildRequires: boost-python3-devel
|
||||
%endif # with_python3
|
||||
|
||||
BuildRequires: python-sphinx
|
||||
BuildRequires: %{_bindir}/sphinx-build
|
||||
BuildRequires: bzip2-devel
|
||||
BuildRequires: zlib-devel
|
||||
%if 0%{?fedora} >=26
|
||||
@ -129,6 +131,7 @@ interfaces may change in the future.
|
||||
%patch2 -p1 -b .eccfix
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
%patch5 -p1
|
||||
|
||||
# These tests will fail.
|
||||
rm -rf checks/ec_tests.cpp
|
||||
@ -265,6 +268,9 @@ LD_LIBRARY_PATH=%{buildroot}%{_libdir} ./check --validate
|
||||
|
||||
|
||||
%changelog
|
||||
* Sun Aug 13 2017 Thomas Moschny <thomas.moschny@gmx.de> - 1.10.16-1
|
||||
- Update to 1.10.16.
|
||||
|
||||
* Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.10.14-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
#! /bin/bash
|
||||
|
||||
name=Botan-1.10.14
|
||||
name=Botan-1.10.16
|
||||
src=${name}.tgz
|
||||
dst=${name}.stripped.tar.gz
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user