boost/boost-1.48.0-python3.patch
Petr Machata bc9c5908b6 Add support for building boost-python against Python 3
This doesn't touch boost-openmpi-python and boost-mpich2-python, as those
are broken anyway at the moment.
2012-05-02 21:49:40 +02:00

16 lines
651 B
Diff

diff -up boost_1_48_0/libs/python/src/CMakeLists.txt\~ boost_1_48_0/libs/python/src/CMakeLists.txt
--- boost_1_48_0/libs/python/src/CMakeLists.txt~ 2012-05-02 20:29:17.095570094 +0200
+++ boost_1_48_0/libs/python/src/CMakeLists.txt 2012-05-02 20:29:27.645898988 +0200
@@ -29,7 +29,8 @@ endif (PYTHON_DEBUG_LIBRARIES AND BUILD_
# Always build the non-debug variants of the boost_python library
set(BUILD_PYTHON_NODEBUG ON)
-boost_add_library(python
+colormsg (GREEN "+-- BOOST_PYTHON_SUFFIX=${BOOST_PYTHON_SUFFIX}")
+boost_add_library(python${BOOST_PYTHON_SUFFIX}
numeric.cpp
list.cpp
long.cpp
Diff finished. Wed May 2 20:29:38 2012