Fixed compilation errors when compiling JSON-related Boost::Property_Tree

Related: #715611
This commit is contained in:
Denis Arnaud 2011-06-24 00:05:42 +02:00
parent 54575e952a
commit f4262d6502
2 changed files with 28 additions and 2 deletions

View File

@ -0,0 +1,15 @@
diff --git a/boost/property_tree/detail/json_parser_read.hpp b/boost/property_tree/detail/json_parser_read.hpp
index 3f06794..46acc5a 100644
--- a/boost/property_tree/detail/json_parser_read.hpp
+++ b/boost/property_tree/detail/json_parser_read.hpp
@@ -179,6 +179,9 @@ namespace boost { namespace property_tree { namespace json_parser
{
using namespace boost::spirit::classic;
+ // There's a boost::assertion too, so another explicit using
+ // here:
+ using boost::spirit::classic::assertion;
// Assertions
assertion<std::string> expect_object("expected object");

View File

@ -1,6 +1,6 @@
# Support for documentation installation
# As the %%doc macro erases the target directory, namely
# $RPM_BUILD_ROOT%{_docdir}/%{name}-%{version}, manually installed
# $RPM_BUILD_ROOT%%{_docdir}/%%{name}-%%{version}, manually installed
# documentation must be saved into a temporary dedicated directory.
%define boost_docdir __tmp_docdir
@ -28,7 +28,7 @@ Name: boost
Summary: The free peer-reviewed portable C++ source libraries
Version: 1.46.0
%define version_enc 1_46_0
Release: 2%{?dist}
Release: 3%{?dist}
License: Boost
# The CMake build framework (set of CMakeLists.txt and module.cmake files) is
@ -106,6 +106,10 @@ Patch4: boost-1.46.0-unordered-cctor.patch
# https://svn.boost.org/trac/boost/changeset/68725)
Patch5: boost-1.46.0-spirit.patch
# Has been fixed in Boost-1.46.1 (https://svn.boost.org/trac/boost/ticket/5424):
# https://svn.boost.org/trac/boost/changeset/69684)
Patch6: boost-1.46.0-ptree-assertion.patch
%bcond_with tests
%bcond_with docs_generated
@ -433,7 +437,10 @@ sed 's/_FEDORA_SONAME/%{sonamever}/' %{PATCH2} | %{__patch} -p0 --fuzz=0
%patch3 -p1
%patch4 -p2
%patch5 -p0
%patch6 -p1
# Fix some permissions
find ./boost/range -type f -name '*.hpp' -exec chmod 644 {} \;
%build
# Support for building tests.
@ -846,6 +853,10 @@ find $RPM_BUILD_ROOT%{_includedir}/ \( -name '*.pl' -o -name '*.sh' \) -exec %{_
%{_bindir}/bjam
%changelog
* Thu Jun 23 2011 Denis Arnaud <denis.arnaud_fedora@m4x.org> - 1.46.0-3
- Fixed compilation errors when compiling JSON-related Boost::Property_Tree
- Related: #715611
* Sat Jun 18 2011 Peter Robinson <pbrobinson@gmail.com> - 1.46.0-2
- Fix compile on ARM platforms