Integrated into "upstream" (CMake-ified Boost) the Boost.TR1/Math patch.

This commit is contained in:
Denis Arnaud 2012-01-05 00:00:47 +01:00
parent eebc669ef4
commit e82ced7d48
8 changed files with 88 additions and 77516 deletions

File diff suppressed because one or more lines are too long

File diff suppressed because one or more lines are too long

File diff suppressed because it is too large Load Diff

View File

@ -1,23 +0,0 @@
diff -up /home/petr/tmp/blefuj.cc\~ /home/petr/tmp/blefuj.cc
--- boost_1_46_0_beta1/libs/signals/src/named_slot_map.cpp~ 2011-02-03 20:28:07.000000000 +0100
+++ boost_1_46_0_beta1/libs/signals/src/named_slot_map.cpp 2011-02-03 20:51:29.000000000 +0100
@@ -47669,7 +47669,7 @@ void named_slot_map::disconnect(const st
i->first.disconnect();
i = next;
}
- groups.erase(group);
+ groups.erase(const_group_iterator (group));
}
}
@@ -47692,7 +47692,7 @@ void named_slot_map::remove_disconnected
}
// Clear out empty groups
- if (empty(g)) groups.erase(g++);
+ if (empty(g)) groups.erase(const_group_iterator (g++));
else ++g;
}
}
Diff finished. Thu Feb 3 20:51:41 2011

View File

@ -1,59 +0,0 @@
Index: boost/spirit/home/qi/nonterminal/detail/parameterized.hpp
===================================================================
--- boost/spirit/home/qi/nonterminal/detail/parameterized.hpp (revision 68724)
+++ boost/spirit/home/qi/nonterminal/detail/parameterized.hpp (revision 68725)
@@ -14,6 +14,7 @@
#include <boost/ref.hpp>
+#include <boost/spirit/home/support/handles_container.hpp>
#include <boost/spirit/home/qi/parser.hpp>
namespace boost { namespace spirit { namespace qi
@@ -59,4 +60,16 @@ namespace boost { namespace spirit { nam
};
}}}
+namespace boost { namespace spirit { namespace traits
+{
+ ///////////////////////////////////////////////////////////////////////////
+ template <typename Subject, typename Params, typename Attribute
+ , typename Context, typename Iterator>
+ struct handles_container<qi::parameterized_nonterminal<Subject, Params>
+ , Attribute, Context, Iterator>
+ : handles_container<typename remove_const<Subject>::type
+ , Attribute, Context, Iterator>
+ {};
+}}}
+
#endif
Index: boost/spirit/home/karma/nonterminal/detail/parameterized.hpp
===================================================================
--- boost/spirit/home/karma/nonterminal/detail/parameterized.hpp (revision 68724)
+++ boost/spirit/home/karma/nonterminal/detail/parameterized.hpp (revision 68725)
@@ -14,6 +14,7 @@
#include <boost/ref.hpp>
+#include <boost/spirit/home/support/handles_container.hpp>
#include <boost/spirit/home/karma/generator.hpp>
namespace boost { namespace spirit { namespace karma
@@ -60,4 +61,17 @@ namespace boost { namespace spirit { nam
};
}}}
+
+namespace boost { namespace spirit { namespace traits
+{
+ ///////////////////////////////////////////////////////////////////////////
+ template <typename Subject, typename Params, typename Attribute
+ , typename Context, typename Iterator>
+ struct handles_container<karma::parameterized_nonterminal<Subject, Params>
+ , Attribute, Context, Iterator>
+ : handles_container<typename remove_const<Subject>::type
+ , Attribute, Context, Iterator>
+ {};
+}}}
+
#endif

View File

@ -5518,7 +5518,7 @@ index 0000000..7684320
+boost_test_run(tribool_io_test)
diff --git a/libs/math/CMakeLists.txt b/libs/math/CMakeLists.txt
new file mode 100644
index 0000000..0f7652e
index 0000000..84080d5
--- /dev/null
+++ b/libs/math/CMakeLists.txt
@@ -0,0 +1,28 @@
@ -5539,7 +5539,7 @@ index 0000000..0f7652e
+# Add a library target to the build system
+boost_library_project(
+ math
+ # SRCDIRS
+ SRCDIRS src/tr1
+ TESTDIRS test
+ HEADERS ${lib_headers}
+ # DOCDIRS
@ -5558,6 +5558,88 @@ index 0000000..e222098
@@ -0,0 +1 @@
+boost_module(math DEPENDS format array)
\ No newline at end of file
diff --git a/libs/math/src/tr1/CMakeLists.txt b/libs/math/src/tr1/CMakeLists.txt
new file mode 100644
index 0000000..692fa72
--- /dev/null
+++ b/libs/math/src/tr1/CMakeLists.txt
@@ -0,0 +1,76 @@
+boost_add_library(math_tr1
+
+ assoc_laguerre.cpp assoc_legendre.cpp beta.cpp
+ comp_ellint_1.cpp comp_ellint_2.cpp comp_ellint_3.cpp
+ cyl_bessel_i.cpp cyl_bessel_j.cpp cyl_bessel_k.cpp
+ cyl_neumann.cpp ellint_1.cpp ellint_2.cpp ellint_3.cpp
+ expint.cpp hermite.cpp laguerre.cpp legendre.cpp
+ riemann_zeta.cpp sph_bessel.cpp sph_legendre.cpp
+ sph_neumann.cpp
+
+ SHARED_COMPILE_FLAGS "-DBOOST_MATH_TR1_DYN_LINK=1"
+ COMPILE_FLAGS "-I${CMAKE_CURRENT_SOURCE_DIR}"
+)
+
+boost_add_library(math_tr1f
+
+ assoc_laguerref.cpp assoc_legendref.cpp betaf.cpp
+ comp_ellint_1f.cpp comp_ellint_2f.cpp comp_ellint_3f.cpp
+ cyl_bessel_if.cpp cyl_bessel_jf.cpp cyl_bessel_kf.cpp
+ cyl_neumannf.cpp ellint_1f.cpp ellint_2f.cpp ellint_3f.cpp
+ expintf.cpp hermitef.cpp laguerref.cpp legendref.cpp
+ riemann_zetaf.cpp sph_besself.cpp sph_legendref.cpp
+ sph_neumannf.cpp
+
+ SHARED_COMPILE_FLAGS "-DBOOST_MATH_TR1_DYN_LINK=1"
+ COMPILE_FLAGS "-I${CMAKE_CURRENT_SOURCE_DIR}"
+)
+
+boost_add_library(math_tr1l
+
+ assoc_laguerrel.cpp assoc_legendrel.cpp betal.cpp
+ comp_ellint_1l.cpp comp_ellint_2l.cpp comp_ellint_3l.cpp
+ cyl_bessel_il.cpp cyl_bessel_jl.cpp cyl_bessel_kl.cpp
+ cyl_neumannl.cpp ellint_1l.cpp ellint_2l.cpp ellint_3l.cpp
+ expintl.cpp hermitel.cpp laguerrel.cpp legendrel.cpp
+ riemann_zetal.cpp sph_bessell.cpp sph_legendrel.cpp
+ sph_neumannl.cpp
+
+ SHARED_COMPILE_FLAGS "-DBOOST_MATH_TR1_DYN_LINK=1"
+ COMPILE_FLAGS "-I${CMAKE_CURRENT_SOURCE_DIR}"
+)
+
+boost_add_library(math_c99
+
+ acosh.cpp asinh.cpp atanh.cpp cbrt.cpp copysign.cpp erfc.cpp
+ erf.cpp expm1.cpp fmax.cpp fmin.cpp fpclassify.cpp hypot.cpp
+ lgamma.cpp llround.cpp log1p.cpp lround.cpp nextafter.cpp
+ nexttoward.cpp round.cpp tgamma.cpp trunc.cpp
+
+ SHARED_COMPILE_FLAGS "-DBOOST_MATH_TR1_DYN_LINK=1"
+ COMPILE_FLAGS "-I${CMAKE_CURRENT_SOURCE_DIR}"
+)
+
+boost_add_library(math_c99f
+
+ acoshf.cpp asinhf.cpp atanhf.cpp cbrtf.cpp copysignf.cpp
+ erfcf.cpp erff.cpp expm1f.cpp fmaxf.cpp fminf.cpp
+ fpclassifyf.cpp hypotf.cpp lgammaf.cpp llroundf.cpp log1pf.cpp
+ lroundf.cpp nextafterf.cpp nexttowardf.cpp roundf.cpp
+ tgammaf.cpp truncf.cpp
+
+ SHARED_COMPILE_FLAGS "-DBOOST_MATH_TR1_DYN_LINK=1"
+ COMPILE_FLAGS "-I${CMAKE_CURRENT_SOURCE_DIR}"
+)
+
+boost_add_library(math_c99l
+
+ acoshl.cpp asinhl.cpp atanhl.cpp cbrtl.cpp copysignl.cpp
+ erfcl.cpp erfl.cpp expm1l.cpp fmaxl.cpp fminl.cpp
+ fpclassifyl.cpp hypotl.cpp lgammal.cpp llroundl.cpp log1pl.cpp
+ lroundl.cpp nextafterl.cpp nexttowardl.cpp roundl.cpp
+ tgammal.cpp truncl.cpp
+
+ SHARED_COMPILE_FLAGS "-DBOOST_MATH_TR1_DYN_LINK=1"
+ COMPILE_FLAGS "-I${CMAKE_CURRENT_SOURCE_DIR}"
+)
diff --git a/libs/math/test/CMakeLists.txt b/libs/math/test/CMakeLists.txt
new file mode 100644
index 0000000..88f26b7
@ -11473,24 +11555,6 @@ index 0000000..8c435b7
+ RELEASE
+ STATIC
+ )
diff --git a/tools/build/CMake/.gitignore b/tools/build/CMake/.gitignore
new file mode 100644
index 0000000..5b99088
--- /dev/null
+++ b/tools/build/CMake/.gitignore
@@ -0,0 +1,12 @@
+/build
+tmp
+*.pyc
+._*
+bjam
+project-config.jam
+bin.v2/
+dist/
+.\#*
+*.tar.*
+*.zip
+
diff --git a/tools/build/CMake/Boost.bmp b/tools/build/CMake/Boost.bmp
new file mode 100644
index 0000000..944ab5e
@ -14992,16 +15056,6 @@ index 0000000..75bc4f1
+ <rewriteURI uriStartString="http://docbook.sourceforge.net/release/xsl/current/" rewritePrefix="file://@DOCBOOK_XSL_DIR@/"/>
+ <rewriteURI uriStartString="http://www.oasis-open.org/docbook/xml/4.2/" rewritePrefix="file://@DOCBOOK_DTD_DIR@/"/>
+</catalog>
diff --git a/tools/build/CMake/docs/.gitignore b/tools/build/CMake/docs/.gitignore
new file mode 100644
index 0000000..7f67dd3
--- /dev/null
+++ b/tools/build/CMake/docs/.gitignore
@@ -0,0 +1,4 @@
+build/doctrees
+build/latex
+Makefile
+
diff --git a/tools/build/CMake/docs/Makefile.in b/tools/build/CMake/docs/Makefile.in
new file mode 100644
index 0000000..e51563a
@ -29958,13 +30012,6 @@ index 0000000..3a98b89
+ </body>
+</html>
\ No newline at end of file
diff --git a/tools/build/CMake/docs/source/.gitignore b/tools/build/CMake/docs/source/.gitignore
new file mode 100644
index 0000000..4ba4af7
--- /dev/null
+++ b/tools/build/CMake/docs/source/.gitignore
@@ -0,0 +1 @@
+boost_cmake_version.py
diff --git a/tools/build/CMake/docs/source/GitLexer.py b/tools/build/CMake/docs/source/GitLexer.py
new file mode 100644
index 0000000..20a672e
@ -37316,13 +37363,6 @@ index 0000000..341ecf8
+boost_external_report(ZLib INCLUDE_DIR LIBRARIES)
+
+
diff --git a/tools/build/CMake/install_me/.gitignore b/tools/build/CMake/install_me/.gitignore
new file mode 100644
index 0000000..211686a
--- /dev/null
+++ b/tools/build/CMake/install_me/.gitignore
@@ -0,0 +1 @@
+*.cmake
diff --git a/tools/build/CMake/install_me/Boost-thisversion.cmake.in b/tools/build/CMake/install_me/Boost-thisversion.cmake.in
new file mode 100644
index 0000000..b292097

View File

@ -1,94 +0,0 @@
diff -up boost_1_47_0/libs/math/CMakeLists.txt\~ boost_1_47_0/libs/math/CMakeLists.txt
--- boost_1_47_0/libs/math/CMakeLists.txt~ 2012-01-03 18:15:11.568913701 +0100
+++ boost_1_47_0/libs/math/CMakeLists.txt 2012-01-03 18:51:11.437962984 +0100
@@ -15,7 +15,7 @@ set (lib_headers
# Add a library target to the build system
boost_library_project(
math
- # SRCDIRS
+ SRCDIRS src/tr1
TESTDIRS test
HEADERS ${lib_headers}
# DOCDIRS
diff -up boost_1_47_0/libs/math/src/tr1/CMakeLists.txt\~ boost_1_47_0/libs/math/src/tr1/CMakeLists.txt
--- boost_1_47_0/libs/math/src/tr1/CMakeLists.txt~ 2012-01-03 18:50:07.514961526 +0100
+++ boost_1_47_0/libs/math/src/tr1/CMakeLists.txt 2012-01-03 18:47:32.803957995 +0100
@@ -0,0 +1,76 @@
+boost_add_library(math_tr1
+
+ assoc_laguerre.cpp assoc_legendre.cpp beta.cpp
+ comp_ellint_1.cpp comp_ellint_2.cpp comp_ellint_3.cpp
+ cyl_bessel_i.cpp cyl_bessel_j.cpp cyl_bessel_k.cpp
+ cyl_neumann.cpp ellint_1.cpp ellint_2.cpp ellint_3.cpp
+ expint.cpp hermite.cpp laguerre.cpp legendre.cpp
+ riemann_zeta.cpp sph_bessel.cpp sph_legendre.cpp
+ sph_neumann.cpp
+
+ SHARED_COMPILE_FLAGS "-DBOOST_MATH_TR1_DYN_LINK=1"
+ COMPILE_FLAGS "-I${CMAKE_CURRENT_SOURCE_DIR}"
+)
+
+boost_add_library(math_tr1f
+
+ assoc_laguerref.cpp assoc_legendref.cpp betaf.cpp
+ comp_ellint_1f.cpp comp_ellint_2f.cpp comp_ellint_3f.cpp
+ cyl_bessel_if.cpp cyl_bessel_jf.cpp cyl_bessel_kf.cpp
+ cyl_neumannf.cpp ellint_1f.cpp ellint_2f.cpp ellint_3f.cpp
+ expintf.cpp hermitef.cpp laguerref.cpp legendref.cpp
+ riemann_zetaf.cpp sph_besself.cpp sph_legendref.cpp
+ sph_neumannf.cpp
+
+ SHARED_COMPILE_FLAGS "-DBOOST_MATH_TR1_DYN_LINK=1"
+ COMPILE_FLAGS "-I${CMAKE_CURRENT_SOURCE_DIR}"
+)
+
+boost_add_library(math_tr1l
+
+ assoc_laguerrel.cpp assoc_legendrel.cpp betal.cpp
+ comp_ellint_1l.cpp comp_ellint_2l.cpp comp_ellint_3l.cpp
+ cyl_bessel_il.cpp cyl_bessel_jl.cpp cyl_bessel_kl.cpp
+ cyl_neumannl.cpp ellint_1l.cpp ellint_2l.cpp ellint_3l.cpp
+ expintl.cpp hermitel.cpp laguerrel.cpp legendrel.cpp
+ riemann_zetal.cpp sph_bessell.cpp sph_legendrel.cpp
+ sph_neumannl.cpp
+
+ SHARED_COMPILE_FLAGS "-DBOOST_MATH_TR1_DYN_LINK=1"
+ COMPILE_FLAGS "-I${CMAKE_CURRENT_SOURCE_DIR}"
+)
+
+boost_add_library(math_c99
+
+ acosh.cpp asinh.cpp atanh.cpp cbrt.cpp copysign.cpp erfc.cpp
+ erf.cpp expm1.cpp fmax.cpp fmin.cpp fpclassify.cpp hypot.cpp
+ lgamma.cpp llround.cpp log1p.cpp lround.cpp nextafter.cpp
+ nexttoward.cpp round.cpp tgamma.cpp trunc.cpp
+
+ SHARED_COMPILE_FLAGS "-DBOOST_MATH_TR1_DYN_LINK=1"
+ COMPILE_FLAGS "-I${CMAKE_CURRENT_SOURCE_DIR}"
+)
+
+boost_add_library(math_c99f
+
+ acoshf.cpp asinhf.cpp atanhf.cpp cbrtf.cpp copysignf.cpp
+ erfcf.cpp erff.cpp expm1f.cpp fmaxf.cpp fminf.cpp
+ fpclassifyf.cpp hypotf.cpp lgammaf.cpp llroundf.cpp log1pf.cpp
+ lroundf.cpp nextafterf.cpp nexttowardf.cpp roundf.cpp
+ tgammaf.cpp truncf.cpp
+
+ SHARED_COMPILE_FLAGS "-DBOOST_MATH_TR1_DYN_LINK=1"
+ COMPILE_FLAGS "-I${CMAKE_CURRENT_SOURCE_DIR}"
+)
+
+boost_add_library(math_c99l
+
+ acoshl.cpp asinhl.cpp atanhl.cpp cbrtl.cpp copysignl.cpp
+ erfcl.cpp erfl.cpp expm1l.cpp fmaxl.cpp fminl.cpp
+ fpclassifyl.cpp hypotl.cpp lgammal.cpp llroundl.cpp log1pl.cpp
+ lroundl.cpp nextafterl.cpp nexttowardl.cpp roundl.cpp
+ tgammal.cpp truncl.cpp
+
+ SHARED_COMPILE_FLAGS "-DBOOST_MATH_TR1_DYN_LINK=1"
+ COMPILE_FLAGS "-I${CMAKE_CURRENT_SOURCE_DIR}"
+)
Diff finished. Tue Jan 3 18:50:10 2012

View File

@ -28,7 +28,7 @@ Name: boost
Summary: The free peer-reviewed portable C++ source libraries
Version: 1.47.0
%define version_enc 1_47_0
Release: 5%{?dist}
Release: 6%{?dist}
License: Boost
# The CMake build framework (set of CMakeLists.txt and module.cmake files) is
@ -98,9 +98,6 @@ Patch3: boost-1.47.0-exceptions.patch
# https://svn.boost.org/trac/boost/ticket/5934
Patch4: boost-1.47.0-tuple.patch
# https://bugzilla.redhat.com/show_bug.cgi?id=771370
Patch5: boost-1.47.0-mathlib.patch
%bcond_with tests
%bcond_with docs_generated
@ -444,7 +441,6 @@ sed 's/_FEDORA_SONAME/%{sonamever}/' %{PATCH1} | %{__patch} -p0 --fuzz=0
%patch2 -p1
%patch3 -p0
%patch4 -p2
%patch5 -p1
%build
# Support for building tests.
@ -898,6 +894,9 @@ find $RPM_BUILD_ROOT%{_includedir}/ \( -name '*.pl' -o -name '*.sh' \) -exec %{_
%{_bindir}/bjam
%changelog
* Wed Jan 4 2012 Denis Arnaud <denis.arnaud_fedora@m4x.org> - 1.47.0-6
- Integrated into "upstream" (CMake-ified Boost) the Boost.TR1/Math patch.
* Wed Jan 4 2012 Petr Machata <pmachata@redhat.com> - 1.47.0-5
- Build math portion of Boost.TR1, package DSOs in boost-math.
- Resolves: #771370