Use <boost/tr1/tuple> instead of C++11 header <tuple> in boost math

This commit is contained in:
Petr Machata 2011-11-03 22:39:38 +01:00
parent 08909f63ae
commit d7d96c8c27
2 changed files with 20 additions and 1 deletions

11
boost-1.47.0-tuple.patch Normal file
View File

@ -0,0 +1,11 @@
Index: /trunk/boost/math/tools/tuple.hpp
===================================================================
--- /trunk/boost/math/tools/tuple.hpp (revision 65320)
+++ /trunk/boost/math/tools/tuple.hpp (revision 74891)
@@ -32,5 +32,5 @@
#elif defined(BOOST_HAS_TR1_TUPLE)
-#include <tuple>
+#include <boost/tr1/tuple.hpp>
namespace boost{ namespace math{

View File

@ -28,7 +28,7 @@ Name: boost
Summary: The free peer-reviewed portable C++ source libraries
Version: 1.47.0
%define version_enc 1_47_0
Release: 3%{?dist}
Release: 4%{?dist}
License: Boost
# The CMake build framework (set of CMakeLists.txt and module.cmake files) is
@ -95,6 +95,9 @@ Patch2: boost-1.47.0-signals-erase.patch
# https://svn.boost.org/trac/boost/ticket/5731
Patch3: boost-1.47.0-exceptions.patch
# https://svn.boost.org/trac/boost/ticket/5934
Patch4: boost-1.47.0-tuple.patch
%bcond_with tests
%bcond_with docs_generated
@ -439,6 +442,7 @@ sed 's/_FEDORA_SONAME/%{sonamever}/' %{PATCH1} | %{__patch} -p0 --fuzz=0
# Fixes
%patch2 -p1
%patch3 -p0
%patch4 -p2
%build
# Support for building tests.
@ -891,6 +895,10 @@ find $RPM_BUILD_ROOT%{_includedir}/ \( -name '*.pl' -o -name '*.sh' \) -exec %{_
%{_bindir}/bjam
%changelog
* Thu Nov 3 2011 Petr Machata <pmachata@redhat.com> - 1.47.0-4
- Use <boost/tr1/tuple> instead of C++11 header <tuple> in boost math.
- Resolves: #751210
* Tue Jul 26 2011 Petr Machata <pmachata@redhat.com> - 1.47.0-3
- Package examples
- Resolves: #722844