Merged the latest changes from the bug-fix release of Boost-1.46

This commit is contained in:
Denis Arnaud 2011-03-13 13:34:44 +01:00
parent 5477eebe96
commit 50e7fa2daf
8 changed files with 14 additions and 104 deletions

View File

@ -1,92 +0,0 @@
Index: /trunk/boost/unordered/unordered_set.hpp
===================================================================
--- /trunk/boost/unordered/unordered_set.hpp (revision 60754)
+++ /trunk/boost/unordered/unordered_set.hpp (revision 68445)
@@ -155,4 +155,9 @@
#if !defined(BOOST_NO_RVALUE_REFERENCES)
+ unordered_set(unordered_set const& other)
+ : table_(other.table_)
+ {
+ }
+
unordered_set(unordered_set&& other)
: table_(other.table_, boost::unordered_detail::move_tag())
@@ -163,4 +168,10 @@
: table_(other.table_, a, boost::unordered_detail::move_tag())
{
+ }
+
+ unordered_set& operator=(unordered_set const& x)
+ {
+ table_ = x.table_;
+ return *this;
}
@@ -652,4 +663,9 @@
#if !defined(BOOST_NO_RVALUE_REFERENCES)
+ unordered_multiset(unordered_multiset const& other)
+ : table_(other.table_)
+ {
+ }
+
unordered_multiset(unordered_multiset&& other)
: table_(other.table_, boost::unordered_detail::move_tag())
@@ -660,4 +676,10 @@
: table_(other.table_, a, boost::unordered_detail::move_tag())
{
+ }
+
+ unordered_multiset& operator=(unordered_multiset const& x)
+ {
+ table_ = x.table_;
+ return *this;
}
Index: /trunk/boost/unordered/unordered_map.hpp
===================================================================
--- /trunk/boost/unordered/unordered_map.hpp (revision 60754)
+++ /trunk/boost/unordered/unordered_map.hpp (revision 68445)
@@ -161,4 +161,9 @@
#if !defined(BOOST_NO_RVALUE_REFERENCES)
+ unordered_map(unordered_map const& other)
+ : table_(other.table_)
+ {
+ }
+
unordered_map(unordered_map&& other)
: table_(other.table_, boost::unordered_detail::move_tag())
@@ -169,4 +174,10 @@
: table_(other.table_, a, boost::unordered_detail::move_tag())
{
+ }
+
+ unordered_map& operator=(unordered_map const& x)
+ {
+ table_ = x.table_;
+ return *this;
}
@@ -706,4 +717,9 @@
#if !defined(BOOST_NO_RVALUE_REFERENCES)
+ unordered_multimap(unordered_multimap const& other)
+ : table_(other.table_)
+ {
+ }
+
unordered_multimap(unordered_multimap&& other)
: table_(other.table_, boost::unordered_detail::move_tag())
@@ -714,4 +730,10 @@
: table_(other.table_, a, boost::unordered_detail::move_tag())
{
+ }
+
+ unordered_multimap& operator=(unordered_multimap const& x)
+ {
+ table_ = x.table_;
+ return *this;
}

View File

@ -21,9 +21,9 @@
Name: boost
Summary: The free peer-reviewed portable C++ source libraries
Version: 1.46.0
%define version_enc 1_46_0
Release: 0.5%{?dist}
Version: 1.46.1
%define version_enc 1_46_1
Release: 1%{?dist}
License: Boost
# The CMake build framework (set of CMakeLists.txt and module.cmake files) is
@ -82,24 +82,24 @@ BuildRequires: libicu-devel
BuildRequires: chrpath
# CMake-related files (CMakeLists.txt and module.cmake files)
Patch0: boost-1.46.0-cmakeify-full.patch
Patch0: boost-1.46.1-cmakeify-full.patch
# Mainly Web-related documentation for the Trac Wiki devoted to "old"
# Boost-CMake (up-to-date until Boost-1.41.0). Now part of
# boost-1.46.0-cmakeify-full.patch
#Patch1: boost-1.46.0-cmakeify-more.patch
# boost-1.46.1-cmakeify-full.patch
#Patch1: boost-1.46.1-cmakeify-more.patch
Patch2: boost-cmake-soname.patch
# The patch may break c++03, and there is therefore no plan yet to include
# it upstream: https://svn.boost.org/trac/boost/ticket/4999
Patch3: boost-1.46.0-signals-erase.patch
Patch3: boost-1.46.1-signals-erase.patch
# Will be fixed in Boost-1.47: https://svn.boost.org/trac/boost/ticket/5119
Patch4: boost-1.46.0-unordered-cctor.patch
# Has been fixed in Boost-1.46.1: https://svn.boost.org/trac/boost/ticket/5119
#Patch4: boost-1.46.0-unordered-cctor.patch
# http://comments.gmane.org/gmane.comp.lib.boost.devel/214323
# Has been fixed on Boost trunk (will be fixed in Boost-1.47:
# https://svn.boost.org/trac/boost/changeset/68725)
Patch5: boost-1.46.0-spirit.patch
Patch5: boost-1.46.1-spirit.patch
%bcond_with tests
%bcond_with docs_generated
@ -426,7 +426,6 @@ sed 's/_FEDORA_SONAME/%{sonamever}/' %{PATCH2} | %{__patch} -p0 --fuzz=0
# fixes
%patch3 -p1
%patch4 -p2
%patch5 -p0
@ -841,6 +840,9 @@ find $RPM_BUILD_ROOT%{_includedir}/ \( -name '*.pl' -o -name '*.sh' \) -exec %{_
%{_bindir}/bjam
%changelog
* Sun Mar 13 2011 Denis Arnaud <denis.arnaud_fedora@m4x.org> - 1.46.1-1
- Merged the latest changes from the bug-fix release of Boost-1.46
* Mon Mar 07 2011 Caolán McNamara <caolanm@redhat.com> - 1.46.0-0.5
- rebuild for icu 4.6

View File

@ -1 +1 @@
37b12f1702319b73876b0097982087e0 boost_1_46_0.tar.bz2
7375679575f4c8db605d426fc721d506 boost_1_46_1.tar.bz2