33 lines
1.1 KiB
Diff
33 lines
1.1 KiB
Diff
--- black-hole-solver-0.20.0/CMakeLists.txt.orig 2019-04-24 13:25:05.705449647 +0300
|
|
+++ black-hole-solver-0.20.0/CMakeLists.txt 2019-04-24 13:25:55.340522389 +0300
|
|
@@ -35,29 +35,6 @@
|
|
"~$"
|
|
)
|
|
|
|
-### This is to set the RPATH correctly, so when installed under a prefix
|
|
-### the executables will find the libraries.
|
|
-###
|
|
-### See:
|
|
-###
|
|
-### http://www.cmake.org/Wiki/CMake_RPATH_handling
|
|
-###
|
|
-### (Taken from that wiki page)
|
|
-
|
|
-# use, i.e. don't skip the full RPATH for the build tree
|
|
-SET(CMAKE_SKIP_BUILD_RPATH FALSE)
|
|
-
|
|
-# when building, don't use the install RPATH already
|
|
-# (but later on when installing)
|
|
-SET(CMAKE_BUILD_WITH_INSTALL_RPATH FALSE)
|
|
-
|
|
-# the RPATH to be used when installing
|
|
-SET(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}")
|
|
-
|
|
-# add the automatically determined parts of the RPATH
|
|
-# which point to directories outside the build tree to the install RPATH
|
|
-SET(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
|
|
-
|
|
SET (LIB_BASE "black_hole_solver")
|
|
option (FCS_WITH_TEST_SUITE "Also build and run the test suite." ON)
|
|
option (FCS_AVOID_TCMALLOC "Avoid linking against Google's tcmalloc")
|