black-hole-solver/bhs-xxhash.patch

22 lines
737 B
Diff

--- black-hole-solver-0.20.0/xxHash-wrapper/wrap_xxhash.h.orig 2019-04-25 13:12:43.484068977 +0300
+++ black-hole-solver-0.20.0/xxHash-wrapper/wrap_xxhash.h 2019-04-25 13:13:01.633166022 +0300
@@ -11,7 +11,6 @@
#pragma once
#include "config.h"
-#define XXH_PRIVATE_API
#include "xxhash.h"
#if SIZEOF_VOID_P == 4
--- black-hole-solver-0.20.0/CMakeLists.txt.orig 2019-04-25 13:16:38.000222097 +0300
+++ black-hole-solver-0.20.0/CMakeLists.txt 2019-04-25 13:17:14.864067712 +0300
@@ -169,7 +169,7 @@
ARCHIVE DESTINATION "lib${LIB_SUFFIX}"
)
-TARGET_LINK_LIBRARIES("${LIB_BASE}" ${LIBTOKYO_CAB_LIBS})
+TARGET_LINK_LIBRARIES("${LIB_BASE}" ${LIBTOKYO_CAB_LIBS} "xxhash")
LIST (APPEND BLACK_HOLE_SOLVER_LIBS "${LIB_BASE}")