Rebase on the new FSF 2.26 binutils release
Resolves: 1271387
This commit is contained in:
parent
58ff635f1e
commit
e37b508a86
@ -1,10 +1,9 @@
|
||||
--- a/bfd/elf.c 2010-08-10 15:04:55.000000000 +0100
|
||||
+++ b/bfd/elf.c 2010-08-10 15:05:42.000000000 +0100
|
||||
@@ -1074,6 +1074,14 @@
|
||||
--- binutils-2.26.orig/bfd/elf.c 2016-01-25 10:11:33.482288877 +0000
|
||||
+++ binutils-2.26/bfd/elf.c 2016-01-25 10:16:48.520223863 +0000
|
||||
@@ -1300,6 +1300,13 @@ _bfd_elf_copy_private_bfd_data (bfd *ibf
|
||||
}
|
||||
}
|
||||
|
||||
/* Copy object attributes. */
|
||||
_bfd_elf_copy_obj_attributes (ibfd, obfd);
|
||||
+
|
||||
+ /* If the input BFD has the OSABI field set and the
|
||||
+ output BFD does not, then copy the value. */
|
||||
+ if (elf_elfheader (ibfd)->e_ident [EI_OSABI] != ELFOSABI_NONE
|
||||
|
@ -1,20 +1,11 @@
|
||||
--- a/bfd/merge.c 2010-08-20 12:19:33.000000000 +0100
|
||||
+++ b/bfd/merge.c 2010-08-20 12:18:01.000000000 +0100
|
||||
@@ -307,6 +307,9 @@
|
||||
len = -off & (entry->alignment - 1);
|
||||
if (len != 0)
|
||||
{
|
||||
+ /* We should never have an entry with an alignment
|
||||
+ greater than the section's alignment. */
|
||||
+ BFD_ASSERT (len <= (bfd_size_type) (1 << alignment_power));
|
||||
if (bfd_bwrite (pad, len, abfd) != len)
|
||||
goto err;
|
||||
off += len;
|
||||
@@ -324,6 +327,7 @@
|
||||
--- binutils-2.26.orig/bfd/merge.c 2016-01-25 10:11:33.505289018 +0000
|
||||
+++ binutils-2.26/bfd/merge.c 2016-01-25 10:19:56.961381656 +0000
|
||||
@@ -334,7 +334,7 @@ sec_merge_emit (bfd *abfd, struct sec_me
|
||||
|
||||
/* Trailing alignment needed? */
|
||||
off = sec->size - off;
|
||||
if (off != 0
|
||||
+ && alignment_power
|
||||
&& bfd_bwrite (pad, off, abfd) != off)
|
||||
goto err;
|
||||
|
||||
- if (off != 0)
|
||||
+ if (off != 0 && alignment_power)
|
||||
{
|
||||
if (contents)
|
||||
memcpy (contents + offset, pad, off);
|
||||
|
@ -9,25 +9,13 @@
|
||||
else !INSTALL_LIBBFD
|
||||
# Empty these so that the respective installation directories will not be created.
|
||||
bfdlibdir =
|
||||
--- a/bfd/Makefile.in 2012-03-06 14:00:32.952957600 +0000
|
||||
+++ b/bfd/Makefile.in 2012-04-27 16:46:19.718975214 +0100
|
||||
@@ -138,7 +138,8 @@
|
||||
installcheck-recursive installdirs-recursive pdf-recursive \
|
||||
ps-recursive uninstall-recursive
|
||||
am__bfdinclude_HEADERS_DIST = $(INCDIR)/plugin-api.h bfd.h \
|
||||
- $(INCDIR)/ansidecl.h $(INCDIR)/symcat.h $(INCDIR)/bfdlink.h
|
||||
+ $(INCDIR)/ansidecl.h $(INCDIR)/symcat.h $(INCDIR)/bfdlink.h \
|
||||
+ $(INCDIR)/demangle.h
|
||||
HEADERS = $(bfdinclude_HEADERS)
|
||||
RECURSIVE_CLEAN_TARGETS = mostlyclean-recursive clean-recursive \
|
||||
distclean-recursive maintainer-clean-recursive
|
||||
@@ -331,7 +332,8 @@
|
||||
--- binutils-2.26.orig/bfd/Makefile.in 2016-01-25 10:23:35.054721634 +0000
|
||||
+++ binutils-2.26/bfd/Makefile.in 2016-01-25 10:25:59.292607840 +0000
|
||||
@@ -350,6 +350,7 @@ libbfd_la_LDFLAGS = $(am__append_1) -rel
|
||||
@INSTALL_LIBBFD_FALSE@bfdinclude_HEADERS = $(am__append_2)
|
||||
@INSTALL_LIBBFD_TRUE@bfdinclude_HEADERS = $(BFD_H) \
|
||||
@INSTALL_LIBBFD_TRUE@ $(INCDIR)/ansidecl.h $(INCDIR)/symcat.h \
|
||||
-@INSTALL_LIBBFD_TRUE@ $(INCDIR)/bfdlink.h $(am__append_2)
|
||||
+@INSTALL_LIBBFD_TRUE@ $(INCDIR)/bfdlink.h $(INCDIR)/demangle.h \
|
||||
+@INSTALL_LIBBFD_TRUE@ $(am__append_2)
|
||||
+@INSTALL_LIBBFD_TRUE@ $(INCDIR)/demangle.h \
|
||||
@INSTALL_LIBBFD_TRUE@ $(INCDIR)/bfdlink.h $(am__append_2)
|
||||
@INSTALL_LIBBFD_FALSE@rpath_bfdlibdir = @bfdlibdir@
|
||||
@INSTALL_LIBBFD_FALSE@noinst_LTLIBRARIES = libbfd.la
|
||||
AM_CFLAGS = $(WARN_CFLAGS)
|
||||
|
@ -46,12 +46,12 @@ diff -cpr ../binutils-2.22.52.0.1.orig/ld/testsuite/ld-bootstrap/bootstrap.exp l
|
||||
untested $testname
|
||||
continue
|
||||
}
|
||||
--- a/ld/emultempl/elf32.em 2013-04-24 11:06:47.777176887 +0100
|
||||
+++ b/ld/emultempl/elf32.em 2013-04-24 11:07:22.405177847 +0100
|
||||
@@ -105,6 +105,7 @@
|
||||
input_flags.dynamic = ${DYNAMIC_LINK-TRUE};
|
||||
--- binutils-2.26.orig/ld/emultempl/elf32.em 2016-01-25 10:11:33.990291993 +0000
|
||||
+++ binutils-2.26/ld/emultempl/elf32.em 2016-01-25 10:21:40.333016777 +0000
|
||||
@@ -104,6 +104,7 @@ gld${EMULATION_NAME}_before_parse (void)
|
||||
config.has_shared = `if test -n "$GENERATE_SHLIB_SCRIPT" ; then echo TRUE ; else echo FALSE ; fi`;
|
||||
config.separate_code = `if test "x${SEPARATE_CODE}" = xyes ; then echo TRUE ; else echo FALSE ; fi`;
|
||||
`if test -n "$CALL_NOP_BYTE" ; then echo link_info.call_nop_byte = $CALL_NOP_BYTE; fi`;
|
||||
+ link_info.relro = TRUE;
|
||||
}
|
||||
|
||||
|
@ -1,13 +1,13 @@
|
||||
--- a/ld/emultempl/aarch64elf.em 2013-06-05 09:46:17.499278813 +0100
|
||||
+++ b/ld/emultempl/aarch64elf.em 2013-06-05 09:54:36.981292659 +0100
|
||||
@@ -264,7 +264,7 @@
|
||||
@@ -271,7 +271,7 @@ gld${EMULATION_NAME}_after_allocation (v
|
||||
}
|
||||
|
||||
static void
|
||||
-gld${EMULATION_NAME}_finish (void)
|
||||
+gld${EMULATION_NAME}_local_finish (void)
|
||||
{
|
||||
if (! link_info.relocatable)
|
||||
if (!bfd_link_relocatable (&link_info))
|
||||
{
|
||||
@@ -276,7 +276,7 @@
|
||||
}
|
||||
|
File diff suppressed because it is too large
Load Diff
@ -1,10 +1,9 @@
|
||||
diff -up binutils-2.25.orig/bfd/Makefile.am binutils-2.25/bfd/Makefile.am
|
||||
--- binutils-2.25.orig/bfd/Makefile.am 2014-12-24 10:28:10.546273213 +0000
|
||||
+++ binutils-2.25/bfd/Makefile.am 2014-12-24 10:30:27.569042391 +0000
|
||||
@@ -1025,8 +1025,8 @@ DISTCLEANFILES = $(BUILD_CFILES) $(BUILD
|
||||
--- binutils-2.26.orig/bfd/Makefile.am 2016-01-25 10:11:33.505289018 +0000
|
||||
+++ binutils-2.26/bfd/Makefile.am 2016-01-25 10:13:23.489964145 +0000
|
||||
@@ -1043,8 +1043,8 @@ DISTCLEANFILES = $(BUILD_CFILES) $(BUILD
|
||||
bfdver.h: $(srcdir)/version.h $(srcdir)/development.sh $(srcdir)/Makefile.in
|
||||
@echo "creating $@"
|
||||
@bfd_version=`echo "$(VERSION)" | sed -e 's/\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\).*/\1.00\2.00\3.00\4.00\5/' -e 's/\([^\.]*\)\..*\(..\)\..*\(..\)\..*\(..\)\..*\(..\)$$/\1\2\3\4\5/'` ;\
|
||||
@bfd_version=`echo "$(VERSION)" | $(SED) -e 's/\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\).*/\1.00\2.00\3.00\4.00\5/' -e 's/\([^\.]*\)\..*\(..\)\..*\(..\)\..*\(..\)\..*\(..\)$$/\1\2\3\4\5/'` ;\
|
||||
- bfd_version_string="\"$(VERSION)\"" ;\
|
||||
- bfd_soversion="$(VERSION)" ;\
|
||||
+ bfd_version_string="\"$(VERSION)-%{release}\"" ;\
|
||||
@ -12,22 +11,21 @@ diff -up binutils-2.25.orig/bfd/Makefile.am binutils-2.25/bfd/Makefile.am
|
||||
bfd_version_package="\"$(PKGVERSION)\"" ;\
|
||||
report_bugs_to="\"$(REPORT_BUGS_TO)\"" ;\
|
||||
. $(srcdir)/development.sh ;\
|
||||
@@ -1037,7 +1037,7 @@ bfdver.h: $(srcdir)/version.h $(srcdir)/
|
||||
@@ -1055,7 +1055,7 @@ bfdver.h: $(srcdir)/version.h $(srcdir)/
|
||||
fi ;\
|
||||
sed -e "s,@bfd_version@,$$bfd_version," \
|
||||
$(SED) -e "s,@bfd_version@,$$bfd_version," \
|
||||
-e "s,@bfd_version_string@,$$bfd_version_string," \
|
||||
- -e "s,@bfd_version_package@,$$bfd_version_package," \
|
||||
+ -e "s,@bfd_version_package@,\"version \"," \
|
||||
-e "s,@report_bugs_to@,$$report_bugs_to," \
|
||||
< $(srcdir)/version.h > $@; \
|
||||
echo "$${bfd_soversion}" > libtool-soversion
|
||||
diff -up binutils-2.25.orig/bfd/Makefile.in binutils-2.25/bfd/Makefile.in
|
||||
--- binutils-2.25.orig/bfd/Makefile.in 2014-12-24 10:28:10.558273280 +0000
|
||||
+++ binutils-2.25/bfd/Makefile.in 2014-12-24 10:31:37.444434637 +0000
|
||||
@@ -2085,8 +2085,8 @@ stmp-lcoff-h: $(LIBCOFF_H_FILES)
|
||||
--- binutils-2.26.orig/bfd/Makefile.in 2016-01-25 10:11:33.505289018 +0000
|
||||
+++ binutils-2.26/bfd/Makefile.in 2016-01-25 10:14:17.818297941 +0000
|
||||
@@ -2111,8 +2111,8 @@ stmp-lcoff-h: $(LIBCOFF_H_FILES)
|
||||
bfdver.h: $(srcdir)/version.h $(srcdir)/development.sh $(srcdir)/Makefile.in
|
||||
@echo "creating $@"
|
||||
@bfd_version=`echo "$(VERSION)" | sed -e 's/\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\).*/\1.00\2.00\3.00\4.00\5/' -e 's/\([^\.]*\)\..*\(..\)\..*\(..\)\..*\(..\)\..*\(..\)$$/\1\2\3\4\5/'` ;\
|
||||
@bfd_version=`echo "$(VERSION)" | $(SED) -e 's/\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\)\.*\([^\.]*\).*/\1.00\2.00\3.00\4.00\5/' -e 's/\([^\.]*\)\..*\(..\)\..*\(..\)\..*\(..\)\..*\(..\)$$/\1\2\3\4\5/'` ;\
|
||||
- bfd_version_string="\"$(VERSION)\"" ;\
|
||||
- bfd_soversion="$(VERSION)" ;\
|
||||
+ bfd_version_string="\"$(VERSION)-%{release}\"" ;\
|
||||
@ -35,13 +33,12 @@ diff -up binutils-2.25.orig/bfd/Makefile.in binutils-2.25/bfd/Makefile.in
|
||||
bfd_version_package="\"$(PKGVERSION)\"" ;\
|
||||
report_bugs_to="\"$(REPORT_BUGS_TO)\"" ;\
|
||||
. $(srcdir)/development.sh ;\
|
||||
@@ -2097,7 +2097,7 @@ bfdver.h: $(srcdir)/version.h $(srcdir)/
|
||||
@@ -2123,7 +2123,7 @@ bfdver.h: $(srcdir)/version.h $(srcdir)/
|
||||
fi ;\
|
||||
sed -e "s,@bfd_version@,$$bfd_version," \
|
||||
$(SED) -e "s,@bfd_version@,$$bfd_version," \
|
||||
-e "s,@bfd_version_string@,$$bfd_version_string," \
|
||||
- -e "s,@bfd_version_package@,$$bfd_version_package," \
|
||||
+ -e "s,@bfd_version_package@,\"version \"," \
|
||||
-e "s,@report_bugs_to@,$$report_bugs_to," \
|
||||
< $(srcdir)/version.h > $@; \
|
||||
echo "$${bfd_soversion}" > libtool-soversion
|
||||
|
||||
|
39
binutils-2.25.1-cleansweep.patch
Normal file
39
binutils-2.25.1-cleansweep.patch
Normal file
@ -0,0 +1,39 @@
|
||||
--- ../binutils-2.25.1.orig/ld/testsuite/ld-plugin/lto.exp 2016-01-08 15:24:58.241083264 +0000
|
||||
+++ ld/testsuite/ld-plugin/lto.exp 2016-01-08 16:30:51.845827089 +0000
|
||||
@@ -144,7 +144,7 @@ set lto_link_tests [list \
|
||||
{pr12760b.c} {} "libpr12760.a"] \
|
||||
[list "PR ld/12760" \
|
||||
"-O2 -Wl,-e,foo -nostdlib -flto -fuse-linker-plugin tmpdir/pr12760a.o -Wl,--start-group tmpdir/libpr12760.a -Wl,--end-group" "" \
|
||||
- {dummy.c} {} "pr12760.exe" "c" "pr12760a.c:6: warning: Bad bar"] \
|
||||
+ {dummy.c} {} "pr12760.exe" "c" ""] \
|
||||
[list "Build libpr13183.a" \
|
||||
"-T" "-flto -O2 $lto_fat" \
|
||||
{pr13183a.c} {} "libpr13183.a"] \
|
||||
@@ -386,6 +386,11 @@ if { [at_least_gcc_version 4 7] } {
|
||||
}
|
||||
}
|
||||
|
||||
+# Fedora specific binutils patches break some of the tests that follow...
|
||||
+restore_notify
|
||||
+return
|
||||
+
|
||||
+
|
||||
# Run "ld -r" to generate inputs for complex LTO tests.
|
||||
run_dump_test "lto-3r"
|
||||
remote_exec host "mv" "tmpdir/dump tmpdir/lto-3.o"
|
||||
--- ../binutils-2.26.orig/binutils/ar.c 2016-01-25 11:16:43.491152038 +0000
|
||||
+++ binutils/ar.c 2016-01-25 11:18:22.209750390 +0000
|
||||
@@ -768,11 +768,11 @@ main (int argc, char **argv)
|
||||
|
||||
if (newer_only && deterministic > 0)
|
||||
fatal (_("`u' is not meaningful with the `D' option."));
|
||||
-
|
||||
+#if 0
|
||||
if (newer_only && deterministic < 0 && DEFAULT_AR_DETERMINISTIC)
|
||||
non_fatal (_("\
|
||||
`u' modifier ignored since `D' is the default (see `U')"));
|
||||
-
|
||||
+#endif
|
||||
default_deterministic ();
|
||||
|
||||
if (postype != pos_default)
|
@ -45,7 +45,7 @@ diff -rup binutils-2.25.1.orig/bfd/plugin.c binutils-2.25.1/bfd/plugin.c
|
||||
}
|
||||
else
|
||||
{
|
||||
@@ -450,6 +468,12 @@ load_plugin (bfd *abfd)
|
||||
@@ -515,6 +515,12 @@ load_plugin (bfd *abfd)
|
||||
static const bfd_target *
|
||||
bfd_plugin_object_p (bfd *abfd)
|
||||
{
|
||||
@ -55,6 +55,6 @@ diff -rup binutils-2.25.1.orig/bfd/plugin.c binutils-2.25.1/bfd/plugin.c
|
||||
+ if (in_get_symbols)
|
||||
+ return NULL;
|
||||
+
|
||||
if (!load_plugin (abfd))
|
||||
return NULL;
|
||||
if (ld_plugin_object_p)
|
||||
return ld_plugin_object_p (abfd);
|
||||
|
||||
|
@ -19,8 +19,8 @@
|
||||
|
||||
Summary: A GNU collection of binary utilities
|
||||
Name: %{?cross}binutils%{?_with_debug:-debug}
|
||||
Version: 2.25.1
|
||||
Release: 9%{?dist}
|
||||
Version: 2.26
|
||||
Release: 1%{?dist}
|
||||
License: GPLv3+
|
||||
Group: Development/Tools
|
||||
URL: http://sources.redhat.com/binutils
|
||||
@ -32,6 +32,7 @@ URL: http://sources.redhat.com/binutils
|
||||
Source: http://ftp.gnu.org/gnu/binutils/binutils-%{version}.tar.bz2
|
||||
|
||||
Source2: binutils-2.19.50.0.1-output-format.sed
|
||||
|
||||
Patch01: binutils-2.20.51.0.2-libtool-lib64.patch
|
||||
Patch02: binutils-2.20.51.0.10-ppc64-pie.patch
|
||||
Patch03: binutils-2.20.51.0.2-ia64-lib64.patch
|
||||
@ -53,16 +54,8 @@ Patch12: binutils-2.25-kernel-ld-r.patch
|
||||
Patch13: binutils-2.23.2-aarch64-em.patch
|
||||
# Fix detections little endian PPC shared libraries
|
||||
Patch14: binutils-2.24-ldforcele.patch
|
||||
# Fix parsing of corupt iHex binaries
|
||||
Patch15: binutils-2.25.1-ihex-parsing.patch
|
||||
# backport https://sourceware.org/git/gitweb.cgi?p=binutils-gdb.git;h=e9c1bdad269c0c3352eebcc9481ed65144001b0b
|
||||
# Qt linked with gold crash on startup, BZ #1193044
|
||||
Patch16: binutils-2.25.1-dynamic_list.patch
|
||||
Patch17: binutils-2.25.1-aarch64-pr18668.patch
|
||||
# Fix incorrectly generated ELF binaries and DSOs
|
||||
Patch18: binutils-rh1247126.patch
|
||||
# Fix infinite recursion when a plugin tries to claim an unrecognized binary
|
||||
Patch19: binutils-2.25.1-plugin-format-checking.patch
|
||||
Patch15: binutils-2.25.1-plugin-format-checking.patch
|
||||
Patch16: binutils-2.25.1-cleansweep.patch
|
||||
|
||||
Provides: bundled(libiberty)
|
||||
|
||||
@ -185,11 +178,8 @@ using libelf instead of BFD.
|
||||
%ifarch ppc64le
|
||||
%patch14 -p1 -b .ldforcele~
|
||||
%endif
|
||||
%patch15 -p1 -b .ihex~
|
||||
%patch16 -p1 -b .dynamic_list~
|
||||
%patch17 -p1
|
||||
%patch18 -p1
|
||||
%patch19 -p1
|
||||
%patch15 -p1
|
||||
%patch16 -p0
|
||||
|
||||
# We cannot run autotools as there is an exact requirement of autoconf-2.59.
|
||||
|
||||
@ -509,6 +499,14 @@ exit 0
|
||||
%endif # %{isnative}
|
||||
|
||||
%changelog
|
||||
* Mon Jan 25 2016 Nick Clifton <nickc@redhat.com> 2.26-1
|
||||
- Rebase on FSF binutils 2.26 release.
|
||||
- Retire: binutils-2.25.1-ihex-parsing.patch
|
||||
- Retire: binutils-2.25.1-dynamic_list.patch
|
||||
- Retire: binutils-2.25.1-aarch64-pr18668.patch
|
||||
- Retire: binutils-rh1247126.patch
|
||||
(#1271387)
|
||||
|
||||
* Thu Nov 05 2015 Nick Clifton <nickc@redhat.com> 2.25.1-9
|
||||
- Prevent an infinite recursion when a plugin tries to claim a file in an unrecognised format.
|
||||
(#1174065)
|
||||
|
Loading…
Reference in New Issue
Block a user