diff --git a/tests/Regression/480009-when-mistaking-argument-of-strings/Makefile b/tests/Regression/480009-when-mistaking-argument-of-strings/Makefile
new file mode 100644
index 0000000..9594d7f
--- /dev/null
+++ b/tests/Regression/480009-when-mistaking-argument-of-strings/Makefile
@@ -0,0 +1,60 @@
+# Copyright (c) 2009 Red Hat, Inc. All rights reserved.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see .
+#
+# Author: Michal Nowak
+
+
+TOPLEVEL_NAMESPACE=/tools
+PACKAGE_NAME=binutils
+RELATIVE_PATH=Sanity/480009-when-mistaking-argument-of-strings
+
+export TEST=$(TOPLEVEL_NAMESPACE)/$(PACKAGE_NAME)/$(RELATIVE_PATH)
+export TESTVERSION=1.0
+
+BUILT_FILES=
+
+FILES=$(METADATA) runtest.sh Makefile PURPOSE
+
+.PHONY: all install download clean
+
+run: $(FILES) build
+ ./runtest.sh
+
+build: $(BUILT_FILES)
+ chmod a+x ./runtest.sh
+
+clean:
+ rm -f *~ $(BUILT_FILES)
+
+
+include /usr/share/rhts/lib/rhts-make.include
+
+
+$(METADATA): Makefile
+ @touch $(METADATA)
+ @echo "Owner: Michal Nowak " > $(METADATA)
+ @echo "Name: $(TEST)" >> $(METADATA)
+ @echo "Path: $(TEST_DIR)" >> $(METADATA)
+ @echo "TestVersion: $(TESTVERSION)" >> $(METADATA)
+ @echo "Description: When mistaking the argument of strings command , the same error message is output." >> $(METADATA)
+ @echo "Bug: 480009" >> $(METADATA)
+ @echo "Type: Sanity" >> $(METADATA)
+ @echo "TestTime: 5m" >> $(METADATA)
+ @echo "RunFor: $(PACKAGE_NAME)" >> $(METADATA)
+ @echo "Requires: $(PACKAGE_NAME)" >> $(METADATA)
+ @echo "License: GPLv3+" >> $(METADATA)
+ @echo "Releases: -RHEL4 -RHEL5" >> $(METADATA)
+
+ rhts-lint $(METADATA)
diff --git a/tests/Regression/480009-when-mistaking-argument-of-strings/PURPOSE b/tests/Regression/480009-when-mistaking-argument-of-strings/PURPOSE
new file mode 100644
index 0000000..ee642a5
--- /dev/null
+++ b/tests/Regression/480009-when-mistaking-argument-of-strings/PURPOSE
@@ -0,0 +1,27 @@
+[RHEL5.2]
+# strings -n file1
+strings: invalid integer argument file1
+
+# strings --bytes file1
+strings: invalid integer argument file1
+
+# strings -n 0
+strings: invalid number 0
+
+# strings --bytes 0
+strings: invalid number 0
+
+
+[RHEL5.3]
+# strings -n file1
+strings: invalid minimum string length 0
+
+# strings --bytes file1
+strings: invalid minimum string length 0
+
+# strings -n 0
+strings: invalid minimum string length 0
+
+# strings --bytes 0
+strings: invalid minimum string length 0
+
diff --git a/tests/Regression/480009-when-mistaking-argument-of-strings/main.fmf b/tests/Regression/480009-when-mistaking-argument-of-strings/main.fmf
new file mode 100644
index 0000000..e0fa3af
--- /dev/null
+++ b/tests/Regression/480009-when-mistaking-argument-of-strings/main.fmf
@@ -0,0 +1,42 @@
+summary: When mistaking the argument of strings command , the same error message is
+ output.
+description: |+
+ [RHEL5.2]
+ # strings -n file1
+ strings: invalid integer argument file1
+
+ # strings --bytes file1
+ strings: invalid integer argument file1
+
+ # strings -n 0
+ strings: invalid number 0
+
+ # strings --bytes 0
+ strings: invalid number 0
+
+
+ [RHEL5.3]
+ # strings -n file1
+ strings: invalid minimum string length 0
+
+ # strings --bytes file1
+ strings: invalid minimum string length 0
+
+ # strings -n 0
+ strings: invalid minimum string length 0
+
+ # strings --bytes 0
+ strings: invalid minimum string length 0
+
+contact: Michal Nowak
+component:
+- binutils
+test: ./runtest.sh
+framework: beakerlib
+recommend:
+- binutils
+duration: 5m
+link:
+- relates: https://bugzilla.redhat.com/show_bug.cgi?id=480009
+extra-summary: /tools/binutils/Sanity/480009-when-mistaking-argument-of-strings
+extra-task: /tools/binutils/Sanity/480009-when-mistaking-argument-of-strings
diff --git a/tests/Regression/480009-when-mistaking-argument-of-strings/runtest.sh b/tests/Regression/480009-when-mistaking-argument-of-strings/runtest.sh
new file mode 100755
index 0000000..bcbdc7c
--- /dev/null
+++ b/tests/Regression/480009-when-mistaking-argument-of-strings/runtest.sh
@@ -0,0 +1,49 @@
+#!/bin/bash
+# vim: dict=/usr/share/beakerlib/dictionary.vim cpt=.,w,b,u,t,i,k
+#
+# Copyright (c) 2009 Red Hat, Inc. All rights reserved.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see .
+#
+# Author: Michal Nowak
+
+# source the test script helpers
+. /usr/share/beakerlib/beakerlib.sh || exit 1
+
+PACKAGE=binutils
+
+rlJournalStart
+ rlPhaseStartSetup
+ rlShowPackageVersion $PACKAGE
+ rlShowRunningKernel
+ rlPhaseEnd
+
+ rlPhaseStartTest "#1: strings -n file1"
+ rlRun "strings -n file1 2>&1 | grep 'invalid integer argument file1'" 0 "Produced expected error msg: 'strings: invalid integer argument file1'"
+ rlPhaseEnd
+
+ rlPhaseStartTest "#2: strings --bytes file1"
+ rlRun "strings --bytes file1 2>&1 | grep 'invalid integer argument file1'" 0 "Produced expected error msg: 'strings: invalid integer argument file1'"
+ rlPhaseEnd
+
+ rlPhaseStartTest "#3: strings -n 0"
+ rlRun "strings -n 0 2>&1 | grep 'invalid minimum string length 0'" 0 "Produced expected error msg: 'strings: invalid minimum string length 0'"
+ rlPhaseEnd
+
+ rlPhaseStartTest "#4: strings --bytes 0"
+ rlRun "strings --bytes 0 2>&1 | grep 'invalid minimum string length 0'" 0 "Produced expected error msg: 'strings: invalid minimum string length 0'"
+ rlPhaseEnd
+
+ rlJournalPrintText
+rlJournalEnd