Fix a problem honouring readelf's -wE and -wN command line options.
This commit is contained in:
parent
b0bbec2ce9
commit
2b924e2a4b
@ -442,3 +442,18 @@ diff -rup binutils.orig/binutils/testsuite/binutils-all/readelf.k binutils-2.37/
|
||||
Separate debug info file: linkdebug\.debug
|
||||
Build-ID \(0x18 bytes\):
|
||||
00 11 22 33 44 55 66 77 88 99 aa bb cc dd ee ff 01 23 45 67 89 ab cd ef
|
||||
Only in binutils-2.37/binutils/testsuite/binutils-all: debuginfod.exp.orig
|
||||
--- binutils.orig/binutils/dwarf.c 2022-06-30 15:28:53.484593360 +0100
|
||||
+++ binutils-2.37/binutils/dwarf.c 2022-06-30 15:32:22.112213811 +0100
|
||||
@@ -11689,7 +11689,10 @@ dwarf_select_sections_by_letters (const
|
||||
{
|
||||
if (entry->letter == * letters)
|
||||
{
|
||||
- * entry->variable |= entry->val;
|
||||
+ if (entry->val == 0)
|
||||
+ * entry->variable = 0;
|
||||
+ else
|
||||
+ * entry->variable |= entry->val;
|
||||
result |= entry->val;
|
||||
|
||||
if (! entry->cont)
|
||||
|
@ -39,7 +39,7 @@
|
||||
Summary: A GNU collection of binary utilities
|
||||
Name: binutils%{?name_cross}%{?_with_debug:-debug}
|
||||
Version: 2.37
|
||||
Release: 20%{?dist}
|
||||
Release: 21%{?dist}
|
||||
License: GPLv3+
|
||||
URL: https://sourceware.org/binutils
|
||||
|
||||
@ -947,6 +947,9 @@ exit 0
|
||||
|
||||
#----------------------------------------------------------------------------
|
||||
%changelog
|
||||
* Thu Jun 30 2022 Nick Clifton <nickc@redhat.com> - 2.37-21
|
||||
- Fix a problem honouring readelf's -wE and -wN command line options.
|
||||
|
||||
* Wed Jun 8 2022 Yara Ahmad <yahmad@redhat.com> - 2.37-20
|
||||
- Fix bug in binutils.spec file that was causing the wrong linker flags to be used.
|
||||
- Change the ld man page so that it says that --enable-new-dtags is the default. (#2090818)
|
||||
|
Loading…
Reference in New Issue
Block a user