- Rebase on 2.20 tarball.

- Remove redundant moxie patch.
- Remove redundant unique is global patch.
- Remove redundant cxxfilt java doc patch.
This commit is contained in:
Nicholas Clifton 2009-10-12 11:18:37 +00:00
parent 002f77263a
commit 2055b15849
15 changed files with 177 additions and 231 deletions

View File

@ -1 +1 @@
binutils-2.19.51.0.14.tar.bz2 binutils-2.20.51.0.2.tar.bz2

View File

@ -1,40 +0,0 @@
diff -rup ../binutils-2.19.51.0.11.orig/bfd/elfcode.h bfd/elfcode.h
--- ../binutils-2.19.51.0.11.orig/bfd/elfcode.h 2009-07-14 11:23:27.000000000 +0100
+++ bfd/elfcode.h 2009-07-14 11:33:56.000000000 +0100
@@ -1170,6 +1170,24 @@ elf_checksum_contents (bfd *abfd,
if (i_shdr.contents)
(*process) (i_shdr.contents, i_shdr.sh_size, arg);
+ else
+ {
+ asection *sec;
+
+ sec = bfd_section_from_elf_index (abfd, count);
+ if (sec != NULL)
+ {
+ if (sec->contents == NULL)
+ {
+ /* Force rereading from file. */
+ sec->flags &= ~SEC_IN_MEMORY;
+ if (! bfd_malloc_and_get_section (abfd, sec, & sec->contents))
+ continue;
+ }
+ if (sec->contents != NULL)
+ (*process) (sec->contents, i_shdr.sh_size, arg);
+ }
+ }
}
return TRUE;
diff -rup ../binutils-2.19.51.0.11.orig/bfd/section.c bfd/section.c
--- ../binutils-2.19.51.0.11.orig/bfd/section.c 2009-07-14 11:23:27.000000000 +0100
+++ bfd/section.c 2009-07-14 11:33:26.000000000 +0100
@@ -1477,7 +1477,7 @@ bfd_malloc_and_get_section (bfd *abfd, s
if (sz == 0)
return TRUE;
- p = bfd_malloc (sec->rawsize > sec->size ? sec->rawsize : sec->size);
+ p = bfd_zmalloc (sec->rawsize > sec->size ? sec->rawsize : sec->size);
if (p == NULL)
return FALSE;
*buf = p;

View File

@ -1,38 +0,0 @@
diff -rup ../binutils-2.19.51.0.10.orig/bfd/configure ./bfd/configure
--- ../binutils-2.19.51.0.10.orig/bfd/configure 2009-06-22 16:16:08.000000000 +0100
+++ ./bfd/configure 2009-06-22 16:16:14.000000000 +0100
@@ -13924,11 +13924,13 @@ if test "x${ac_cv_sizeof_long}" = "x8";
BFD_HOST_64BIT_LONG=1
test -n "${HOST_64BIT_TYPE}" || HOST_64BIT_TYPE="long"
test -n "${HOST_U_64BIT_TYPE}" || HOST_U_64BIT_TYPE="unsigned long"
-elif test "x${ac_cv_sizeof_long_long}" = "x8"; then
+fi
+if test "x${ac_cv_sizeof_long_long}" = "x8"; then
BFD_HOST_64BIT_LONG_LONG=1
test -n "${HOST_64BIT_TYPE}" || HOST_64BIT_TYPE="long long"
test -n "${HOST_U_64BIT_TYPE}" || HOST_U_64BIT_TYPE="unsigned long long"
- if test "x${ac_cv_sizeof_void_p}" = "x8"; then
+ if test "x${ac_cv_sizeof_void_p}" = "x8" \
+ -a "x${ac_cv_sizeof_long}" != "x8"; then
BFD_HOSTPTR_T="unsigned long long"
fi
fi
diff -rup ../binutils-2.19.51.0.10.orig/bfd/configure.in ./bfd/configure.in
--- ../binutils-2.19.51.0.10.orig/bfd/configure.in 2009-06-22 16:16:08.000000000 +0100
+++ ./bfd/configure.in 2009-06-22 16:16:14.000000000 +0100
@@ -172,11 +172,13 @@ if test "x${ac_cv_sizeof_long}" = "x8";
BFD_HOST_64BIT_LONG=1
test -n "${HOST_64BIT_TYPE}" || HOST_64BIT_TYPE="long"
test -n "${HOST_U_64BIT_TYPE}" || HOST_U_64BIT_TYPE="unsigned long"
-elif test "x${ac_cv_sizeof_long_long}" = "x8"; then
+fi
+if test "x${ac_cv_sizeof_long_long}" = "x8"; then
BFD_HOST_64BIT_LONG_LONG=1
test -n "${HOST_64BIT_TYPE}" || HOST_64BIT_TYPE="long long"
test -n "${HOST_U_64BIT_TYPE}" || HOST_U_64BIT_TYPE="unsigned long long"
- if test "x${ac_cv_sizeof_void_p}" = "x8"; then
+ if test "x${ac_cv_sizeof_void_p}" = "x8" \
+ -a "x${ac_cv_sizeof_long}" != "x8"; then
BFD_HOSTPTR_T="unsigned long long"
fi
fi

View File

@ -1,17 +0,0 @@
--- ../binutils-2.19.51.0.11.orig/bfd/elf32-moxie.c 2009-07-14 11:42:48.000000000 +0100
+++ bfd/elf32-moxie.c 2009-07-14 12:28:32.000000000 +0100
@@ -242,12 +242,12 @@ moxie_elf_relocate_section (bfd *output_
}
else
{
- bfd_boolean unresolved_reloc, warned;
+ bfd_boolean unresolved_reloc, warned, ignored;
RELOC_FOR_GLOBAL_SYMBOL (info, input_bfd, input_section, rel,
r_symndx, symtab_hdr, sym_hashes,
h, sec, relocation,
- unresolved_reloc, warned);
+ unresolved_reloc, warned, ignored);
name = h->root.root.string;
}

View File

@ -1,28 +0,0 @@
http://sourceware.org/ml/binutils/2009-09/msg00701.html
http://sourceware.org/ml/binutils-cvs/2009-09/msg00335.html
### binutils/ChangeLog 2009/09/29 14:17:04 1.1543
### binutils/ChangeLog 2009/09/29 15:34:08 1.1544
## -1,3 +1,8 @@
+2009-09-29 Nick Clifton <nickc@redhat.com>
+
+ * doc/binutils.texi (c++filt): Remove spurious description of
+ nonexistent --java command line switch for cxxfilt.
+
2009-09-29 DJ Delorie <dj@redhat.com>
* readelf.c: Add support for RX target.
--- binutils/doc/binutils.texi 2009/09/11 11:16:19 1.154
+++ binutils/doc/binutils.texi 2009/09/29 15:34:08 1.155
@@ -2814,11 +2814,6 @@
name @code{_foo}. This option removes the initial underscore. Whether
@command{c++filt} removes the underscore by default is target dependent.
-@item -j
-@itemx --java
-Prints demangled names using Java syntax. The default is to use C++
-syntax.
-
@item -n
@itemx --no-strip-underscores
Do not remove the initial underscore.

View File

@ -1,42 +0,0 @@
2009-08-06 Jakub Jelinek <jakub@redhat.com>
Alan Modra <amodra@bigpond.net.au>
PR binutils/10492
* elf.c (sym_is_global): Return true even for BSF_GNU_UNIQUE
symbols.
* elf32-mips.c (mips_elf_sym_is_global): Likewise.
* elfn32-mips.c (mips_elf_sym_is_global): Likewise.
--- bfd/elf.c.jj 2009-08-06 14:20:38.000000000 +0200
+++ bfd/elf.c 2009-08-06 14:41:06.000000000 +0200
@@ -3084,7 +3084,7 @@ sym_is_global (bfd *abfd, asymbol *sym)
if (bed->elf_backend_sym_is_global)
return (*bed->elf_backend_sym_is_global) (abfd, sym);
- return ((sym->flags & (BSF_GLOBAL | BSF_WEAK)) != 0
+ return ((sym->flags & (BSF_GLOBAL | BSF_WEAK | BSF_GNU_UNIQUE)) != 0
|| bfd_is_und_section (bfd_get_section (sym))
|| bfd_is_com_section (bfd_get_section (sym)));
}
--- bfd/elf32-mips.c.jj 2009-08-06 14:17:48.000000000 +0200
+++ bfd/elf32-mips.c 2009-08-06 14:41:52.000000000 +0200
@@ -1450,7 +1450,7 @@ mips_elf_sym_is_global (bfd *abfd ATTRIB
if (SGI_COMPAT (abfd))
return (sym->flags & BSF_SECTION_SYM) == 0;
else
- return ((sym->flags & (BSF_GLOBAL | BSF_WEAK)) != 0
+ return ((sym->flags & (BSF_GLOBAL | BSF_WEAK | BSF_GNU_UNIQUE)) != 0
|| bfd_is_und_section (bfd_get_section (sym))
|| bfd_is_com_section (bfd_get_section (sym)));
}
--- bfd/elfn32-mips.c.jj 2008-11-19 15:50:38.000000000 +0100
+++ bfd/elfn32-mips.c 2009-08-06 14:42:32.000000000 +0200
@@ -2289,7 +2289,7 @@ mips_elf_sym_is_global (bfd *abfd ATTRIB
if (SGI_COMPAT (abfd))
return (sym->flags & BSF_SECTION_SYM) == 0;
else
- return ((sym->flags & (BSF_GLOBAL | BSF_WEAK)) != 0
+ return ((sym->flags & (BSF_GLOBAL | BSF_WEAK | BSF_GNU_UNIQUE)) != 0
|| bfd_is_und_section (bfd_get_section (sym))
|| bfd_is_com_section (bfd_get_section (sym)));
}

View File

@ -0,0 +1,38 @@
--- ../binutils-2.20.51.0.2.orig/bfd/elfcode.h 2009-10-12 11:45:05.000000000 +0100
+++ bfd/elfcode.h 2009-10-12 11:47:14.000000000 +0100
@@ -1175,6 +1175,24 @@ elf_checksum_contents (bfd *abfd,
if (i_shdr.contents)
(*process) (i_shdr.contents, i_shdr.sh_size, arg);
+ else
+ {
+ asection *sec;
+
+ sec = bfd_section_from_elf_index (abfd, count);
+ if (sec != NULL)
+ {
+ if (sec->contents == NULL)
+ {
+ /* Force rereading from file. */
+ sec->flags &= ~SEC_IN_MEMORY;
+ if (! bfd_malloc_and_get_section (abfd, sec, & sec->contents))
+ continue;
+ }
+ if (sec->contents != NULL)
+ (*process) (sec->contents, i_shdr.sh_size, arg);
+ }
+ }
}
return TRUE;
--- ../binutils-2.20.51.0.2.orig/bfd/section.c 2009-10-12 11:45:05.000000000 +0100
+++ bfd/section.c 2009-10-12 11:48:44.000000000 +0100
@@ -1553,7 +1553,7 @@ bfd_malloc_and_get_section (bfd *abfd, s
return TRUE;
p = (bfd_byte *)
- bfd_malloc (sec->rawsize > sec->size ? sec->rawsize : sec->size);
+ bfd_zmalloc (sec->rawsize > sec->size ? sec->rawsize : sec->size);
if (p == NULL)
return FALSE;
*buf = p;

View File

@ -1,6 +1,5 @@
diff -rup ../binutils-2.19.51.0.10.orig/ld/ldmain.c ./ld/ldmain.c --- ../binutils-2.20.51.0.2.orig/ld/ldmain.c 2009-10-12 11:28:44.000000000 +0100
--- ../binutils-2.19.51.0.10.orig/ld/ldmain.c 2009-06-22 15:56:54.000000000 +0100 +++ ld/ldmain.c 2009-10-12 11:38:36.000000000 +0100
+++ ./ld/ldmain.c 2009-06-22 16:05:54.000000000 +0100
@@ -256,14 +256,6 @@ main (int argc, char **argv) @@ -256,14 +256,6 @@ main (int argc, char **argv)
command_line.warn_search_mismatch = TRUE; command_line.warn_search_mismatch = TRUE;
command_line.check_section_addresses = -1; command_line.check_section_addresses = -1;
@ -16,10 +15,9 @@ diff -rup ../binutils-2.19.51.0.10.orig/ld/ldmain.c ./ld/ldmain.c
/* We initialize DEMANGLING based on the environment variable /* We initialize DEMANGLING based on the environment variable
COLLECT_NO_DEMANGLE. The gcc collect2 program will demangle the COLLECT_NO_DEMANGLE. The gcc collect2 program will demangle the
output of the linker, unless COLLECT_NO_DEMANGLE is set in the output of the linker, unless COLLECT_NO_DEMANGLE is set in the
diff -rup ../binutils-2.19.51.0.10.orig/ld/ld.texinfo ./ld/ld.texinfo --- ../binutils-2.20.51.0.2.orig/ld/ld.texinfo 2009-10-12 11:28:44.000000000 +0100
--- ../binutils-2.19.51.0.10.orig/ld/ld.texinfo 2009-06-22 15:56:53.000000000 +0100 +++ ld/ld.texinfo 2009-10-12 11:38:36.000000000 +0100
+++ ./ld/ld.texinfo 2009-06-22 16:05:42.000000000 +0100 @@ -1140,10 +1140,7 @@ for a library that satisfies a symbol re
@@ -1118,10 +1118,7 @@ for a library that satisfies a symbol re
which is undefined at the point that the library was linked, or, if which is undefined at the point that the library was linked, or, if
the library is not found in the DT_NEEDED lists of other libraries the library is not found in the DT_NEEDED lists of other libraries
linked up to that point, a reference from another dynamic library. linked up to that point, a reference from another dynamic library.
@ -31,7 +29,7 @@ diff -rup ../binutils-2.19.51.0.10.orig/ld/ld.texinfo ./ld/ld.texinfo
@kindex --add-needed @kindex --add-needed
@kindex --no-add-needed @kindex --no-add-needed
@@ -1185,21 +1182,14 @@ When creating a shared library, bind ref @@ -1207,21 +1204,14 @@ When creating a shared library, bind ref
definition within the shared library, if any. Normally, it is possible definition within the shared library, if any. Normally, it is possible
for a program linked against a shared library to override the definition for a program linked against a shared library to override the definition
within the shared library. This option is only meaningful on ELF within the shared library. This option is only meaningful on ELF
@ -55,10 +53,9 @@ diff -rup ../binutils-2.19.51.0.10.orig/ld/ld.texinfo ./ld/ld.texinfo
@kindex --dynamic-list=@var{dynamic-list-file} @kindex --dynamic-list=@var{dynamic-list-file}
@item --dynamic-list=@var{dynamic-list-file} @item --dynamic-list=@var{dynamic-list-file}
diff -rup ../binutils-2.19.51.0.10.orig/ld/NEWS ./ld/NEWS --- ../binutils-2.20.51.0.2.orig/ld/NEWS 2009-10-12 11:28:44.000000000 +0100
--- ../binutils-2.19.51.0.10.orig/ld/NEWS 2009-06-22 15:56:54.000000000 +0100 +++ ld/NEWS 2009-10-12 11:38:36.000000000 +0100
+++ ./ld/NEWS 2009-06-22 16:04:15.000000000 +0100 @@ -64,11 +64,6 @@ Changes in 2.20:
@@ -55,11 +55,6 @@
For the switch --enable-runtime-pseudo-reloc it uses for 32-bit For the switch --enable-runtime-pseudo-reloc it uses for 32-bit
runtime pseudo relocation version one, for 64-bit the version two. runtime pseudo relocation version one, for 64-bit the version two.

View File

@ -1,7 +1,7 @@
diff -rup ../binutils-2.19.51.0.10.orig/bfd/configure ./bfd/configure diff -rup ../binutils-2.20.51.0.2.orig/bfd/configure ./bfd/configure
--- ../binutils-2.19.51.0.10.orig/bfd/configure 2009-06-22 15:56:55.000000000 +0100 --- ../binutils-2.20.51.0.2.orig/bfd/configure 2009-10-12 11:28:45.000000000 +0100
+++ ./bfd/configure 2009-06-22 15:58:46.000000000 +0100 +++ ./bfd/configure 2009-10-12 11:31:43.000000000 +0100
@@ -10137,10 +10137,34 @@ fi @@ -10670,10 +10670,34 @@ fi
# before this can be enabled. # before this can be enabled.
hardcode_into_libs=yes hardcode_into_libs=yes
@ -38,10 +38,10 @@ diff -rup ../binutils-2.19.51.0.10.orig/bfd/configure ./bfd/configure
# We used to test for /lib/ld.so.1 and disable shared libraries on # We used to test for /lib/ld.so.1 and disable shared libraries on
Only in ./bfd: configure.orig Only in ./bfd: configure.orig
diff -rup ../binutils-2.19.51.0.10.orig/binutils/configure ./binutils/configure diff -rup ../binutils-2.20.51.0.2.orig/binutils/configure ./binutils/configure
--- ../binutils-2.19.51.0.10.orig/binutils/configure 2009-06-22 15:56:54.000000000 +0100 --- ../binutils-2.20.51.0.2.orig/binutils/configure 2009-10-12 11:28:44.000000000 +0100
+++ ./binutils/configure 2009-06-22 15:58:46.000000000 +0100 +++ ./binutils/configure 2009-10-12 11:31:43.000000000 +0100
@@ -10362,10 +10362,34 @@ fi @@ -10461,10 +10461,34 @@ fi
# before this can be enabled. # before this can be enabled.
hardcode_into_libs=yes hardcode_into_libs=yes
@ -78,10 +78,10 @@ diff -rup ../binutils-2.19.51.0.10.orig/binutils/configure ./binutils/configure
# We used to test for /lib/ld.so.1 and disable shared libraries on # We used to test for /lib/ld.so.1 and disable shared libraries on
Only in ./binutils: configure.orig Only in ./binutils: configure.orig
diff -rup ../binutils-2.19.51.0.10.orig/gas/configure ./gas/configure diff -rup ../binutils-2.20.51.0.2.orig/gas/configure ./gas/configure
--- ../binutils-2.19.51.0.10.orig/gas/configure 2009-06-22 15:56:55.000000000 +0100 --- ../binutils-2.20.51.0.2.orig/gas/configure 2009-10-12 11:28:45.000000000 +0100
+++ ./gas/configure 2009-06-22 15:58:46.000000000 +0100 +++ ./gas/configure 2009-10-12 11:31:43.000000000 +0100
@@ -10330,10 +10330,34 @@ fi @@ -10418,10 +10418,34 @@ fi
# before this can be enabled. # before this can be enabled.
hardcode_into_libs=yes hardcode_into_libs=yes
@ -118,10 +118,10 @@ diff -rup ../binutils-2.19.51.0.10.orig/gas/configure ./gas/configure
# We used to test for /lib/ld.so.1 and disable shared libraries on # We used to test for /lib/ld.so.1 and disable shared libraries on
Only in ./gas: configure.orig Only in ./gas: configure.orig
diff -rup ../binutils-2.19.51.0.10.orig/gprof/configure ./gprof/configure diff -rup ../binutils-2.20.51.0.2.orig/gprof/configure ./gprof/configure
--- ../binutils-2.19.51.0.10.orig/gprof/configure 2009-06-22 15:56:54.000000000 +0100 --- ../binutils-2.20.51.0.2.orig/gprof/configure 2009-10-12 11:28:44.000000000 +0100
+++ ./gprof/configure 2009-06-22 15:58:46.000000000 +0100 +++ ./gprof/configure 2009-10-12 11:31:43.000000000 +0100
@@ -10422,10 +10422,34 @@ fi @@ -10356,10 +10356,34 @@ fi
# before this can be enabled. # before this can be enabled.
hardcode_into_libs=yes hardcode_into_libs=yes
@ -158,10 +158,10 @@ diff -rup ../binutils-2.19.51.0.10.orig/gprof/configure ./gprof/configure
# We used to test for /lib/ld.so.1 and disable shared libraries on # We used to test for /lib/ld.so.1 and disable shared libraries on
Only in ./gprof: configure.orig Only in ./gprof: configure.orig
diff -rup ../binutils-2.19.51.0.10.orig/ld/configure ./ld/configure diff -rup ../binutils-2.20.51.0.2.orig/ld/configure ./ld/configure
--- ../binutils-2.19.51.0.10.orig/ld/configure 2009-06-22 15:56:54.000000000 +0100 --- ../binutils-2.20.51.0.2.orig/ld/configure 2009-10-12 11:28:44.000000000 +0100
+++ ./ld/configure 2009-06-22 15:58:46.000000000 +0100 +++ ./ld/configure 2009-10-12 11:31:43.000000000 +0100
@@ -10622,10 +10622,34 @@ fi @@ -10806,10 +10806,34 @@ fi
# before this can be enabled. # before this can be enabled.
hardcode_into_libs=yes hardcode_into_libs=yes
@ -198,9 +198,9 @@ diff -rup ../binutils-2.19.51.0.10.orig/ld/configure ./ld/configure
# We used to test for /lib/ld.so.1 and disable shared libraries on # We used to test for /lib/ld.so.1 and disable shared libraries on
Only in ./ld: configure.orig Only in ./ld: configure.orig
diff -rup ../binutils-2.19.51.0.10.orig/libtool.m4 ./libtool.m4 diff -rup ../binutils-2.20.51.0.2.orig/libtool.m4 ./libtool.m4
--- ../binutils-2.19.51.0.10.orig/libtool.m4 2009-06-22 15:56:54.000000000 +0100 --- ../binutils-2.20.51.0.2.orig/libtool.m4 2009-10-12 11:28:44.000000000 +0100
+++ ./libtool.m4 2009-06-22 15:58:46.000000000 +0100 +++ ./libtool.m4 2009-10-12 11:31:43.000000000 +0100
@@ -2475,10 +2475,30 @@ linux* | k*bsd*-gnu | kopensolaris*-gnu) @@ -2475,10 +2475,30 @@ linux* | k*bsd*-gnu | kopensolaris*-gnu)
# before this can be enabled. # before this can be enabled.
hardcode_into_libs=yes hardcode_into_libs=yes
@ -233,11 +233,10 @@ diff -rup ../binutils-2.19.51.0.10.orig/libtool.m4 ./libtool.m4
fi fi
# We used to test for /lib/ld.so.1 and disable shared libraries on # We used to test for /lib/ld.so.1 and disable shared libraries on
Only in .: libtool.m4.orig diff -rup ../binutils-2.20.51.0.2.orig/opcodes/configure ./opcodes/configure
diff -rup ../binutils-2.19.51.0.10.orig/opcodes/configure ./opcodes/configure --- ../binutils-2.20.51.0.2.orig/opcodes/configure 2009-10-12 11:28:44.000000000 +0100
--- ../binutils-2.19.51.0.10.orig/opcodes/configure 2009-06-22 15:56:54.000000000 +0100 +++ ./opcodes/configure 2009-10-12 11:31:43.000000000 +0100
+++ ./opcodes/configure 2009-06-22 15:58:46.000000000 +0100 @@ -10406,10 +10406,34 @@ fi
@@ -10132,10 +10132,34 @@ fi
# before this can be enabled. # before this can be enabled.
hardcode_into_libs=yes hardcode_into_libs=yes

View File

@ -1,6 +1,6 @@
--- ../binutils-2.19.51.0.10.orig/bfd/elf64-ppc.c 2009-06-22 15:56:55.000000000 +0100 --- ../binutils-2.20.51.0.2.orig/bfd/elf64-ppc.c 2009-10-12 11:28:45.000000000 +0100
+++ ./bfd/elf64-ppc.c 2009-06-22 16:00:39.000000000 +0100 +++ bfd/elf64-ppc.c 2009-10-12 11:34:17.000000000 +0100
@@ -11466,7 +11466,12 @@ ppc64_elf_relocate_section (bfd *output_ @@ -11992,7 +11992,12 @@ ppc64_elf_relocate_section (bfd *output_
else if (!SYMBOL_REFERENCES_LOCAL (info, &h->elf) else if (!SYMBOL_REFERENCES_LOCAL (info, &h->elf)
&& !is_opd && !is_opd
&& r_type != R_PPC64_TOC) && r_type != R_PPC64_TOC)

View File

@ -0,0 +1,77 @@
diff -rup ../binutils-2.20.51.0.2.orig/bfd/configure bfd/configure
--- ../binutils-2.20.51.0.2.orig/bfd/configure 2009-10-12 11:45:05.000000000 +0100
+++ bfd/configure 2009-10-12 11:45:13.000000000 +0100
@@ -12694,11 +12694,13 @@ if test "x${ac_cv_sizeof_long}" = "x8";
BFD_HOST_64BIT_LONG=1
test -n "${HOST_64BIT_TYPE}" || HOST_64BIT_TYPE="long"
test -n "${HOST_U_64BIT_TYPE}" || HOST_U_64BIT_TYPE="unsigned long"
-elif test "x${ac_cv_sizeof_long_long}" = "x8"; then
+fi
+if test "x${ac_cv_sizeof_long_long}" = "x8"; then
BFD_HOST_64BIT_LONG_LONG=1
test -n "${HOST_64BIT_TYPE}" || HOST_64BIT_TYPE="long long"
test -n "${HOST_U_64BIT_TYPE}" || HOST_U_64BIT_TYPE="unsigned long long"
- if test "x${ac_cv_sizeof_void_p}" = "x8"; then
+ if test "x${ac_cv_sizeof_void_p}" = "x8" \
+ -a "x${ac_cv_sizeof_long}" != "x8"; then
BFD_HOSTPTR_T="unsigned long long"
fi
fi
diff -rup ../binutils-2.20.51.0.2.orig/bfd/configure.in bfd/configure.in
--- ../binutils-2.20.51.0.2.orig/bfd/configure.in 2009-10-12 11:45:05.000000000 +0100
+++ bfd/configure.in 2009-10-12 11:45:13.000000000 +0100
@@ -172,11 +172,13 @@ if test "x${ac_cv_sizeof_long}" = "x8";
BFD_HOST_64BIT_LONG=1
test -n "${HOST_64BIT_TYPE}" || HOST_64BIT_TYPE="long"
test -n "${HOST_U_64BIT_TYPE}" || HOST_U_64BIT_TYPE="unsigned long"
-elif test "x${ac_cv_sizeof_long_long}" = "x8"; then
+fi
+if test "x${ac_cv_sizeof_long_long}" = "x8"; then
BFD_HOST_64BIT_LONG_LONG=1
test -n "${HOST_64BIT_TYPE}" || HOST_64BIT_TYPE="long long"
test -n "${HOST_U_64BIT_TYPE}" || HOST_U_64BIT_TYPE="unsigned long long"
- if test "x${ac_cv_sizeof_void_p}" = "x8"; then
+ if test "x${ac_cv_sizeof_void_p}" = "x8" \
+ -a "x${ac_cv_sizeof_long}" != "x8"; then
BFD_HOSTPTR_T="unsigned long long"
fi
fi
diff -rup ../binutils-2.20.51.0.2.orig/bfd/configure.orig bfd/configure.orig
--- ../binutils-2.20.51.0.2.orig/bfd/configure.orig 2009-10-12 11:45:05.000000000 +0100
+++ bfd/configure.orig 2009-10-12 11:31:43.000000000 +0100
@@ -10670,10 +10670,34 @@ fi
# before this can be enabled.
hardcode_into_libs=yes
+ # find out which ABI we are using
+ libsuff=
+ case "$host_cpu" in
+ x86_64*|s390*|powerpc*|ppc*|sparc*)
+ echo 'int i;' > conftest.$ac_ext
+ if { (eval echo "$as_me:$LINENO: \"$ac_compile\"") >&5
+ (eval $ac_compile) 2>&5
+ ac_status=$?
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); }; then
+ case `/usr/bin/file conftest.$ac_objext` in
+ *64-bit*)
+ libsuff=64
+ if test x"$sys_lib_search_path_spec" = x"/lib /usr/lib /usr/local/lib"; then
+ sys_lib_search_path_spec="/lib${libsuff} /usr/lib${libsuff} /usr/local/lib${libsuff}"
+ fi
+ sys_lib_dlsearch_path_spec="/lib${libsuff} /usr/lib${libsuff}"
+ ;;
+ esac
+ fi
+ rm -rf conftest*
+ ;;
+ esac
+
# Append ld.so.conf contents to the search path
if test -f /etc/ld.so.conf; then
lt_ld_extra=`awk '/^include / { system(sprintf("cd /etc; cat %s 2>/dev/null", \$2)); skip = 1; } { if (!skip) print \$0; skip = 0; }' < /etc/ld.so.conf | $SED -e 's/#.*//;/^[ ]*hwcap[ ]/d;s/[:, ]/ /g;s/=[^=]*$//;s/=[^= ]* / /g;/^$/d' | tr '\n' ' '`
- sys_lib_dlsearch_path_spec="/lib /usr/lib $lt_ld_extra"
+ sys_lib_dlsearch_path_spec="/lib${libsuff} /usr/lib${libsuff} $lt_ld_extra"
fi
# We used to test for /lib/ld.so.1 and disable shared libraries on

View File

@ -1,6 +1,6 @@
--- ../binutils-2.19.51.0.10.orig/bfd/Makefile.am 2009-06-22 15:56:55.000000000 +0100 --- ../binutils-2.20.51.0.2.orig/bfd/Makefile.am 2009-10-12 11:28:45.000000000 +0100
+++ ./bfd/Makefile.am 2009-06-22 16:13:31.000000000 +0100 +++ bfd/Makefile.am 2009-10-12 11:42:24.000000000 +0100
@@ -1038,12 +1038,12 @@ bfdver.h: $(srcdir)/version.h $(srcdir)/ @@ -951,12 +951,12 @@ bfdver.h: $(srcdir)/version.h $(srcdir)/
report_bugs_to="\"$(REPORT_BUGS_TO)\"" ;\ report_bugs_to="\"$(REPORT_BUGS_TO)\"" ;\
if test "x$(RELEASE)" = x ; then \ if test "x$(RELEASE)" = x ; then \
bfd_version_date=`sed -n -e 's/.*DATE //p' < $(srcdir)/version.h` ;\ bfd_version_date=`sed -n -e 's/.*DATE //p' < $(srcdir)/version.h` ;\
@ -16,9 +16,9 @@
-e "s,@report_bugs_to@,$$report_bugs_to," \ -e "s,@report_bugs_to@,$$report_bugs_to," \
< $(srcdir)/version.h > $@; \ < $(srcdir)/version.h > $@; \
echo "$${bfd_soversion}" > libtool-soversion echo "$${bfd_soversion}" > libtool-soversion
--- ../binutils-2.19.51.0.10.orig/bfd/Makefile.in 2009-06-22 15:56:55.000000000 +0100 --- ../binutils-2.20.51.0.2.orig/bfd/Makefile.in 2009-10-12 11:28:45.000000000 +0100
+++ ./bfd/Makefile.in 2009-06-22 16:13:31.000000000 +0100 +++ bfd/Makefile.in 2009-10-12 11:42:24.000000000 +0100
@@ -1639,12 +1639,12 @@ bfdver.h: $(srcdir)/version.h $(srcdir)/ @@ -1978,12 +1978,12 @@ bfdver.h: $(srcdir)/version.h $(srcdir)/
report_bugs_to="\"$(REPORT_BUGS_TO)\"" ;\ report_bugs_to="\"$(REPORT_BUGS_TO)\"" ;\
if test "x$(RELEASE)" = x ; then \ if test "x$(RELEASE)" = x ; then \
bfd_version_date=`sed -n -e 's/.*DATE //p' < $(srcdir)/version.h` ;\ bfd_version_date=`sed -n -e 's/.*DATE //p' < $(srcdir)/version.h` ;\

View File

@ -16,23 +16,20 @@
Summary: A GNU collection of binary utilities Summary: A GNU collection of binary utilities
Name: %{?cross}binutils%{?_with_debug:-debug} Name: %{?cross}binutils%{?_with_debug:-debug}
Version: 2.19.51.0.14 Version: 2.20.51.0.2
Release: 32%{?dist} Release: 1%{?dist}
License: GPLv3+ License: GPLv3+
Group: Development/Tools Group: Development/Tools
URL: http://sources.redhat.com/binutils URL: http://sources.redhat.com/binutils
Source: ftp://ftp.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.bz2 Source: ftp://ftp.kernel.org/pub/linux/devel/binutils/binutils-%{version}.tar.bz2
Source2: binutils-2.19.50.0.1-output-format.sed Source2: binutils-2.19.50.0.1-output-format.sed
Patch01: binutils-2.19.51.0.10-libtool-lib64.patch Patch01: binutils-2.20.51.0.2-libtool-lib64.patch
Patch02: binutils-2.19.51.0.10-ppc64-pie.patch Patch02: binutils-2.20.51.0.2-ppc64-pie.patch
Patch03: binutils-2.19.50.0.1-ia64-lib64.patch Patch03: binutils-2.20.51.0.2-ia64-lib64.patch
Patch04: binutils-2.19.51.0.10-envvar-revert.patch Patch04: binutils-2.20.51.0.2-envvar-revert.patch
Patch05: binutils-2.19.51.0.10-version.patch Patch05: binutils-2.20.51.0.2-version.patch
Patch06: binutils-2.19.51.0.10-set-long-long.patch Patch06: binutils-2.20.51.0.2-set-long-long.patch
Patch07: binutils-2.19.51.0.10-build-id.patch Patch07: binutils-2.20.51.0.2-build-id.patch
Patch09: binutils-2.19.51.0.11-moxie.patch
Patch10: binutils-2.19.51.0.14-unique-is-global.patch
Patch11: binutils-2.19.51.0.14-cxxfilt-java-doc.patch
%if 0%{?_with_debug:1} %if 0%{?_with_debug:1}
# Define this if you want to skip the strip step and preserve debug info. # Define this if you want to skip the strip step and preserve debug info.
@ -104,9 +101,6 @@ to consider using libelf instead of BFD.
%patch05 -p0 -b .version~ %patch05 -p0 -b .version~
%patch06 -p0 -b .set-long-long~ %patch06 -p0 -b .set-long-long~
%patch07 -p0 -b .build-id~ %patch07 -p0 -b .build-id~
%patch09 -p0 -b .moxie~
%patch10 -p0 -b .unique-is-global~
%patch11 -p0 -b .cxxfilt-java-doc~
# We cannot run autotools as there is an exact requirement of autoconf-2.59. # We cannot run autotools as there is an exact requirement of autoconf-2.59.
@ -357,6 +351,12 @@ fi
%endif # %{isnative} %endif # %{isnative}
%changelog %changelog
* Mon Oct 12 2009 Nick Clifton <nickc@redhat.com> 2.20.51.0.2-1
- Rebase on 2.20 tarball.
- Remove redundant moxie patch.
- Remove redundant unique is global patch.
- Remove redundant cxxfilt java doc patch.
* Tue Sep 29 2009 Jan Kratochvil <jan.kratochvil@redhat.com> 2.19.51.0.14-32 * Tue Sep 29 2009 Jan Kratochvil <jan.kratochvil@redhat.com> 2.19.51.0.14-32
- Remove spurious description of nonexistent --java switch for cxxfilt. - Remove spurious description of nonexistent --java switch for cxxfilt.

View File

@ -1 +1 @@
e0b485a3ff9392da1351dc3fb61a3d10 binutils-2.19.51.0.14.tar.bz2 b01b185a5eab43190fb83efaeb2ffef9 binutils-2.20.51.0.2.tar.bz2