- Update to 2.18.50.0.9.

- Drop the ppc-only spu target pre-build stage (BZ 455242).
- Drop parsing elf64-i386 files for kdump PAE vmcore dumps (BZ 457189).
- New .spec BuildRequires zlib-devel (/-static) for compressed sections.
- Update .spec Buildroot to be more unique.
This commit is contained in:
Jan Kratochvil 2008-08-30 18:28:42 +00:00
parent 3b9eb32a70
commit 075413a631
7 changed files with 1311 additions and 1393 deletions

View File

@ -1 +1 @@
binutils-2.18.50.0.8.tar.bz2
binutils-2.18.50.0.9.tar.bz2

View File

@ -1,26 +0,0 @@
2008-07-29 Jan Kratochvil <jan.kratochvil@redhat.com>
Recognize elf64-i386 at least as elf64-little.
* elfcore.h (elf_core_file_p): Exclusion of existing arches for the
generic arch fallback now matches also the arch size.
--- bfd/elfcore.h 10 May 2008 01:58:17 -0000 1.27
+++ bfd/elfcore.h 29 Jul 2008 18:25:07 -0000
@@ -159,11 +159,12 @@ elf_core_file_p (bfd *abfd)
if ((*target_ptr)->flavour != bfd_target_elf_flavour)
continue;
back = xvec_get_elf_backend_data (*target_ptr);
- if (back->elf_machine_code == i_ehdrp->e_machine
- || (back->elf_machine_alt1 != 0
- && i_ehdrp->e_machine == back->elf_machine_alt1)
- || (back->elf_machine_alt2 != 0
- && i_ehdrp->e_machine == back->elf_machine_alt2))
+ if (ARCH_SIZE == back->s->arch_size
+ && (back->elf_machine_code == i_ehdrp->e_machine
+ || (back->elf_machine_alt1 != 0
+ && i_ehdrp->e_machine == back->elf_machine_alt1)
+ || (back->elf_machine_alt2 != 0
+ && i_ehdrp->e_machine == back->elf_machine_alt2)))
{
/* target_ptr is an ELF backend which matches this
object file, so reject the generic ELF target. */

View File

@ -1,46 +0,0 @@
2008-07-30 Jan Kratochvil <jan.kratochvil@redhat.com>
* Makefile.def: ld's spu_ovl.o depends on gas and binutils.
* Makefile.in: Regenerate.
--- Makefile.def 30 Jul 2008 15:03:54 -0000 1.92
+++ Makefile.def 30 Jul 2008 21:18:12 -0000
@@ -378,6 +378,9 @@ dependencies = { module=all-ld; on=all-b
dependencies = { module=all-ld; on=all-build-byacc; };
dependencies = { module=all-ld; on=all-build-flex; };
dependencies = { module=all-ld; on=all-intl; };
+// spu_ovl.o depends on both gas and binutils/bin2c
+dependencies = { module=all-ld; on=all-gas; };
+dependencies = { module=all-ld; on=all-binutils; };
dependencies = { module=configure-gold; on=configure-intl; };
dependencies = { module=all-gold; on=all-libiberty; };
dependencies = { module=all-gold; on=all-intl; };
--- Makefile.in 30 Jul 2008 15:03:54 -0000 1.285
+++ Makefile.in 30 Jul 2008 21:18:34 -0000
@@ -53308,6 +53308,26 @@ all-stageb3g2-ld: maybe-all-stageb3g2-in
all-stage4-ld: maybe-all-stage4-intl
all-stageprofile-ld: maybe-all-stageprofile-intl
all-stagefeedback-ld: maybe-all-stagefeedback-intl
+all-ld: maybe-all-gas
+
+all-stage1-ld: maybe-all-stage1-gas
+all-stage2-ld: maybe-all-stage2-gas
+all-stageb2g0-ld: maybe-all-stageb2g0-gas
+all-stage3-ld: maybe-all-stage3-gas
+all-stageb3g2-ld: maybe-all-stageb3g2-gas
+all-stage4-ld: maybe-all-stage4-gas
+all-stageprofile-ld: maybe-all-stageprofile-gas
+all-stagefeedback-ld: maybe-all-stagefeedback-gas
+all-ld: maybe-all-binutils
+
+all-stage1-ld: maybe-all-stage1-binutils
+all-stage2-ld: maybe-all-stage2-binutils
+all-stageb2g0-ld: maybe-all-stageb2g0-binutils
+all-stage3-ld: maybe-all-stage3-binutils
+all-stageb3g2-ld: maybe-all-stageb3g2-binutils
+all-stage4-ld: maybe-all-stage4-binutils
+all-stageprofile-ld: maybe-all-stageprofile-binutils
+all-stagefeedback-ld: maybe-all-stagefeedback-binutils
configure-gold: maybe-configure-intl
configure-stage1-gold: maybe-configure-stage1-intl

View File

@ -1,20 +0,0 @@
2008-07-30 Jan Kratochvil <jan.kratochvil@redhat.com>
* emultempl/spuelf.em: Abort on the missing required `spu_ovl.o'.
--- ld/emultempl/spuelf.em 19 Jun 2008 16:14:53 -0000 1.24
+++ ld/emultempl/spuelf.em 30 Jul 2008 18:28:25 -0000
@@ -57,7 +57,12 @@ char **my_argv;
static const char ovl_mgr[] = {
EOF
-../binutils/bin2c < ${srcdir}/emultempl/spu_ovl.o >> e${EMULATION_NAME}.c
+if ! ../binutils/bin2c < ${srcdir}/emultempl/spu_ovl.o >> e${EMULATION_NAME}.c
+then
+ echo >&2 "Missing ${srcdir}/emultempl/spu_ovl.o"
+ echo >&2 "You must build gas/as-new with --target=spu to build spu_ovl.o"
+ exit 1
+fi
fragment <<EOF
};

View File

@ -1,4 +1,3 @@
%define _default_patch_fuzz 2
# rpmbuild parameters:
# --define "binutils_target arm-linux-gnu" to create arm-linux-gnu-binutils.
# --with debug: Build without optimizations and without splitting the debuginfo.
@ -17,8 +16,8 @@
Summary: A GNU collection of binary utilities.
Name: %{?cross}binutils%{?_with_debug:-debug}
Version: 2.18.50.0.8
Release: 2%{?dist}
Version: 2.18.50.0.9
Release: 1%{?dist}
License: GPLv3+
Group: Development/Tools
URL: http://sources.redhat.com/binutils
@ -30,20 +29,25 @@ Patch4: binutils-2.18.50.0.6-ia64-lib64.patch
Patch5: binutils-2.18.50.0.6-build-fixes.patch
Patch6: binutils-2.18.50.0.8-symbolic-envvar-revert.patch
Patch7: binutils-2.18.50.0.6-version.patch
Patch8: binutils-2.18.50.0.8-spu_ovl-fatal.patch
Patch9: binutils-2.18.50.0.8-spu_ovl-dependency.patch
Patch10: binutils-2.18.50.0.8-generic-elf-size.patch
Patch11: binutils-2.18.50.0.8-largefile.patch
Patch11: binutils-2.18.50.0.9-largefile.patch
%if 0%{?_with_debug:1}
# Define this if you want to skip the strip step and preserve debug info.
# Useful for testing.
%define __debug_install_post : > %{_builddir}/%{?buildsubdir}/debugfiles.list
%define debug_package %{nil}
%define run_testsuite 0%{?_with_testsuite:1}
%else
%define run_testsuite 0%{!?_without_testsuite:1}
%endif
Buildroot: %{_tmppath}/binutils-root
BuildRequires: texinfo >= 4.0, dejagnu, gettext, flex, bison, automake, autoconf
Buildroot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
BuildRequires: texinfo >= 4.0, dejagnu, gettext, flex, bison, zlib-devel
# Required for: ld-bootstrap/bootstrap.exp bootstrap with --static
# It should not be required for: ld-elf/elf.exp static {preinit,init,fini} array
%if %{run_testsuite}
BuildRequires: zlib-static
%endif
Conflicts: gcc-c++ < 4.0.0
Prereq: /sbin/install-info
%ifarch ia64
@ -93,9 +97,6 @@ to consider using libelf instead of BFD.
%patch5 -p0 -b .build-fixes~
%patch6 -p0 -b .symbolic-envvar-revert~
%patch7 -p0 -b .version~
%patch8 -p0 -b .spu_ovl-fatal~
%patch9 -p0 -b .spu_ovl-dependency~
%patch10 -p0 -b .generic-elf-size~
%patch11 -p0 -b .largefile~
# We cannot run autotools as there is an exact requirement of autoconf-2.59.
@ -138,18 +139,6 @@ esac
case %{binutils_target} in ppc*|ppc64*)
CARGS="$CARGS --enable-targets=spu"
# This file is present in CVS but missing in H. J. Lu's snapshots.
# To include it for --enable-targets=spu we need to build gas by --target=spu.
! test -f ld/emultempl/spu_ovl.o
mkdir build-spu
cd build-spu
CFLAGS="${CFLAGS:-%optflags} -O0 -s" ../configure \
--target=spu --disable-shared --enable-static --disable-werror \
--with-bugurl=http://bugzilla.redhat.com/bugzilla/
make %{_smp_mflags} all
cd ..
test -f ld/emultempl/spu_ovl.o
rm -rf build-spu
;;
esac
@ -188,7 +177,7 @@ make %{_smp_mflags} tooldir=%{_prefix} info
# Do not use %%check as it is run after %%install where libbfd.so is rebuild
# with -fvisibility=hidden no longer being usable in its shared form.
%if 0%{?_without_testsuite:1} || (0%{!?_with_testsuite:1} && 0%{?_with_debug:1})
%if !%{run_testsuite}
echo ====================TESTSUITE DISABLED=========================
%else
make -k check < /dev/null > check.log 2>&1 || :
@ -334,6 +323,13 @@ fi
%endif # %{isnative}
%changelog
* Sat Aug 30 2008 Jan Kratochvil <jan.kratochvil@redhat.com> 2.18.50.0.9-1
- Update to 2.18.50.0.9.
- Drop the ppc-only spu target pre-build stage (BZ 455242).
- Drop parsing elf64-i386 files for kdump PAE vmcore dumps (BZ 457189).
- New .spec BuildRequires zlib-devel (/-static) for compressed sections.
- Update .spec Buildroot to be more unique.
* Fri Aug 1 2008 Jan Kratochvil <jan.kratochvil@redhat.com> 2.18.50.0.8-2
- Fix parsing elf64-i386 files for kdump PAE vmcore dumps (BZ 457189).
- Turn on 64-bit BFD support for i386, globally enable AC_SYS_LARGEFILE.

View File

@ -1 +1 @@
a49df3481468f281f42afbf915e10db2 binutils-2.18.50.0.8.tar.bz2
68e3510d9c790b134450c0a243c251cd binutils-2.18.50.0.9.tar.bz2