Merge remote-tracking branch 'origin/main' into epel8
This commit is contained in:
commit
ebfc21e784
41
baresip-2.0.1-time_h.patch
Normal file
41
baresip-2.0.1-time_h.patch
Normal file
@ -0,0 +1,41 @@
|
||||
From 17029c9bed0648570b5bb53dee3359899f13e93a Mon Sep 17 00:00:00 2001
|
||||
From: Robert Scheck <robert@fedoraproject.org>
|
||||
Date: Mon, 28 Mar 2022 22:20:13 +0200
|
||||
Subject: [PATCH] Avoid undeclared 'CLOCK_REALTIME' on RHEL/CentOS 7 (fixes
|
||||
#1781)
|
||||
|
||||
Build-time failure without this patch:
|
||||
|
||||
src/audio.c: In function 'rx_thread':
|
||||
src/audio.c:746:3: warning: implicit declaration of function 'clock_gettime'; did you mean 'calc_ptime'? [-Wimplicit-function-declaration]
|
||||
clock_gettime(CLOCK_REALTIME, &ts);
|
||||
^~~~~~~~~~~~~
|
||||
calc_ptime
|
||||
src/audio.c:746:3: warning: nested extern declaration of 'clock_gettime' [-Wnested-externs]
|
||||
src/audio.c:746:17: error: 'CLOCK_REALTIME' undeclared (first use in this function)
|
||||
clock_gettime(CLOCK_REALTIME, &ts);
|
||||
^~~~~~~~~~~~~~
|
||||
---
|
||||
src/audio.c | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/src/audio.c b/src/audio.c
|
||||
index 67af6f0e7..ce329778b 100644
|
||||
--- a/src/audio.c
|
||||
+++ b/src/audio.c
|
||||
@@ -6,6 +6,7 @@
|
||||
*/
|
||||
#define _DEFAULT_SOURCE 1
|
||||
#define _BSD_SOURCE 1
|
||||
+#define _POSIX_C_SOURCE 199309L
|
||||
#include <string.h>
|
||||
#include <stdlib.h>
|
||||
#ifdef HAVE_UNISTD_H
|
||||
@@ -17,6 +18,7 @@
|
||||
#if defined(HAVE_PTHREAD) && defined(WIN32)
|
||||
#include <pthread_time.h> /* needs mingw-w64 winpthreads */
|
||||
#endif
|
||||
+#include <time.h>
|
||||
#include <re.h>
|
||||
#include <rem.h>
|
||||
#include <baresip.h>
|
15
baresip.spec
15
baresip.spec
@ -1,6 +1,6 @@
|
||||
Summary: Modular SIP user-agent with audio and video support
|
||||
Name: baresip
|
||||
Version: 2.0.0
|
||||
Version: 2.0.1
|
||||
Release: 1%{?dist}
|
||||
License: BSD
|
||||
URL: https://github.com/baresip/baresip
|
||||
@ -11,10 +11,11 @@ Source11: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/1e1d6921
|
||||
Source12: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/COPYING#/COPYING.adwaita-icon-theme
|
||||
Source13: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/COPYING_CCBYSA3#/COPYING_CCBYSA3.adwaita-icon-theme
|
||||
Source14: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/COPYING_LGPL#/COPYING_LGPL.adwaita-icon-theme
|
||||
Patch0: https://github.com/baresip/baresip/commit/17029c9bed0648570b5bb53dee3359899f13e93a.patch#/baresip-2.0.1-time_h.patch
|
||||
BuildRequires: make
|
||||
BuildRequires: gcc
|
||||
BuildRequires: libre-devel >= 2.1.0
|
||||
BuildRequires: librem-devel >= 1.0.0
|
||||
BuildRequires: libre-devel >= 2.2.0
|
||||
BuildRequires: librem-devel >= 2.0.0
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 8
|
||||
BuildRequires: openssl-devel >= 1.1.0
|
||||
%else
|
||||
@ -95,7 +96,6 @@ Summary: D-BUS communication channel control module for baresip
|
||||
BuildRequires: %{_bindir}/gdbus-codegen
|
||||
BuildRequires: pkgconfig(glib-2.0)
|
||||
BuildRequires: pkgconfig(gio-unix-2.0)
|
||||
BuildRequires: pandoc
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description ctrl_dbus
|
||||
@ -365,8 +365,7 @@ This module provides the X11 video output driver.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
# https://github.com/baresip/baresip/issues/1770
|
||||
sed -e '/^\$(MOD)\.html/d' -i modules/ctrl_dbus/module.mk
|
||||
%patch0 -p1 -b .time_h
|
||||
|
||||
%build
|
||||
%if 0%{?rhel} == 7
|
||||
@ -504,7 +503,6 @@ gtk-update-icon-cache --force %{_datadir}/icons/Adwaita &>/dev/null || :
|
||||
%{_libdir}/%{name}/modules/codec2.so
|
||||
|
||||
%files ctrl_dbus
|
||||
%doc modules/ctrl_dbus/ctrl_dbus.html
|
||||
%{_libdir}/%{name}/modules/ctrl_dbus.so
|
||||
|
||||
%files g722
|
||||
@ -585,6 +583,9 @@ gtk-update-icon-cache --force %{_datadir}/icons/Adwaita &>/dev/null || :
|
||||
%{_libdir}/%{name}/modules/x11.so
|
||||
|
||||
%changelog
|
||||
* Mon Mar 28 2022 Robert Scheck <robert@fedoraproject.org> 2.0.1-1
|
||||
- Upgrade to 2.0.1 (#2068919)
|
||||
|
||||
* Sun Mar 13 2022 Robert Scheck <robert@fedoraproject.org> 2.0.0-1
|
||||
- Upgrade to 2.0.0 (#2063451)
|
||||
|
||||
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (baresip-2.0.0.tar.gz) = 6a02b423189a1a5bc267acd5a8162919b30cc2a88acd4fa571b12e2bf8c40abd7757e32742b1824957731bce79680abfa9078271de1865d7a90fd84094e398a3
|
||||
SHA512 (baresip-2.0.1.tar.gz) = e7359354b1297308a129bc4c7b67257020eba45a0cf64cb5321e5e47c50cf27c75ba6c11b46accac8bbb31e544c46c39a9588bc4007dec9d29b1440a54abf604
|
||||
SHA512 (call-incoming-symbolic.svg) = 49b6422efff9986dd4a18b34df4ab185b01b46c44ab5b8c1d45ab1ca25694cb42e73428b0a69e5fe2eb61c4e7a7aba9c0df82b5e0290f45950f3942be63bf987
|
||||
SHA512 (call-outgoing-symbolic.svg) = 142cf668d977e3a709d3c13e01d86fdd09e501affd1756df3000de84581c55b3b5082758b32a73ae0e47f45233cc7e55609f3e54effbba01666ca97d5a55fdaa
|
||||
SHA512 (COPYING.adwaita-icon-theme) = e8963bab4d94d9fbcfc930b95164afff9502e4e53209104f4836fcd6dab2c2e9f105c9f9a17b43bc9502903c9c7b2e0880dacf2339cbe110a19654f13742e20a
|
||||
|
Loading…
Reference in New Issue
Block a user