Merge remote-tracking branch 'origin/main' into epel8
This commit is contained in:
commit
e51a0e68cb
61
baresip-2.9.0-gtk.patch
Normal file
61
baresip-2.9.0-gtk.patch
Normal file
@ -0,0 +1,61 @@
|
||||
From 7ee4a769aaa1e3899b536b724cc854dd327ae865 Mon Sep 17 00:00:00 2001
|
||||
From: mbattista <m0battista@gmail.com>
|
||||
Date: Mon, 7 Nov 2022 20:20:45 +0100
|
||||
Subject: [PATCH] gtk: fixes issue #2315 and GTK errors on quit (#2316)
|
||||
|
||||
---
|
||||
modules/gtk/gtk_mod.c | 13 ++++++++-----
|
||||
1 file changed, 8 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/modules/gtk/gtk_mod.c b/modules/gtk/gtk_mod.c
|
||||
index f3cf82603..c359a40f1 100644
|
||||
--- a/modules/gtk/gtk_mod.c
|
||||
+++ b/modules/gtk/gtk_mod.c
|
||||
@@ -131,9 +131,6 @@ static void menu_on_quit(GtkMenuItem *menuItem, gpointer arg)
|
||||
struct gtk_mod *mod = arg;
|
||||
(void)menuItem;
|
||||
|
||||
- gtk_widget_destroy(GTK_WIDGET(mod->app_menu));
|
||||
- g_object_unref(G_OBJECT(mod->status_icon));
|
||||
-
|
||||
mqueue_push(mod->mq, MQ_QUIT, 0);
|
||||
info("quit from gtk\n");
|
||||
}
|
||||
@@ -772,12 +769,15 @@ static gboolean status_icon_on_button_press(GtkStatusIcon *status_icon,
|
||||
int gtk_mod_connect(struct gtk_mod *mod, const char *uri)
|
||||
{
|
||||
char *uric = NULL;
|
||||
+ struct pl url_pl;
|
||||
int err = 0;
|
||||
|
||||
+ pl_set_str(&url_pl, uri);
|
||||
if (!mod)
|
||||
return ENOMEM;
|
||||
|
||||
- err = account_uri_complete_strdup(ua_account(mod->ua_cur), &uric, uri);
|
||||
+ err = account_uri_complete_strdup(ua_account(mod->ua_cur),
|
||||
+ &uric, &url_pl);
|
||||
if (err)
|
||||
goto out;
|
||||
|
||||
@@ -793,8 +793,10 @@ int gtk_mod_connect_attended(struct gtk_mod *mod, const char *uri,
|
||||
{
|
||||
struct attended_transfer_store *ats;
|
||||
char *uric = NULL;
|
||||
+ struct pl url_pl;
|
||||
int err = 0;
|
||||
|
||||
+ pl_set_str(&url_pl, uri);
|
||||
if (!mod)
|
||||
return ENOMEM;
|
||||
|
||||
@@ -802,7 +804,8 @@ int gtk_mod_connect_attended(struct gtk_mod *mod, const char *uri,
|
||||
if (!ats)
|
||||
return ENOMEM;
|
||||
|
||||
- err = account_uri_complete_strdup(ua_account(mod->ua_cur), &uric, uri);
|
||||
+ err = account_uri_complete_strdup(ua_account(mod->ua_cur),
|
||||
+ &uric, &url_pl);
|
||||
if (err)
|
||||
goto out;
|
||||
|
12
baresip.spec
12
baresip.spec
@ -1,7 +1,7 @@
|
||||
Summary: Modular SIP user-agent with audio and video support
|
||||
Name: baresip
|
||||
Version: 2.9.0
|
||||
Release: 1%{?dist}
|
||||
Release: 3%{?dist}
|
||||
License: BSD-3-Clause
|
||||
URL: https://github.com/baresip/baresip
|
||||
Source0: https://github.com/baresip/baresip/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||
@ -11,6 +11,7 @@ Source11: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/1e1d6921
|
||||
Source12: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/COPYING#/COPYING.adwaita-icon-theme
|
||||
Source13: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/COPYING_CCBYSA3#/COPYING_CCBYSA3.adwaita-icon-theme
|
||||
Source14: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/COPYING_LGPL#/COPYING_LGPL.adwaita-icon-theme
|
||||
Patch0: https://github.com/baresip/baresip/commit/7ee4a769aaa1e3899b536b724cc854dd327ae865.patch#/baresip-2.9.0-gtk.patch
|
||||
BuildRequires: cmake
|
||||
%if 0%{?rhel} && 0%{?rhel} < 8
|
||||
BuildRequires: cmake3
|
||||
@ -156,7 +157,7 @@ BuildRequires: pkgconfig(gtk+-3.0) >= 3.0
|
||||
BuildRequires: pkgconfig(glib-2.0) >= 2.32
|
||||
BuildRequires: desktop-file-utils
|
||||
%if 0%{?rhel} == 7 || 0%{?rhel} == 8
|
||||
License: BSD and (LGPLv3+ or CC-BY-SA)
|
||||
License: BSD-3-Clause AND (LGPL-3.0-or-later OR CC-BY-SA-3.0)
|
||||
BuildRequires: librsvg2
|
||||
BuildRequires: /usr/bin/gtk-encode-symbolic-svg
|
||||
Requires: adwaita-icon-theme < 3.31.91-1
|
||||
@ -351,6 +352,7 @@ This module provides the X11 video output driver.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .gtk
|
||||
|
||||
%build
|
||||
%if 0%{?rhel} && 0%{?rhel} < 8
|
||||
@ -561,6 +563,12 @@ gtk-update-icon-cache --force %{_datadir}/icons/Adwaita &>/dev/null || :
|
||||
%{_libdir}/%{name}/modules/x11.so
|
||||
|
||||
%changelog
|
||||
* Tue Nov 08 2022 Robert Scheck <robert@fedoraproject.org> 2.9.0-3
|
||||
- Added upstream patch to fix GTK+ dial segfault regression
|
||||
|
||||
* Mon Nov 07 2022 Richard Shaw <hobbes1069@gmail.com> - 2.9.0-2
|
||||
- Rebuild for updated codec2.
|
||||
|
||||
* Tue Nov 01 2022 Robert Scheck <robert@fedoraproject.org> 2.9.0-1
|
||||
- Upgrade to 2.9.0 (#2139174)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user