Upgrade to 3.10.0 (#2268424)
This commit is contained in:
parent
34bade78f1
commit
b6237125e9
@ -1,45 +0,0 @@
|
||||
From 04efa525e7909196fe4b410150267935e36150c7 Mon Sep 17 00:00:00 2001
|
||||
From: Robert Scheck <robert@fedoraproject.org>
|
||||
Date: Fri, 2 Feb 2024 00:41:37 +0100
|
||||
Subject: [PATCH] cmake: add /usr/{local,}/include/re and
|
||||
/usr/{local,}/lib{64,} to FindRE.cmake (fixes #2899)
|
||||
|
||||
---
|
||||
cmake/FindRE.cmake | 23 ++++++++++++++++++-----
|
||||
1 file changed, 18 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/cmake/FindRE.cmake b/cmake/FindRE.cmake
|
||||
index 2e36c90a4..4272fff36 100644
|
||||
--- a/cmake/FindRE.cmake
|
||||
+++ b/cmake/FindRE.cmake
|
||||
@@ -1,12 +1,25 @@
|
||||
find_package(PkgConfig QUIET)
|
||||
pkg_check_modules(PC_LIBRE QUIET libre)
|
||||
|
||||
-find_path(RE_INCLUDE_DIR re.h
|
||||
- HINTS ../re/include ${PC_LIBRE_INCLUDEDIR} ${PC_LIBRE_INCLUDE_DIRS})
|
||||
+find_path(RE_INCLUDE_DIR
|
||||
+ NAME re.h
|
||||
+ HINTS
|
||||
+ ../re/include
|
||||
+ ${PC_LIBRE_INCLUDEDIR}
|
||||
+ ${PC_LIBRE_INCLUDE_DIRS}
|
||||
+ PATHS /usr/local/include/re /usr/include/re
|
||||
+)
|
||||
|
||||
-find_library(RE_LIBRARY NAMES re libre re-static
|
||||
- HINTS ../re ../re/build ../re/build/Debug
|
||||
- ${PC_LIBRE_LIBDIR} ${PC_LIBRE_LIBRARY_DIRS})
|
||||
+find_library(RE_LIBRARY
|
||||
+ NAMES re libre re-static
|
||||
+ HINTS
|
||||
+ ../re
|
||||
+ ../re/build
|
||||
+ ../re/build/Debug
|
||||
+ ${PC_LIBRE_LIBDIR}
|
||||
+ ${PC_LIBRE_LIBRARY_DIRS}
|
||||
+ PATHS /usr/local/lib64 /usr/lib64 /usr/local/lib /usr/lib
|
||||
+)
|
||||
|
||||
include(FindPackageHandleStandardArgs)
|
||||
find_package_handle_standard_args(RE DEFAULT_MSG RE_LIBRARY RE_INCLUDE_DIR)
|
15
baresip.spec
15
baresip.spec
@ -1,7 +1,7 @@
|
||||
Summary: Modular SIP user-agent with audio and video support
|
||||
Name: baresip
|
||||
Version: 3.9.0
|
||||
Release: 2%{?dist}
|
||||
Version: 3.10.0
|
||||
Release: 1%{?dist}
|
||||
License: BSD-3-Clause
|
||||
URL: https://github.com/baresip/baresip
|
||||
Source0: https://github.com/baresip/baresip/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||
@ -11,14 +11,13 @@ Source11: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/1e1d6921
|
||||
Source12: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/COPYING#/COPYING.adwaita-icon-theme
|
||||
Source13: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/COPYING_CCBYSA3#/COPYING_CCBYSA3.adwaita-icon-theme
|
||||
Source14: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/COPYING_LGPL#/COPYING_LGPL.adwaita-icon-theme
|
||||
Patch0: https://github.com/baresip/baresip/pull/2900/commits/04efa525e7909196fe4b410150267935e36150c7.patch#/baresip-3.8.0-cmake-findre.patch
|
||||
BuildRequires: cmake
|
||||
%if 0%{?rhel} && 0%{?rhel} < 8
|
||||
BuildRequires: cmake3
|
||||
%endif
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: libre-devel >= 3.9.0
|
||||
BuildRequires: libre-devel >= 3.10.0
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 9
|
||||
BuildRequires: openssl-devel
|
||||
%else
|
||||
@ -167,7 +166,7 @@ BuildRequires: desktop-file-utils
|
||||
%if 0%{?rhel} == 7 || 0%{?rhel} == 8
|
||||
License: BSD-3-Clause AND (LGPL-3.0-or-later OR CC-BY-SA-3.0)
|
||||
BuildRequires: librsvg2
|
||||
BuildRequires: /usr/bin/gtk-encode-symbolic-svg
|
||||
BuildRequires: %{_bindir}/gtk-encode-symbolic-svg
|
||||
Requires: adwaita-icon-theme < 3.31.91-1
|
||||
%else
|
||||
Requires: adwaita-icon-theme >= 3.31.91-1
|
||||
@ -384,6 +383,7 @@ This module provides the X11 video output driver.
|
||||
|
||||
%cmake \
|
||||
-DDEFAULT_CAFILE:PATH="%{_sysconfdir}/pki/tls/certs/ca-bundle.crt" \
|
||||
-DDEFAULT_CAPATH:PATH="%{_sysconfdir}/pki/tls/certs" \
|
||||
%if 0%{?fedora} || 0%{?rhel} > 8
|
||||
-DDEFAULT_AUDIO_DEVICE:STRING="pipewire" \
|
||||
%else
|
||||
@ -453,7 +453,7 @@ gtk-update-icon-cache --force %{_datadir}/icons/Adwaita &>/dev/null || :
|
||||
%license LICENSE
|
||||
%doc CHANGELOG.md docs/THANKS docs/examples
|
||||
%{_bindir}/%{name}
|
||||
%{_libdir}/lib%{name}.so.13*
|
||||
%{_libdir}/lib%{name}.so.14*
|
||||
%dir %{_libdir}/%{name}/
|
||||
%dir %{_libdir}/%{name}/modules/
|
||||
%{_libdir}/%{name}/modules/account.so
|
||||
@ -593,6 +593,9 @@ gtk-update-icon-cache --force %{_datadir}/icons/Adwaita &>/dev/null || :
|
||||
%{_libdir}/%{name}/modules/x11.so
|
||||
|
||||
%changelog
|
||||
* Sun Mar 10 2024 Robert Scheck <robert@fedoraproject.org> 3.10.0-1
|
||||
- Upgrade to 3.10.0 (#2268424)
|
||||
|
||||
* Wed Feb 07 2024 Pete Walter <pwalter@fedoraproject.org> - 3.9.0-2
|
||||
- Rebuild for libvpx 1.14.x
|
||||
|
||||
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (baresip-3.9.0.tar.gz) = 7e6bf2c68ae4dec60da7692527d511b7acf373e14c67c96591b7a5e02af7275ff7adde8a8c07af6ed98474b87357b734aae17fb337d4fad8353c253de56dc534
|
||||
SHA512 (baresip-3.10.0.tar.gz) = 62c977e4af72a401fc8d52a52afc7f3750070f539af8b41098c92dd5e1b6ed1e654bd7d35dda8704c255fbc13a5b2c75bb441818b86f4cf8ff95c1ffd87a0a8a
|
||||
SHA512 (call-incoming-symbolic.svg) = 49b6422efff9986dd4a18b34df4ab185b01b46c44ab5b8c1d45ab1ca25694cb42e73428b0a69e5fe2eb61c4e7a7aba9c0df82b5e0290f45950f3942be63bf987
|
||||
SHA512 (call-outgoing-symbolic.svg) = 142cf668d977e3a709d3c13e01d86fdd09e501affd1756df3000de84581c55b3b5082758b32a73ae0e47f45233cc7e55609f3e54effbba01666ca97d5a55fdaa
|
||||
SHA512 (COPYING.adwaita-icon-theme) = e8963bab4d94d9fbcfc930b95164afff9502e4e53209104f4836fcd6dab2c2e9f105c9f9a17b43bc9502903c9c7b2e0880dacf2339cbe110a19654f13742e20a
|
||||
|
Loading…
Reference in New Issue
Block a user