Added upstream patch to fix GTK+ dial history space error
This commit is contained in:
parent
012ae194b8
commit
9b61b8fa2f
22
baresip-2.9.0-gtk-dial-history.patch
Normal file
22
baresip-2.9.0-gtk-dial-history.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
From 6574b653af4e9c8284b6fbd902841a6fc22281bc Mon Sep 17 00:00:00 2001
|
||||||
|
From: mbattista <m0battista@gmail.com>
|
||||||
|
Date: Tue, 15 Nov 2022 08:13:22 +0100
|
||||||
|
Subject: [PATCH] Space at the beginning of sip: creates errors (#2329)
|
||||||
|
|
||||||
|
---
|
||||||
|
modules/gtk/gtk_mod.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/modules/gtk/gtk_mod.c b/modules/gtk/gtk_mod.c
|
||||||
|
index c359a40f1..77aa57bff 100644
|
||||||
|
--- a/modules/gtk/gtk_mod.c
|
||||||
|
+++ b/modules/gtk/gtk_mod.c
|
||||||
|
@@ -168,7 +168,7 @@ static void menu_on_dial_history(GtkMenuItem *menuItem, gpointer arg)
|
||||||
|
if (!label_1)
|
||||||
|
return;
|
||||||
|
|
||||||
|
- label_1[0] = ' ';
|
||||||
|
+ label_1 = label_1 + 1;
|
||||||
|
|
||||||
|
uri = strtok(label_1, "]");
|
||||||
|
gtk_mod_connect(mod, uri);
|
11
baresip.spec
11
baresip.spec
@ -1,7 +1,7 @@
|
|||||||
Summary: Modular SIP user-agent with audio and video support
|
Summary: Modular SIP user-agent with audio and video support
|
||||||
Name: baresip
|
Name: baresip
|
||||||
Version: 2.9.0
|
Version: 2.9.0
|
||||||
Release: 3%{?dist}
|
Release: 4%{?dist}
|
||||||
License: BSD-3-Clause
|
License: BSD-3-Clause
|
||||||
URL: https://github.com/baresip/baresip
|
URL: https://github.com/baresip/baresip
|
||||||
Source0: https://github.com/baresip/baresip/archive/v%{version}/%{name}-%{version}.tar.gz
|
Source0: https://github.com/baresip/baresip/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||||
@ -11,7 +11,8 @@ Source11: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/1e1d6921
|
|||||||
Source12: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/COPYING#/COPYING.adwaita-icon-theme
|
Source12: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/COPYING#/COPYING.adwaita-icon-theme
|
||||||
Source13: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/COPYING_CCBYSA3#/COPYING_CCBYSA3.adwaita-icon-theme
|
Source13: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/COPYING_CCBYSA3#/COPYING_CCBYSA3.adwaita-icon-theme
|
||||||
Source14: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/COPYING_LGPL#/COPYING_LGPL.adwaita-icon-theme
|
Source14: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/COPYING_LGPL#/COPYING_LGPL.adwaita-icon-theme
|
||||||
Patch0: https://github.com/baresip/baresip/commit/7ee4a769aaa1e3899b536b724cc854dd327ae865.patch#/baresip-2.9.0-gtk.patch
|
Patch0: https://github.com/baresip/baresip/commit/7ee4a769aaa1e3899b536b724cc854dd327ae865.patch#/baresip-2.9.0-gtk-dial-segfault.patch
|
||||||
|
Patch1: https://github.com/baresip/baresip/commit/6574b653af4e9c8284b6fbd902841a6fc22281bc.patch#/baresip-2.9.0-gtk-dial-history.patch
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
%if 0%{?rhel} && 0%{?rhel} < 8
|
%if 0%{?rhel} && 0%{?rhel} < 8
|
||||||
BuildRequires: cmake3
|
BuildRequires: cmake3
|
||||||
@ -352,7 +353,8 @@ This module provides the X11 video output driver.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .gtk
|
%patch0 -p1 -b .gtk-dial-segfault
|
||||||
|
%patch1 -p1 -b .gtk-dial-history
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%if 0%{?rhel} && 0%{?rhel} < 8
|
%if 0%{?rhel} && 0%{?rhel} < 8
|
||||||
@ -563,6 +565,9 @@ gtk-update-icon-cache --force %{_datadir}/icons/Adwaita &>/dev/null || :
|
|||||||
%{_libdir}/%{name}/modules/x11.so
|
%{_libdir}/%{name}/modules/x11.so
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Nov 17 2022 Robert Scheck <robert@fedoraproject.org> 2.9.0-4
|
||||||
|
- Added upstream patch to fix GTK+ dial history space error
|
||||||
|
|
||||||
* Tue Nov 08 2022 Robert Scheck <robert@fedoraproject.org> 2.9.0-3
|
* Tue Nov 08 2022 Robert Scheck <robert@fedoraproject.org> 2.9.0-3
|
||||||
- Added upstream patch to fix GTK+ dial segfault regression
|
- Added upstream patch to fix GTK+ dial segfault regression
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user