Merge remote-tracking branch 'origin/main' into epel8
This commit is contained in:
commit
5a175234c3
38
baresip-2.5.0-missing-free-line-signal.patch
Normal file
38
baresip-2.5.0-missing-free-line-signal.patch
Normal file
@ -0,0 +1,38 @@
|
||||
From 823dfd9f8990d11dc9c914597ebb3ac4ca6fdf2c Mon Sep 17 00:00:00 2001
|
||||
From: Juha Heinanen <jh@tutpro.com>
|
||||
Date: Sat, 16 Jul 2022 14:17:42 +0300
|
||||
Subject: [PATCH] Revert PR #1922
|
||||
|
||||
---
|
||||
src/call.c | 16 ++++++++++------
|
||||
1 file changed, 10 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/src/call.c b/src/call.c
|
||||
index 537d256a9..9af64bde9 100644
|
||||
--- a/src/call.c
|
||||
+++ b/src/call.c
|
||||
@@ -2224,14 +2224,18 @@ static void sipsess_progr_handler(const struct sip_msg *msg, void *arg)
|
||||
break;
|
||||
}
|
||||
|
||||
- if (media) {
|
||||
+ call_stream_stop(call);
|
||||
+
|
||||
+ if (media)
|
||||
+ call_stream_start(call, false);
|
||||
+
|
||||
+ if (media)
|
||||
call_event_handler(call, CALL_EVENT_PROGRESS, call->peer_uri);
|
||||
- update_media(call);
|
||||
- }
|
||||
- else {
|
||||
- call_stream_stop(call);
|
||||
+ else
|
||||
call_event_handler(call, CALL_EVENT_RINGING, call->peer_uri);
|
||||
- }
|
||||
+
|
||||
+ if (media)
|
||||
+ update_media(call);
|
||||
}
|
||||
|
||||
|
10
baresip.spec
10
baresip.spec
@ -1,7 +1,7 @@
|
||||
Summary: Modular SIP user-agent with audio and video support
|
||||
Name: baresip
|
||||
Version: 2.5.0
|
||||
Release: 1%{?dist}
|
||||
Release: 3%{?dist}
|
||||
License: BSD
|
||||
URL: https://github.com/baresip/baresip
|
||||
Source0: https://github.com/baresip/baresip/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||
@ -11,6 +11,7 @@ Source11: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/1e1d6921
|
||||
Source12: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/COPYING#/COPYING.adwaita-icon-theme
|
||||
Source13: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/COPYING_CCBYSA3#/COPYING_CCBYSA3.adwaita-icon-theme
|
||||
Source14: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/COPYING_LGPL#/COPYING_LGPL.adwaita-icon-theme
|
||||
Patch0: https://github.com/baresip/baresip/commit/823dfd9f8990d11dc9c914597ebb3ac4ca6fdf2c.patch#/baresip-2.5.0-missing-free-line-signal.patch
|
||||
BuildRequires: make
|
||||
BuildRequires: gcc
|
||||
BuildRequires: libre-devel >= 2.5.0
|
||||
@ -369,6 +370,7 @@ This module provides the X11 video output driver.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .missing-free-line-signal
|
||||
|
||||
%build
|
||||
%if 0%{?rhel} == 7
|
||||
@ -587,6 +589,12 @@ gtk-update-icon-cache --force %{_datadir}/icons/Adwaita &>/dev/null || :
|
||||
%{_libdir}/%{name}/modules/x11.so
|
||||
|
||||
%changelog
|
||||
* Sat Jul 16 2022 Robert Scheck <robert@fedoraproject.org> 2.5.0-3
|
||||
- Added upstream patch to fix missing free-line signal regression
|
||||
|
||||
* Sat Jul 09 2022 Richard Shaw <hobbes1069@gmail.com> - 2.5.0-2
|
||||
- Rebuild for codec2 1.0.4.
|
||||
|
||||
* Sat Jul 02 2022 Robert Scheck <robert@fedoraproject.org> 2.5.0-1
|
||||
- Upgrade to 2.5.0 (#2103207)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user