Upgrade to 3.8.1 (#2256553)
This commit is contained in:
parent
d4e900835f
commit
2ed9779fc8
@ -1,28 +0,0 @@
|
||||
From ad6a48ad4a10580841cb5b07b27a96a26b26ada1 Mon Sep 17 00:00:00 2001
|
||||
From: Robert Scheck <robert@fedoraproject.org>
|
||||
Date: Thu, 28 Dec 2023 07:50:39 +0100
|
||||
Subject: [PATCH] cmake: add only non-system link paths to rpath (fixes #2849)
|
||||
|
||||
---
|
||||
CMakeLists.txt | 8 ++++++--
|
||||
1 file changed, 6 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index 822f4ccdb..3dd2c0a73 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -54,8 +54,12 @@ set(CMAKE_EXPORT_COMPILE_COMMANDS ON)
|
||||
set(CMAKE_C_STANDARD 11)
|
||||
set(CMAKE_C_EXTENSIONS OFF)
|
||||
|
||||
-set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib")
|
||||
-set(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
|
||||
+list(FIND CMAKE_C_IMPLICIT_LINK_DIRECTORIES
|
||||
+ "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}" IS_SYSTEM_DIR)
|
||||
+if(IS_SYSTEM_DIR STREQUAL "-1")
|
||||
+ set(CMAKE_INSTALL_RPATH "${CMAKE_INSTALL_PREFIX}/lib${LIB_SUFFIX}")
|
||||
+ set(CMAKE_INSTALL_RPATH_USE_LINK_PATH TRUE)
|
||||
+endif()
|
||||
|
||||
if(MSVC)
|
||||
add_compile_options("/W3")
|
@ -1,6 +1,6 @@
|
||||
Summary: Modular SIP user-agent with audio and video support
|
||||
Name: baresip
|
||||
Version: 3.8.0
|
||||
Version: 3.8.1
|
||||
Release: 1%{?dist}
|
||||
License: BSD-3-Clause
|
||||
URL: https://github.com/baresip/baresip
|
||||
@ -11,7 +11,6 @@ Source11: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/1e1d6921
|
||||
Source12: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/COPYING#/COPYING.adwaita-icon-theme
|
||||
Source13: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/COPYING_CCBYSA3#/COPYING_CCBYSA3.adwaita-icon-theme
|
||||
Source14: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/COPYING_LGPL#/COPYING_LGPL.adwaita-icon-theme
|
||||
Patch0: https://github.com/baresip/baresip/pull/2850/commits/ad6a48ad4a10580841cb5b07b27a96a26b26ada1.patch#/baresip-3.8.0-rpath.patch
|
||||
BuildRequires: cmake
|
||||
%if 0%{?rhel} && 0%{?rhel} < 8
|
||||
BuildRequires: cmake3
|
||||
@ -593,6 +592,9 @@ gtk-update-icon-cache --force %{_datadir}/icons/Adwaita &>/dev/null || :
|
||||
%{_libdir}/%{name}/modules/x11.so
|
||||
|
||||
%changelog
|
||||
* Sat Jan 06 2024 Robert Scheck <robert@fedoraproject.org> 3.8.1-1
|
||||
- Upgrade to 3.8.1 (#2256553)
|
||||
|
||||
* Thu Dec 28 2023 Robert Scheck <robert@fedoraproject.org> 3.8.0-1
|
||||
- Upgrade to 3.8.0 (#2256050)
|
||||
|
||||
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (baresip-3.8.0.tar.gz) = 12ff9aaedcc3bc19a38235f5abc955aa1a64db47827895b95ca55329cb29acef353ee0871e888f12f0a9ea5a2ac0b3a34c278115c05e9f55d055638b5e13f852
|
||||
SHA512 (baresip-3.8.1.tar.gz) = 7b3cd7a61630860e466d57400cf37e7317733f8ad96b67ee34d11900fd79f5337d224a94d3b19826ebf617746f68ebc7671ed17dfaa1dbf1fe80bb6538972106
|
||||
SHA512 (call-incoming-symbolic.svg) = 49b6422efff9986dd4a18b34df4ab185b01b46c44ab5b8c1d45ab1ca25694cb42e73428b0a69e5fe2eb61c4e7a7aba9c0df82b5e0290f45950f3942be63bf987
|
||||
SHA512 (call-outgoing-symbolic.svg) = 142cf668d977e3a709d3c13e01d86fdd09e501affd1756df3000de84581c55b3b5082758b32a73ae0e47f45233cc7e55609f3e54effbba01666ca97d5a55fdaa
|
||||
SHA512 (COPYING.adwaita-icon-theme) = e8963bab4d94d9fbcfc930b95164afff9502e4e53209104f4836fcd6dab2c2e9f105c9f9a17b43bc9502903c9c7b2e0880dacf2339cbe110a19654f13742e20a
|
||||
|
Loading…
x
Reference in New Issue
Block a user