Merge remote-tracking branch 'origin/main' into epel8
This commit is contained in:
commit
2b9c0bec45
@ -1,38 +0,0 @@
|
||||
From 823dfd9f8990d11dc9c914597ebb3ac4ca6fdf2c Mon Sep 17 00:00:00 2001
|
||||
From: Juha Heinanen <jh@tutpro.com>
|
||||
Date: Sat, 16 Jul 2022 14:17:42 +0300
|
||||
Subject: [PATCH] Revert PR #1922
|
||||
|
||||
---
|
||||
src/call.c | 16 ++++++++++------
|
||||
1 file changed, 10 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/src/call.c b/src/call.c
|
||||
index 537d256a9..9af64bde9 100644
|
||||
--- a/src/call.c
|
||||
+++ b/src/call.c
|
||||
@@ -2224,14 +2224,18 @@ static void sipsess_progr_handler(const struct sip_msg *msg, void *arg)
|
||||
break;
|
||||
}
|
||||
|
||||
- if (media) {
|
||||
+ call_stream_stop(call);
|
||||
+
|
||||
+ if (media)
|
||||
+ call_stream_start(call, false);
|
||||
+
|
||||
+ if (media)
|
||||
call_event_handler(call, CALL_EVENT_PROGRESS, call->peer_uri);
|
||||
- update_media(call);
|
||||
- }
|
||||
- else {
|
||||
- call_stream_stop(call);
|
||||
+ else
|
||||
call_event_handler(call, CALL_EVENT_RINGING, call->peer_uri);
|
||||
- }
|
||||
+
|
||||
+ if (media)
|
||||
+ update_media(call);
|
||||
}
|
||||
|
||||
|
41
baresip.spec
41
baresip.spec
@ -1,6 +1,6 @@
|
||||
Summary: Modular SIP user-agent with audio and video support
|
||||
Name: baresip
|
||||
Version: 2.5.1
|
||||
Version: 2.6.0
|
||||
Release: 1%{?dist}
|
||||
License: BSD
|
||||
URL: https://github.com/baresip/baresip
|
||||
@ -13,8 +13,8 @@ Source13: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/C
|
||||
Source14: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/COPYING_LGPL#/COPYING_LGPL.adwaita-icon-theme
|
||||
BuildRequires: make
|
||||
BuildRequires: gcc
|
||||
BuildRequires: libre-devel >= 2.5.0
|
||||
BuildRequires: librem-devel >= 2.5.0
|
||||
BuildRequires: libre-devel >= 2.6.0
|
||||
BuildRequires: librem-devel >= 2.6.0
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 8
|
||||
BuildRequires: openssl-devel >= 1.1.0
|
||||
%else
|
||||
@ -31,6 +31,8 @@ Obsoletes: %{name}-cairo < 1.1.0-1
|
||||
Obsoletes: %{name}-rst < 2.0.0-1
|
||||
Obsoletes: %{name}-speex_pp < 2.0.0-1
|
||||
Obsoletes: %{name}-x11grab < 2.0.0-1
|
||||
Obsoletes: %{name}-gsm < 2.6.0-1
|
||||
Obsoletes: %{name}-gst_video < 2.6.0-1
|
||||
|
||||
%description
|
||||
A modular SIP user-agent with support for audio and video, and many IETF
|
||||
@ -123,16 +125,6 @@ Baresip is a modular SIP user-agent with audio and video support.
|
||||
|
||||
This module provides the G.726 audio codec.
|
||||
|
||||
%package gsm
|
||||
Summary: GSM audio codec module for baresip
|
||||
BuildRequires: gsm-devel
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description gsm
|
||||
Baresip is a modular SIP user-agent with audio and video support.
|
||||
|
||||
This module provides the GSM audio codec.
|
||||
|
||||
%package gst
|
||||
Summary: GStreamer audio source driver for baresip
|
||||
BuildRequires: pkgconfig(gstreamer-1.0)
|
||||
@ -144,17 +136,6 @@ Baresip is a modular SIP user-agent with audio and video support.
|
||||
This module uses the GStreamer 1.0 framework to play external media and
|
||||
provides them as an internal audio source.
|
||||
|
||||
%package gst_video
|
||||
Summary: Video codec support using GStreamer for baresip
|
||||
BuildRequires: pkgconfig(gstreamer-1.0)
|
||||
BuildRequires: pkgconfig(gstreamer-app-1.0)
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
|
||||
%description gst_video
|
||||
Baresip is a modular SIP user-agent with audio and video support.
|
||||
|
||||
This module implements video codecs using GStreamer 1.0 framework.
|
||||
|
||||
%package gtk
|
||||
Summary: GTK+ menu-based user interface module for baresip
|
||||
BuildRequires: pkgconfig(gtk+-3.0) >= 3.0
|
||||
@ -514,15 +495,9 @@ gtk-update-icon-cache --force %{_datadir}/icons/Adwaita &>/dev/null || :
|
||||
%files g726
|
||||
%{_libdir}/%{name}/modules/g726.so
|
||||
|
||||
%files gsm
|
||||
%{_libdir}/%{name}/modules/gsm.so
|
||||
|
||||
%files gst
|
||||
%{_libdir}/%{name}/modules/gst.so
|
||||
|
||||
%files gst_video
|
||||
%{_libdir}/%{name}/modules/gst_video.so
|
||||
|
||||
%files gtk
|
||||
%{_libdir}/%{name}/modules/gtk.so
|
||||
%{_datadir}/applications/com.github.baresip.desktop
|
||||
@ -587,6 +562,12 @@ gtk-update-icon-cache --force %{_datadir}/icons/Adwaita &>/dev/null || :
|
||||
%{_libdir}/%{name}/modules/x11.so
|
||||
|
||||
%changelog
|
||||
* Tue Aug 02 2022 Robert Scheck <robert@fedoraproject.org> 2.6.0-1
|
||||
- Upgrade to 2.6.0 (#2113067)
|
||||
|
||||
* Wed Jul 20 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.5.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Mon Jul 18 2022 Robert Scheck <robert@fedoraproject.org> 2.5.1-1
|
||||
- Upgrade to 2.5.1 (#2107946)
|
||||
|
||||
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (baresip-2.5.1.tar.gz) = 35f035aed738efdb8b7e362c1ec269c9315a63198dc5b5feba03a5a16d1ca154b098a01c8ad482ee2998d40e871cfa2cab6c2fa913f1a7889009eb93fc2538e4
|
||||
SHA512 (baresip-2.6.0.tar.gz) = 0738fec088df22773a25413cc4b8188d29b5caf3ec8f3148f90e6ebfee8c9488ae35e2405a7d2ede3a25e9144e9a764a96f59fd78476ec2fcd8992469f5e11ac
|
||||
SHA512 (call-incoming-symbolic.svg) = 49b6422efff9986dd4a18b34df4ab185b01b46c44ab5b8c1d45ab1ca25694cb42e73428b0a69e5fe2eb61c4e7a7aba9c0df82b5e0290f45950f3942be63bf987
|
||||
SHA512 (call-outgoing-symbolic.svg) = 142cf668d977e3a709d3c13e01d86fdd09e501affd1756df3000de84581c55b3b5082758b32a73ae0e47f45233cc7e55609f3e54effbba01666ca97d5a55fdaa
|
||||
SHA512 (COPYING.adwaita-icon-theme) = e8963bab4d94d9fbcfc930b95164afff9502e4e53209104f4836fcd6dab2c2e9f105c9f9a17b43bc9502903c9c7b2e0880dacf2339cbe110a19654f13742e20a
|
||||
|
Loading…
x
Reference in New Issue
Block a user