Merge remote-tracking branch 'origin/main' into epel8
This commit is contained in:
commit
0c667828cb
@ -1,44 +0,0 @@
|
||||
From dd9106090136304455e9e7a6295a50ed4406e481 Mon Sep 17 00:00:00 2001
|
||||
From: Robert Scheck <robert@fedoraproject.org>
|
||||
Date: Sat, 14 Jan 2023 22:41:57 +0100
|
||||
Subject: [PATCH] cmake/pulse: Remove pulse-simple library lookup
|
||||
|
||||
The PulseAudio driver using the simple API has already been
|
||||
removed via commit 1aac3e3589977d5785a7ecd74bcad0d99e907c99,
|
||||
commit 5fb1e54e9d11082eba76d3b86d399e1539a0cc8c and commit
|
||||
d0a47f07214c61102c04c5de0d2b88a94b25b89c.
|
||||
---
|
||||
cmake/FindPULSE.cmake | 14 +-------------
|
||||
1 file changed, 1 insertion(+), 13 deletions(-)
|
||||
|
||||
diff --git a/cmake/FindPULSE.cmake b/cmake/FindPULSE.cmake
|
||||
index 3c18353e2..c9e3fd31f 100644
|
||||
--- a/cmake/FindPULSE.cmake
|
||||
+++ b/cmake/FindPULSE.cmake
|
||||
@@ -25,25 +25,13 @@ find_library(PULSE_LIBRARY
|
||||
PATHS /usr/local/lib /usr/lib
|
||||
)
|
||||
|
||||
-find_library(PULSE_SIMPLE_LIBRARY
|
||||
- NAME pulse-simple
|
||||
- HINTS
|
||||
- "${PULSE_LIBRARY_DIRS}"
|
||||
- "${PULSE_HINTS}/lib"
|
||||
- PATHS /usr/local/lib /usr/lib
|
||||
-)
|
||||
-
|
||||
include(FindPackageHandleStandardArgs)
|
||||
find_package_handle_standard_args(PULSE DEFAULT_MSG PULSE_LIBRARY
|
||||
PULSE_INCLUDE_DIR)
|
||||
|
||||
if(PULSE_FOUND)
|
||||
set( PULSE_INCLUDE_DIRS ${PULSE_INCLUDE_DIR} )
|
||||
- if(DEFINED PULSE_SIMPLE_LIBRARY)
|
||||
- set( PULSE_LIBRARIES ${PULSE_LIBRARY} ${PULSE_SIMPLE_LIBRARY} )
|
||||
- else()
|
||||
- set( PULSE_LIBRARIES ${PULSE_LIBRARY} )
|
||||
- endif()
|
||||
+ set( PULSE_LIBRARIES ${PULSE_LIBRARY} )
|
||||
else()
|
||||
set( PULSE_INCLUDE_DIRS )
|
||||
set( PULSE_LIBRARIES )
|
19
baresip.spec
19
baresip.spec
@ -1,6 +1,6 @@
|
||||
Summary: Modular SIP user-agent with audio and video support
|
||||
Name: baresip
|
||||
Version: 2.11.0
|
||||
Version: 2.12.0
|
||||
Release: 1%{?dist}
|
||||
License: BSD-3-Clause
|
||||
URL: https://github.com/baresip/baresip
|
||||
@ -11,15 +11,14 @@ Source11: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/1e1d6921
|
||||
Source12: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/COPYING#/COPYING.adwaita-icon-theme
|
||||
Source13: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/COPYING_CCBYSA3#/COPYING_CCBYSA3.adwaita-icon-theme
|
||||
Source14: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/COPYING_LGPL#/COPYING_LGPL.adwaita-icon-theme
|
||||
Patch0: https://github.com/baresip/baresip/commit/dd9106090136304455e9e7a6295a50ed4406e481.patch#/baresip-2.11.0-no-pulse-simple.patch
|
||||
BuildRequires: cmake
|
||||
%if 0%{?rhel} && 0%{?rhel} < 8
|
||||
BuildRequires: cmake3
|
||||
%endif
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: libre-devel >= 2.11.0
|
||||
BuildRequires: librem-devel >= 2.11.0
|
||||
BuildRequires: libre-devel >= 2.12.0
|
||||
BuildRequires: librem-devel >= 2.12.0
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 8
|
||||
BuildRequires: openssl-devel >= 1.1.0
|
||||
%else
|
||||
@ -352,7 +351,6 @@ This module provides the X11 video output driver.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .no-pulse-simple
|
||||
|
||||
%build
|
||||
%if 0%{?rhel} && 0%{?rhel} < 8
|
||||
@ -427,7 +425,7 @@ gtk-update-icon-cache --force %{_datadir}/icons/Adwaita &>/dev/null || :
|
||||
%license LICENSE
|
||||
%doc CHANGELOG.md docs/THANKS docs/examples
|
||||
%{_bindir}/%{name}
|
||||
%{_libdir}/lib%{name}.so.3*
|
||||
%{_libdir}/lib%{name}.so.4*
|
||||
%dir %{_libdir}/%{name}/
|
||||
%dir %{_libdir}/%{name}/modules/
|
||||
%{_libdir}/%{name}/modules/account.so
|
||||
@ -562,6 +560,15 @@ gtk-update-icon-cache --force %{_datadir}/icons/Adwaita &>/dev/null || :
|
||||
%{_libdir}/%{name}/modules/x11.so
|
||||
|
||||
%changelog
|
||||
* Sat Feb 18 2023 Robert Scheck <robert@fedoraproject.org> 2.12.0-1
|
||||
- Upgrade to 2.12.0 (#2170292)
|
||||
|
||||
* Wed Feb 15 2023 Tom Callaway <spot@fedoraproject.org> - 2.11.0-3
|
||||
- rebuild for libvpx
|
||||
|
||||
* Wed Jan 18 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.11.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Sat Jan 14 2023 Robert Scheck <robert@fedoraproject.org> 2.11.0-1
|
||||
- Upgrade to 2.11.0 (#2160564)
|
||||
|
||||
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (baresip-2.11.0.tar.gz) = 1fa0f8dbe32fd8fcaf2d2fbfef35e089ed799244bd716f744c9a007f624dfe5a8c3565f5ddec6514004ff6b1038649799987e1b2605b117777310e1c1d7f942b
|
||||
SHA512 (baresip-2.12.0.tar.gz) = b0c60be4b30c6e4497cf57a6a8e9598f840b85e6ed2088fe204f9bb2ccbd923aa32c3b9f6b62781d002c133cf092e6a8aa0ce9fad37bb396edb7e70562874eaa
|
||||
SHA512 (call-incoming-symbolic.svg) = 49b6422efff9986dd4a18b34df4ab185b01b46c44ab5b8c1d45ab1ca25694cb42e73428b0a69e5fe2eb61c4e7a7aba9c0df82b5e0290f45950f3942be63bf987
|
||||
SHA512 (call-outgoing-symbolic.svg) = 142cf668d977e3a709d3c13e01d86fdd09e501affd1756df3000de84581c55b3b5082758b32a73ae0e47f45233cc7e55609f3e54effbba01666ca97d5a55fdaa
|
||||
SHA512 (COPYING.adwaita-icon-theme) = e8963bab4d94d9fbcfc930b95164afff9502e4e53209104f4836fcd6dab2c2e9f105c9f9a17b43bc9502903c9c7b2e0880dacf2339cbe110a19654f13742e20a
|
||||
|
Loading…
Reference in New Issue
Block a user