Merge remote-tracking branch 'origin/main' into f35
This commit is contained in:
commit
07763a3297
@ -1,22 +0,0 @@
|
||||
From 6574b653af4e9c8284b6fbd902841a6fc22281bc Mon Sep 17 00:00:00 2001
|
||||
From: mbattista <m0battista@gmail.com>
|
||||
Date: Tue, 15 Nov 2022 08:13:22 +0100
|
||||
Subject: [PATCH] Space at the beginning of sip: creates errors (#2329)
|
||||
|
||||
---
|
||||
modules/gtk/gtk_mod.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/modules/gtk/gtk_mod.c b/modules/gtk/gtk_mod.c
|
||||
index c359a40f1..77aa57bff 100644
|
||||
--- a/modules/gtk/gtk_mod.c
|
||||
+++ b/modules/gtk/gtk_mod.c
|
||||
@@ -168,7 +168,7 @@ static void menu_on_dial_history(GtkMenuItem *menuItem, gpointer arg)
|
||||
if (!label_1)
|
||||
return;
|
||||
|
||||
- label_1[0] = ' ';
|
||||
+ label_1 = label_1 + 1;
|
||||
|
||||
uri = strtok(label_1, "]");
|
||||
gtk_mod_connect(mod, uri);
|
@ -1,61 +0,0 @@
|
||||
From 7ee4a769aaa1e3899b536b724cc854dd327ae865 Mon Sep 17 00:00:00 2001
|
||||
From: mbattista <m0battista@gmail.com>
|
||||
Date: Mon, 7 Nov 2022 20:20:45 +0100
|
||||
Subject: [PATCH] gtk: fixes issue #2315 and GTK errors on quit (#2316)
|
||||
|
||||
---
|
||||
modules/gtk/gtk_mod.c | 13 ++++++++-----
|
||||
1 file changed, 8 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/modules/gtk/gtk_mod.c b/modules/gtk/gtk_mod.c
|
||||
index f3cf82603..c359a40f1 100644
|
||||
--- a/modules/gtk/gtk_mod.c
|
||||
+++ b/modules/gtk/gtk_mod.c
|
||||
@@ -131,9 +131,6 @@ static void menu_on_quit(GtkMenuItem *menuItem, gpointer arg)
|
||||
struct gtk_mod *mod = arg;
|
||||
(void)menuItem;
|
||||
|
||||
- gtk_widget_destroy(GTK_WIDGET(mod->app_menu));
|
||||
- g_object_unref(G_OBJECT(mod->status_icon));
|
||||
-
|
||||
mqueue_push(mod->mq, MQ_QUIT, 0);
|
||||
info("quit from gtk\n");
|
||||
}
|
||||
@@ -772,12 +769,15 @@ static gboolean status_icon_on_button_press(GtkStatusIcon *status_icon,
|
||||
int gtk_mod_connect(struct gtk_mod *mod, const char *uri)
|
||||
{
|
||||
char *uric = NULL;
|
||||
+ struct pl url_pl;
|
||||
int err = 0;
|
||||
|
||||
+ pl_set_str(&url_pl, uri);
|
||||
if (!mod)
|
||||
return ENOMEM;
|
||||
|
||||
- err = account_uri_complete_strdup(ua_account(mod->ua_cur), &uric, uri);
|
||||
+ err = account_uri_complete_strdup(ua_account(mod->ua_cur),
|
||||
+ &uric, &url_pl);
|
||||
if (err)
|
||||
goto out;
|
||||
|
||||
@@ -793,8 +793,10 @@ int gtk_mod_connect_attended(struct gtk_mod *mod, const char *uri,
|
||||
{
|
||||
struct attended_transfer_store *ats;
|
||||
char *uric = NULL;
|
||||
+ struct pl url_pl;
|
||||
int err = 0;
|
||||
|
||||
+ pl_set_str(&url_pl, uri);
|
||||
if (!mod)
|
||||
return ENOMEM;
|
||||
|
||||
@@ -802,7 +804,8 @@ int gtk_mod_connect_attended(struct gtk_mod *mod, const char *uri,
|
||||
if (!ats)
|
||||
return ENOMEM;
|
||||
|
||||
- err = account_uri_complete_strdup(ua_account(mod->ua_cur), &uric, uri);
|
||||
+ err = account_uri_complete_strdup(ua_account(mod->ua_cur),
|
||||
+ &uric, &url_pl);
|
||||
if (err)
|
||||
goto out;
|
||||
|
17
baresip.spec
17
baresip.spec
@ -1,7 +1,7 @@
|
||||
Summary: Modular SIP user-agent with audio and video support
|
||||
Name: baresip
|
||||
Version: 2.9.0
|
||||
Release: 4%{?dist}
|
||||
Version: 2.10.0
|
||||
Release: 1%{?dist}
|
||||
License: BSD-3-Clause
|
||||
URL: https://github.com/baresip/baresip
|
||||
Source0: https://github.com/baresip/baresip/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||
@ -11,16 +11,14 @@ Source11: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/1e1d6921
|
||||
Source12: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/COPYING#/COPYING.adwaita-icon-theme
|
||||
Source13: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/COPYING_CCBYSA3#/COPYING_CCBYSA3.adwaita-icon-theme
|
||||
Source14: https://gitlab.gnome.org/GNOME/adwaita-icon-theme/-/raw/master/COPYING_LGPL#/COPYING_LGPL.adwaita-icon-theme
|
||||
Patch0: https://github.com/baresip/baresip/commit/7ee4a769aaa1e3899b536b724cc854dd327ae865.patch#/baresip-2.9.0-gtk-dial-segfault.patch
|
||||
Patch1: https://github.com/baresip/baresip/commit/6574b653af4e9c8284b6fbd902841a6fc22281bc.patch#/baresip-2.9.0-gtk-dial-history.patch
|
||||
BuildRequires: cmake
|
||||
%if 0%{?rhel} && 0%{?rhel} < 8
|
||||
BuildRequires: cmake3
|
||||
%endif
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: libre-devel >= 2.9.0
|
||||
BuildRequires: librem-devel >= 2.9.0
|
||||
BuildRequires: libre-devel >= 2.10.0
|
||||
BuildRequires: librem-devel >= 2.10.0
|
||||
%if 0%{?fedora} || 0%{?rhel} >= 8
|
||||
BuildRequires: openssl-devel >= 1.1.0
|
||||
%else
|
||||
@ -353,8 +351,6 @@ This module provides the X11 video output driver.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .gtk-dial-segfault
|
||||
%patch1 -p1 -b .gtk-dial-history
|
||||
|
||||
%build
|
||||
%if 0%{?rhel} && 0%{?rhel} < 8
|
||||
@ -429,7 +425,7 @@ gtk-update-icon-cache --force %{_datadir}/icons/Adwaita &>/dev/null || :
|
||||
%license LICENSE
|
||||
%doc CHANGELOG.md docs/THANKS docs/examples
|
||||
%{_bindir}/%{name}
|
||||
%{_libdir}/lib%{name}.so.1*
|
||||
%{_libdir}/lib%{name}.so.2*
|
||||
%dir %{_libdir}/%{name}/
|
||||
%dir %{_libdir}/%{name}/modules/
|
||||
%{_libdir}/%{name}/modules/account.so
|
||||
@ -565,6 +561,9 @@ gtk-update-icon-cache --force %{_datadir}/icons/Adwaita &>/dev/null || :
|
||||
%{_libdir}/%{name}/modules/x11.so
|
||||
|
||||
%changelog
|
||||
* Wed Dec 07 2022 Robert Scheck <robert@fedoraproject.org> 2.10.0-1
|
||||
- Upgrade to 2.10.0 (#2151456)
|
||||
|
||||
* Thu Nov 17 2022 Robert Scheck <robert@fedoraproject.org> 2.9.0-4
|
||||
- Added upstream patch to fix GTK+ dial history space error
|
||||
|
||||
|
2
sources
2
sources
@ -1,4 +1,4 @@
|
||||
SHA512 (baresip-2.9.0.tar.gz) = 1f04298e94b35df3c3178df382eaefcbc2df6035dd0b1100ae5d83b2d76c6625557f32e7480b0ed9e7174e7c3160a4ad550c73fc1a40bbab229a7f5c302dbc7f
|
||||
SHA512 (baresip-2.10.0.tar.gz) = f0d46b4964467437aa3a998fb40d4cf89b26a97bc0081daad4c3ae25662213bb4bcb003b327c26869318f27531ed336ce6ecafae3bec6f24a0c6d818e2e4fc43
|
||||
SHA512 (call-incoming-symbolic.svg) = 49b6422efff9986dd4a18b34df4ab185b01b46c44ab5b8c1d45ab1ca25694cb42e73428b0a69e5fe2eb61c4e7a7aba9c0df82b5e0290f45950f3942be63bf987
|
||||
SHA512 (call-outgoing-symbolic.svg) = 142cf668d977e3a709d3c13e01d86fdd09e501affd1756df3000de84581c55b3b5082758b32a73ae0e47f45233cc7e55609f3e54effbba01666ca97d5a55fdaa
|
||||
SHA512 (COPYING.adwaita-icon-theme) = e8963bab4d94d9fbcfc930b95164afff9502e4e53209104f4836fcd6dab2c2e9f105c9f9a17b43bc9502903c9c7b2e0880dacf2339cbe110a19654f13742e20a
|
||||
|
Loading…
Reference in New Issue
Block a user