Fix multilib, don't ship .a's
This commit is contained in:
parent
d55e311517
commit
d3027f2cc3
33
audiofile-multilib.patch
Normal file
33
audiofile-multilib.patch
Normal file
@ -0,0 +1,33 @@
|
|||||||
|
--- audiofile-0.2.6/audiofile-config.in.multilib 2006-07-27 19:23:38.000000000 -0400
|
||||||
|
+++ audiofile-0.2.6/audiofile-config.in 2006-07-27 19:25:18.000000000 -0400
|
||||||
|
@@ -1,7 +1,7 @@
|
||||||
|
#!/bin/sh
|
||||||
|
|
||||||
|
-prefix=@prefix@
|
||||||
|
-exec_prefix=@exec_prefix@
|
||||||
|
+prefix=`pkg-config --variable prefix audiofile`
|
||||||
|
+exec_prefix=`pkg-config --variable exec_prefix audiofile`
|
||||||
|
exec_prefix_set=no
|
||||||
|
|
||||||
|
usage="\
|
||||||
|
@@ -36,17 +36,13 @@
|
||||||
|
echo $exec_prefix
|
||||||
|
;;
|
||||||
|
--version)
|
||||||
|
- echo @AUDIOFILE_VERSION@
|
||||||
|
+ pkg-config --modversion audiofile
|
||||||
|
;;
|
||||||
|
--cflags)
|
||||||
|
- if test @includedir@ != /usr/include ; then
|
||||||
|
- includes=-I@includedir@
|
||||||
|
- fi
|
||||||
|
- echo $includes
|
||||||
|
+ pkg-config --cflags audiofile
|
||||||
|
;;
|
||||||
|
--libs)
|
||||||
|
- libdirs=-L@libdir@
|
||||||
|
- echo $libdirs -laudiofile -lm
|
||||||
|
+ pkg-config --libs audiofile
|
||||||
|
;;
|
||||||
|
*)
|
||||||
|
echo "${usage}" 1>&2
|
@ -1,13 +1,14 @@
|
|||||||
Summary: A library for accessing various audio file formats.
|
Summary: A library for accessing various audio file formats.
|
||||||
Name: audiofile
|
Name: audiofile
|
||||||
Version: 0.2.6
|
Version: 0.2.6
|
||||||
Release: 4.1
|
Release: 5
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
License: LGPL
|
License: LGPL
|
||||||
Group: System Environment/Libraries
|
Group: System Environment/Libraries
|
||||||
Source: ftp://ftp.gnome.org/pub/gnome/sources/audiofile/0.2/audiofile-%{version}.tar.bz2
|
Source: ftp://ftp.gnome.org/pub/gnome/sources/audiofile/0.2/audiofile-%{version}.tar.bz2
|
||||||
Patch0: audiofile-underquoted.patch
|
Patch0: audiofile-underquoted.patch
|
||||||
Patch1: audiofile-const.patch
|
Patch1: audiofile-const.patch
|
||||||
|
Patch2: audiofile-multilib.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
BuildRoot: %{_tmppath}/%{name}-%{version}-root
|
||||||
Prereq: /sbin/ldconfig
|
Prereq: /sbin/ldconfig
|
||||||
|
|
||||||
@ -34,6 +35,7 @@ other resources you can use to develop Audio File applications.
|
|||||||
%setup -q
|
%setup -q
|
||||||
%patch0 -p1 -b .underquoted
|
%patch0 -p1 -b .underquoted
|
||||||
%patch1 -p1 -b .const
|
%patch1 -p1 -b .const
|
||||||
|
%patch2 -p1 -b .multilib
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure
|
%configure
|
||||||
@ -46,6 +48,7 @@ mkdir -p %{buildroot}
|
|||||||
%makeinstall
|
%makeinstall
|
||||||
|
|
||||||
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
|
||||||
|
rm -f $RPM_BUILD_ROOT%{_libdir}/*.a
|
||||||
rm -f docs/Makefile*
|
rm -f docs/Makefile*
|
||||||
|
|
||||||
%post
|
%post
|
||||||
@ -68,12 +71,15 @@ rm -rf %{buildroot}
|
|||||||
%defattr(-, root, root)
|
%defattr(-, root, root)
|
||||||
%{_bindir}/audiofile-config
|
%{_bindir}/audiofile-config
|
||||||
%{_libdir}/lib*.so
|
%{_libdir}/lib*.so
|
||||||
%{_libdir}/*.a
|
|
||||||
%{_libdir}/pkgconfig/*.pc
|
%{_libdir}/pkgconfig/*.pc
|
||||||
%{_includedir}/*
|
%{_includedir}/*
|
||||||
%{_datadir}/aclocal/*
|
%{_datadir}/aclocal/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jul 27 2006 Matthias Clasen <mclasen@redhat.com> - 1:0.2.6-5
|
||||||
|
- Fix multilib conflicts
|
||||||
|
- Don't ship static libraries
|
||||||
|
|
||||||
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1:0.2.6-4.1
|
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1:0.2.6-4.1
|
||||||
- rebuild
|
- rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user