62670b4e6a
- Dropped x86_64-SSE2, ix86-SSE1, ix86-3DNow, z10, z196 (uncompilable). - Modified incompatible patches. - Added armv7neon support, modified archdef from softfp abi to hard abi. - Modified Make.lib to include build-id, soname, versioned library name and symlinks. - Now builds monolithic libsatlas (serial) and libtatlas (threaded) libraries with lapack and blas included. - Lapack source tarball needed instead of static library. - Disabled cpu throttling detection again (sorry, could not work on atlas otherwise, feel free to enable yet again - atlas-throttling.patch). - Removed mentions of "Fedora" to promote redistribution. - Modified parts of atlas.spec sometimes left in place, work still in progress, cleanup needed.
17 lines
560 B
Diff
17 lines
560 B
Diff
diff --git a/CONFIG/src/SpewMakeInc.c b/CONFIG/src/SpewMakeInc.c
|
|
index eed259e..65d68a1 100644
|
|
--- a/CONFIG/src/SpewMakeInc.c
|
|
+++ b/CONFIG/src/SpewMakeInc.c
|
|
@@ -764,9 +764,9 @@ int main(int nargs, char **args)
|
|
else
|
|
{
|
|
if (ptrbits == 32)
|
|
- fprintf(fpout, " -melf_i386");
|
|
+ fprintf(fpout, " -Wl,-melf_i386");
|
|
else if (ptrbits == 64)
|
|
- fprintf(fpout, " -melf_x86_64");
|
|
+ fprintf(fpout, " -Wl,-melf_x86_64");
|
|
if (OS == OSFreeBSD)
|
|
fprintf(fpout, "_fbsd");
|
|
}
|