62670b4e6a
- Dropped x86_64-SSE2, ix86-SSE1, ix86-3DNow, z10, z196 (uncompilable). - Modified incompatible patches. - Added armv7neon support, modified archdef from softfp abi to hard abi. - Modified Make.lib to include build-id, soname, versioned library name and symlinks. - Now builds monolithic libsatlas (serial) and libtatlas (threaded) libraries with lapack and blas included. - Lapack source tarball needed instead of static library. - Disabled cpu throttling detection again (sorry, could not work on atlas otherwise, feel free to enable yet again - atlas-throttling.patch). - Removed mentions of "Fedora" to promote redistribution. - Modified parts of atlas.spec sometimes left in place, work still in progress, cleanup needed.
24 lines
525 B
Diff
24 lines
525 B
Diff
---
|
|
CONFIG/src/backend/probe_gas_s390.S | 13 +++++++++
|
|
10 files changed, 108 insertions(+), 7 deletions(-)
|
|
|
|
Index: b/CONFIG/src/backend/probe_gas_s390.S
|
|
===================================================================
|
|
--- /dev/null
|
|
+++ b/CONFIG/src/backend/probe_gas_s390.S
|
|
@@ -0,0 +1,13 @@
|
|
+#define ATL_GAS_PPC
|
|
+#include "atlas_asm.h"
|
|
+/*
|
|
+ * Linux S390 assembler for:
|
|
+ * int asm_probe(int i)
|
|
+ * RETURNS: i*3
|
|
+ */
|
|
+.globl ATL_asmdecor(asm_probe)
|
|
+ATL_asmdecor(asm_probe):
|
|
+ lr r3,r2
|
|
+ ar r2,r3
|
|
+ ar r2,r3
|
|
+ br r14
|
|
|