aedee9c4f9
Also: - Add japron subpackage with the Java interface. - Add %check script. - Drop upstreamed -format-security, -mlgmpidl12, -test, and -ppl1 patches. - Add -texinfo patch to fix documentation build failure.
103 lines
5.1 KiB
Diff
103 lines
5.1 KiB
Diff
--- apron/apron.texi.orig 2015-09-21 13:23:19.000000000 -0600
|
|
+++ apron/apron.texi 2016-01-27 20:16:48.938507952 -0700
|
|
@@ -16,7 +16,9 @@
|
|
|
|
@c Please read the COPYING file packaged in the distribution
|
|
|
|
+@ifnottex
|
|
@setcontentsaftertitlepage
|
|
+@end ifnottex
|
|
|
|
@tex
|
|
\global\parskip=0.5ex
|
|
@@ -69,6 +71,7 @@ numerical variables.
|
|
@contents
|
|
@end ifnothtml
|
|
|
|
+@ifnottex
|
|
@menu
|
|
* Copying::
|
|
* Introduction to APRON::
|
|
@@ -82,6 +85,7 @@ numerical variables.
|
|
* Examples::
|
|
* Appendices::
|
|
@end menu
|
|
+@end ifnottex
|
|
|
|
@c *******************************************************************
|
|
@node Copying, Introduction to APRON, Top, Top
|
|
@@ -2472,7 +2476,8 @@ Polynomial fraction with possibly interv
|
|
@end deftypefun
|
|
|
|
@deftypefun bool ap_texpr1_is_scalar (ap_texpr1_t* @var{e})
|
|
-All coefficients are scalar (non-interval)@end deftypefun
|
|
+All coefficients are scalar (non-interval)
|
|
+@end deftypefun
|
|
|
|
@c -------------------------------------------------------------------
|
|
@node Operations on tree expressions of level 1, , Tests on tree expressions of level 1, Tree expressions of level 1
|
|
--- apron/Makefile.orig 2016-01-25 10:41:11.000000000 -0700
|
|
+++ apron/Makefile 2016-01-27 20:11:18.016455265 -0700
|
|
@@ -103,15 +103,15 @@ newpolka.texi: ../newpolka/newpolka.texi
|
|
box.texi: ../box/box.texi
|
|
ln -sf $< $@
|
|
|
|
-apron.pdf: apron.texi rationale.texi ap_pkgrid.texi ap_ppl.texi newpolka.texi box.texi
|
|
- $(TEXI2DVI) --pdf -o $@ $<
|
|
+apron.pdf: apron.texi rationale.texi ../products/ap_pkgrid.texi ../ppl/ap_ppl.texi ../newpolka/newpolka.texi ../box/box.texi
|
|
+ $(TEXI2ANY) --pdf -o $@ $<
|
|
|
|
apron.info: apron.texi rationale.texi ap_pkgrid.texi ap_ppl.texi newpolka.texi box.texi
|
|
$(MAKEINFO) -o $@ $<
|
|
|
|
|
|
html: apron.texi rationale.texi ap_pkgrid.texi ap_ppl.texi newpolka.texi box.texi
|
|
- $(TEXI2HTML) -split=section -nonumber-sections -menu -subdir=html $<
|
|
+ $(TEXI2ANY) --html --split=section --no-number-sections $<
|
|
cp -f ../octagons/oct_doc.html html
|
|
|
|
#---------------------------------------
|
|
--- configure.orig 2016-01-25 10:42:37.000000000 -0700
|
|
+++ configure 2016-01-27 20:11:41.782530893 -0700
|
|
@@ -599,8 +599,7 @@ OCAMLFIND = $ocamlfind
|
|
LATEX = latex
|
|
DVIPDF = dvipdf
|
|
MAKEINDEX = makeindex
|
|
-TEXI2DVI = texi2dvi
|
|
-TEXI2HTML = texi2html
|
|
+TEXI2ANY = texi2any
|
|
|
|
# OSX only:
|
|
ABSOLUTE_DYLIB_INSTALL_NAMES = $absolute_dylib_install_names
|
|
--- Makefile.config.model.orig 2015-08-20 07:27:35.000000000 -0600
|
|
+++ Makefile.config.model 2016-01-27 20:11:30.047481096 -0700
|
|
@@ -177,7 +177,6 @@ CAMLIDL = camlidl
|
|
LATEX=latex
|
|
DVIPDF=dvipdf
|
|
MAKEINDEX=makeindex
|
|
-TEXI2DVI=texi2dvi
|
|
-TEXI2HTML=texi2html
|
|
+TEXI2ANY=texi2any
|
|
|
|
OCAMLPACK = $(shell dirname $(realpath $(lastword $(MAKEFILE_LIST))))/ocamlpack
|
|
--- mlapronidl/Makefile.orig 2016-01-25 10:41:11.000000000 -0700
|
|
+++ mlapronidl/Makefile 2016-01-27 21:47:15.529162480 -0700
|
|
@@ -156,7 +156,7 @@ apron_ocamldoc.mli: introduction.odoc $(
|
|
mlapronidl.pdf: mlapronidl.dvi
|
|
$(DVIPDF) mlapronidl.dvi
|
|
|
|
-mlapronidl.dvi: mlapronidl.tex introduction.mli $(MLMODULES:%=%.mli) ../box/box.mli ../octagons/oct.mli ../newpolka/polka.mli ../ppl/ppl.mli ../products/polkaGrid.mli $(MLGMPIDL_LIB)/mpz.mli $(MLGMPIDL_LIB)/mpq.mli $(MLGMPIDL_LIB)/gmp_random.mli $(MLGMPIDL_LIB)/mpf.mli $(MLGMPIDL_LIB)/mpfr.mli $(MLGMPIDL_LIB)/mpzf.mli $(MLGMPIDL_LIB)/mpqf.mli $(MLGMPIDL_LIB)/mpfrf.mli
|
|
+mlapronidl.dvi: mlapronidl.tex introduction.mli $(MLMODULES:%=%.mli) ../box/box.mli ../octagons/oct.mli ../newpolka/polka.mli ../ppl/ppl.mli ../products/polkaGrid.mli
|
|
$(OCAMLDOC) $(OCAMLINC) -I ../newpolka -I ../ppl \
|
|
-latextitle 1,chapter -latextitle 2,section -latextitle 3,subsection -latextitle 4,subsubsection -latextitle 5,paragraph -latextitle 6,subparagraph -noheader -notrailer -latex -sepfiles introduction.mli $(MLMODULES:%=%.mli) ../box/box.mli ../octagons/oct.mli ../newpolka/polka.mli ../ppl/ppl.mli ../products/polkaGrid.mli $(MLGMPIDL_LIB)/mpz.mli $(MLGMPIDL_LIB)/mpq.mli $(MLGMPIDL_LIB)/gmp_random.mli $(MLGMPIDL_LIB)/mpf.mli $(MLGMPIDL_LIB)/mpfr.mli $(MLGMPIDL_LIB)/mpzf.mli $(MLGMPIDL_LIB)/mpqf.mli $(MLGMPIDL_LIB)/mpfrf.mli
|
|
$(LATEX) mlapronidl
|
|
@@ -164,7 +164,7 @@ mlapronidl.dvi: mlapronidl.tex introduct
|
|
$(LATEX) mlapronidl
|
|
$(LATEX) mlapronidl
|
|
|
|
-html: mlapronidl.odoc introduction.mli $(IDLMODULES:%=%.mli) parser.mli $(MLMODULES:%=%.mli) ../box/box.mli ../octagons/oct.mli ../newpolka/polka.mli ../ppl/ppl.mli ../products/polkaGrid.mli $(MLGMPIDL_LIB)/mpz.mli $(MLGMPIDL_LIB)/mpq.mli $(MLGMPIDL_LIB)/gmp_random.mli $(MLGMPIDL_LIB)/mpf.mli $(MLGMPIDL_LIB)/mpfr.mli $(MLGMPIDL_LIB)/mpzf.mli $(MLGMPIDL_LIB)/mpqf.mli $(MLGMPIDL_LIB)/mpfrf.mli
|
|
+html: mlapronidl.odoc introduction.mli $(IDLMODULES:%=%.mli) parser.mli $(MLMODULES:%=%.mli) ../box/box.mli ../octagons/oct.mli ../newpolka/polka.mli ../ppl/ppl.mli ../products/polkaGrid.mli
|
|
mkdir -p html
|
|
$(OCAMLDOC) $(OCAMLINC) -I ../newpolka -I ../ppl \
|
|
-html -d html -colorize-code -intro mlapronidl.odoc introduction.mli $(IDLMODULES:%=%.mli) parser.mli ../box/box.mli ../octagons/oct.mli ../newpolka/polka.mli ../ppl/ppl.mli ../products/polkaGrid.mli $(MLGMPIDL_LIB)/mpz.mli $(MLGMPIDL_LIB)/mpq.mli $(MLGMPIDL_LIB)/gmp_random.mli $(MLGMPIDL_LIB)/mpf.mli $(MLGMPIDL_LIB)/mpfr.mli $(MLGMPIDL_LIB)/mpzf.mli $(MLGMPIDL_LIB)/mpqf.mli $(MLGMPIDL_LIB)/mpfrf.mli
|