Version 0.9.15

This commit is contained in:
Jerry James 2024-06-13 13:52:15 -06:00
parent 58b3445103
commit 73954a2f02
4 changed files with 23 additions and 31 deletions

View File

@ -1,23 +0,0 @@
--- itv/itv.c.orig 2023-09-20 13:55:04.000000000 -0600
+++ itv/itv.c 2024-04-11 10:06:42.240079202 -0600
@@ -519,13 +519,15 @@ void itv_divn(itv_internal_t* intern,
else {
/* 0 is in the middle of b: one cross-divide b by c->sup */
if (a!=b) {
- bound_div(a->inf,b->sup,c->sup);
- bound_div(a->sup,b->inf,c->sup);
+ bound_neg(intern->mul_bound,c->sup);
+ bound_div(a->inf,b->sup,intern->mul_bound);
+ bound_div(a->sup,b->inf,intern->mul_bound);
}
else {
- bound_div(intern->mul_bound,b->sup,c->sup);
- bound_div(a->sup,b->inf,c->sup);
- bound_set(a->inf,intern->mul_bound);
+ bound_neg(intern->mul_bound,c->sup);
+ bound_div(intern->sqrt_bound,b->sup,intern->mul_bound);
+ bound_div(a->sup,b->inf,intern->mul_bound);
+ bound_set(a->inf,intern->sqrt_bound);
}
}
}

17
apron-flint.patch Normal file
View File

@ -0,0 +1,17 @@
Fixes this error:
pplite_poly.cc: In destructor pplite::apron::pplite_internal::~pplite_internal():
pplite_poly.cc:46:7: error: flint_cleanup was not declared in this scope
46 | flint_cleanup();
| ^~~~~~~~~~~~~
--- pplite/pplite_poly.cc.orig 2024-06-07 09:36:08.000000000 -0600
+++ pplite/pplite_poly.cc 2024-06-13 08:21:55.536500683 -0600
@@ -18,6 +18,7 @@
#include "ap_pplite.h"
#include "pplite_user.hh"
#include "pplite_poly.hh"
+#include <flint/flint.h>
#include <cassert>

View File

@ -1,5 +1,5 @@
Name: apron Name: apron
Version: 0.9.14 Version: 0.9.15
Summary: Numerical abstract domain library Summary: Numerical abstract domain library
Release: %autorelease Release: %autorelease
@ -29,10 +29,8 @@ Patch3: %{name}-japron-link.patch
# https://github.com/antoinemine/apron/issues/94 # https://github.com/antoinemine/apron/issues/94
# https://github.com/antoinemine/apron/pull/95 # https://github.com/antoinemine/apron/pull/95
Patch4: %{name}-hasvar.patch Patch4: %{name}-hasvar.patch
# Fix an internal division bug # Add a missing flint #include
# https://github.com/antoinemine/apron/issues/100 Patch5: %{name}-flint.patch
# https://github.com/antoinemine/apron/pull/101
Patch5: %{name}-division.patch
# OCaml packages not built on i686 since OCaml 5 / Fedora 39. # OCaml packages not built on i686 since OCaml 5 / Fedora 39.
ExcludeArch: %{ix86} ExcludeArch: %{ix86}
@ -153,13 +151,13 @@ sed -i 's/^\([[:blank:]]*cp[[:blank:]]\)/\1-p /' Makefile */Makefile
# Build with debuginfo # Build with debuginfo
sed -i 's/^OCAMLOPTFLAGS =/& -g/' configure sed -i 's/^OCAMLOPTFLAGS =/& -g/' configure
sed -i "s|\$(OCAMLMKLIB) -L.*|& -g|" vars.mk sed -i 's|\$(OCAMLMKLIB) -L.*|& -g|' vars.mk
# Give the C++ library an soname # Give the C++ library an soname
sed -i '/shared/s/\$(CXX)/$(CXX_APRON_DYLIB)/' apronxx/Makefile sed -i '/shared/s/\$(CXX)/$(CXX_APRON_DYLIB)/' apronxx/Makefile
# For reproducibility, omit timestamps from generated documentation # For reproducibility, omit timestamps from generated documentation
sed -i '/HTML_TIMESTAMP/s/YES/NO/' apronxx/doc/Doxyfile sed -i '/HTML_TIMESTAMP/s/= YES/= NO/' apronxx/doc/Doxyfile
%build %build
# This is NOT an autoconf-generated script. Do not use %%configure # This is NOT an autoconf-generated script. Do not use %%configure

View File

@ -1 +1 @@
SHA512 (apron-0.9.14.tar.gz) = 9c1107cea95d56a377f221724064bc65dc605a624171064e681c07e1dece688e06b5511e9974df7c20d883d7dc6cdb25bf1431a8968d721d5c587875ffef751a SHA512 (apron-0.9.15.tar.gz) = c96dc5904c4126f84b01ed0d5a8f38e2c4b9653fa714e3c77fc305d7b8cf8e239eb9a6838dcdc015b2722cbf38f378e5d07122d4c7c5a62f27137992f35a665d