Add -format-security patch.
This commit is contained in:
parent
3afccdc590
commit
623bf9c6ba
11
apron-format-security.patch
Normal file
11
apron-format-security.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- ./box/box_representation.c.orig 2009-09-11 12:00:28.000000000 -0600
|
||||
+++ ./box/box_representation.c 2013-11-20 07:55:00.000000000 -0700
|
||||
@@ -270,7 +270,7 @@ void box_fprintdiff(FILE* stream,
|
||||
( sgn1<0 ?
|
||||
"+[" :
|
||||
"[=, " );
|
||||
- fprintf(stream,str);
|
||||
+ fputs(str,stream);
|
||||
if (sgn1!=0){
|
||||
bound_neg(bound,b->p[i]->inf);
|
||||
bound_fprint(stream,bound);
|
10
apron.spec
10
apron.spec
@ -4,7 +4,7 @@
|
||||
|
||||
Name: apron
|
||||
Version: 0.9.10
|
||||
Release: 13%{?dist}
|
||||
Release: 14%{?dist}
|
||||
Summary: Numerical abstract domain library
|
||||
|
||||
# The entire package is LGPLv2+ except newpolka/mf_qsort.c and ppl/*, all of
|
||||
@ -25,6 +25,8 @@ Patch1: %{name}-mlgmpidl12.patch
|
||||
Patch2: %{name}-test.patch
|
||||
# Not yet sent upstream. Adapt to PPL 1.0 + GMP 5.1.0
|
||||
Patch3: %{name}-ppl1.patch
|
||||
# Alreay applied upstream. Fix a -Werror=format-security failure.
|
||||
Patch4: %{name}-format-security.patch
|
||||
|
||||
BuildRequires: mpfr-devel
|
||||
BuildRequires: ppl-devel
|
||||
@ -37,7 +39,7 @@ BuildRequires: ocaml-ocamldoc
|
||||
%global opt %(test -x %{_bindir}/ocamlopt && echo 1 || echo 0)
|
||||
%endif
|
||||
|
||||
%global sover %(echo %{version} | cut -d. -f 1)
|
||||
%global sover %(cut -d. -f 1 <<< %{version})
|
||||
|
||||
%description
|
||||
The APRON library is dedicated to the static analysis of the numerical
|
||||
@ -85,6 +87,7 @@ Development files for the Ocaml interface to the APRON library.
|
||||
%patch1
|
||||
%patch2
|
||||
%patch3
|
||||
%patch4
|
||||
|
||||
# Set the configuration values
|
||||
sed -e "s|^# HAS_CPP.*|HAS_CPP = 1|" \
|
||||
@ -247,6 +250,9 @@ done
|
||||
%endif
|
||||
|
||||
%changelog
|
||||
* Wed Nov 20 2013 Jerry James <loganjerry@gmail.com> - 0.9.10-14
|
||||
- Add -format-security patch
|
||||
|
||||
* Sat Sep 14 2013 Richard W.M. Jones <rjones@redhat.com> - 0.9.10-13
|
||||
- Rebuild for OCaml 4.01.0.
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user