Version 0.9.13. Drop upstreamed -texinfo patch.
This commit is contained in:
parent
1bf9db5b92
commit
2d433f02e8
@ -1,72 +0,0 @@
|
||||
--- apron/apron.texi.orig 2019-11-10 07:33:31.000000000 -0700
|
||||
+++ apron/apron.texi 2020-01-17 09:04:07.152719196 -0700
|
||||
@@ -67,6 +67,7 @@ numerical variables.
|
||||
@contents
|
||||
@end ifnothtml
|
||||
|
||||
+@ifnottex
|
||||
@menu
|
||||
* Copying::
|
||||
* Introduction to APRON::
|
||||
@@ -80,6 +81,7 @@ numerical variables.
|
||||
* Examples::
|
||||
* Appendices::
|
||||
@end menu
|
||||
+@end ifnottex
|
||||
|
||||
@c *******************************************************************
|
||||
@node Copying, Introduction to APRON, Top, Top
|
||||
@@ -2470,7 +2472,8 @@ Polynomial fraction with possibly interv
|
||||
@end deftypefun
|
||||
|
||||
@deftypefun bool ap_texpr1_is_scalar (ap_texpr1_t* @var{e})
|
||||
-All coefficients are scalar (non-interval)@end deftypefun
|
||||
+All coefficients are scalar (non-interval)
|
||||
+@end deftypefun
|
||||
|
||||
@c -------------------------------------------------------------------
|
||||
@node Operations on tree expressions of level 1, , Tests on tree expressions of level 1, Tree expressions of level 1
|
||||
--- apron/Makefile.orig 2019-11-10 07:33:31.000000000 -0700
|
||||
+++ apron/Makefile 2020-01-17 09:04:07.152719196 -0700
|
||||
@@ -106,15 +106,15 @@ newpolka.texi: ../newpolka/newpolka.texi
|
||||
box.texi: ../box/box.texi
|
||||
ln -sf $< $@
|
||||
|
||||
-apron.pdf: apron.texi rationale.texi ap_pkgrid.texi ap_ppl.texi newpolka.texi box.texi
|
||||
- $(TEXI2DVI) --pdf -o $@ $<
|
||||
+apron.pdf: apron.texi rationale.texi ../products/ap_pkgrid.texi ../ppl/ap_ppl.texi ../newpolka/newpolka.texi ../box/box.texi
|
||||
+ $(TEXI2ANY) --pdf -o $@ $<
|
||||
|
||||
apron.info: apron.texi rationale.texi ap_pkgrid.texi ap_ppl.texi newpolka.texi box.texi
|
||||
$(MAKEINFO) -o $@ $<
|
||||
|
||||
|
||||
html: apron.texi rationale.texi ap_pkgrid.texi ap_ppl.texi newpolka.texi box.texi
|
||||
- $(TEXI2HTML) -split=section -nonumber-sections -menu -subdir=html $<
|
||||
+ $(TEXI2ANY) --html --split=section --no-number-sections $<
|
||||
cp -f ../octagons/oct_doc.html html
|
||||
|
||||
#---------------------------------------
|
||||
--- configure.orig 2019-11-10 07:33:31.000000000 -0700
|
||||
+++ configure 2020-01-17 09:04:07.152719196 -0700
|
||||
@@ -621,8 +621,7 @@ LATEX = latex
|
||||
PDFLATEX = pdflatex
|
||||
DVIPDF = dvipdf
|
||||
MAKEINDEX = makeindex
|
||||
-TEXI2DVI = texi2dvi
|
||||
-TEXI2HTML = texi2html
|
||||
+TEXI2ANY = texi2any
|
||||
|
||||
# OSX only:
|
||||
ABSOLUTE_DYLIB_INSTALL_NAMES = $absolute_dylib_install_names
|
||||
--- Makefile.config.model.orig 2019-11-10 07:33:31.000000000 -0700
|
||||
+++ Makefile.config.model 2020-01-17 09:04:07.153719179 -0700
|
||||
@@ -178,7 +178,6 @@ LATEX=latex
|
||||
PDFLATEX=pdflatex
|
||||
DVIPDF=dvipdf
|
||||
MAKEINDEX=makeindex
|
||||
-TEXI2DVI=texi2dvi
|
||||
-TEXI2HTML=texi2html
|
||||
+TEXI2ANY=texi2any
|
||||
|
||||
OCAMLPACK = $(shell dirname $(realpath $(lastword $(MAKEFILE_LIST))))/ocamlpack
|
16
apron.spec
16
apron.spec
@ -1,6 +1,6 @@
|
||||
Name: apron
|
||||
Version: 0.9.12
|
||||
Release: 10%{?dist}
|
||||
Version: 0.9.13
|
||||
Release: 1%{?dist}
|
||||
Summary: Numerical abstract domain library
|
||||
|
||||
# The entire package is LGPLv2+ except newpolka/mf_qsort.c and ppl/*, all of
|
||||
@ -15,10 +15,8 @@ Source0: https://github.com/antoinemine/%{name}/archive/v%{version}/%{nam
|
||||
# libap_pkgrid be weak references, since that library can be combined with
|
||||
# either of the 2 implementations.
|
||||
Patch0: %{name}-weak.patch
|
||||
# Adapt to texinfo 6.x
|
||||
Patch1: %{name}-texinfo.patch
|
||||
# Adapt to mpfr 4
|
||||
Patch2: %{name}-mpfr4.patch
|
||||
Patch1: %{name}-mpfr4.patch
|
||||
|
||||
BuildRequires: doxygen-latex
|
||||
BuildRequires: gcc-c++
|
||||
@ -88,6 +86,7 @@ Development files for the Ocaml interface to the APRON library.
|
||||
%package -n japron
|
||||
Summary: Java interface to APRON
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
Requires: javapackages-filesystem
|
||||
|
||||
%description -n japron
|
||||
Java interface to the APRON library.
|
||||
@ -124,9 +123,6 @@ sed -e "s|\$(OCAMLMKLIB) -L.*|& -g -ldopt '$RPM_LD_FLAGS'|" \
|
||||
-e "/CMXS/s|-linkall|-ccopt '$RPM_LD_FLAGS' &|" \
|
||||
-i vars.mk
|
||||
|
||||
# The "java -version" output has an extra line we don't want
|
||||
sed -i 's/head -1/head -2 | tail -1/' configure
|
||||
|
||||
%build
|
||||
# This is NOT an autoconf-generated script. Do not use %%configure
|
||||
export CPPFLAGS="-D_GNU_SOURCE"
|
||||
@ -235,6 +231,10 @@ test/ctest1
|
||||
%{_jnidir}/*.so
|
||||
|
||||
%changelog
|
||||
* Fri Sep 25 2020 Jerry James <loganjerry@gmail.com> - 0.9.13-1
|
||||
- Version 0.9.13
|
||||
- Drop upstreamed -texinfo patch
|
||||
|
||||
* Tue Sep 01 2020 Richard W.M. Jones <rjones@redhat.com> - 0.9.12-10
|
||||
- OCaml 4.11.1 rebuild
|
||||
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (apron-0.9.12.tar.gz) = c5c8c05f7bf04ecd2fb71c023a7a2537a366fcc68286f8319481b8274aa9c4bbd1883113ce10e5073232357cf0bbeb433e51339d504d14d656eccede98459742
|
||||
SHA512 (apron-0.9.13.tar.gz) = 62b73925ae41cead924c6077380be98e2e2fc0c02b1bff0a77293dc065126ae651793883783e497228f8261ffd47311d5a08cfd1875d3da3cc113ae428fa2c61
|
||||
|
Loading…
Reference in New Issue
Block a user