Update to 0.9.14-beta2. Enable csdp support.
This commit is contained in:
parent
0079bf76a8
commit
1731fc67e0
23
apron-csdp.patch
Normal file
23
apron-csdp.patch
Normal file
@ -0,0 +1,23 @@
|
|||||||
|
--- taylor1plus/Makefile.orig 2023-07-09 03:58:59.000000000 -0600
|
||||||
|
+++ taylor1plus/Makefile 2023-07-27 09:07:33.315882622 -0600
|
||||||
|
@@ -58,8 +58,8 @@ CAML_TO_INSTALL_DEBUG += dllt1pMPQ_caml_
|
||||||
|
endif
|
||||||
|
endif
|
||||||
|
|
||||||
|
-LIBS = -lapron -lgmpxx -lmpfr -lgmp -lm
|
||||||
|
-LIBS_DEBUG = -lapron_debug -lgmpxx -lmpfr -lgmp -lm
|
||||||
|
+LIBS = -Wl,--as-needed -lapron -lsdp -lgmpxx -lmpfr -lgmp -lm
|
||||||
|
+LIBS_DEBUG = -Wl,--as-needed -lapron_debug -lsdp -lgmpxx -lmpfr -lgmp -lm
|
||||||
|
|
||||||
|
#---------------------------------------
|
||||||
|
# Rules
|
||||||
|
--- taylor1plus/t1p_fun.c.orig 2023-07-09 03:58:59.000000000 -0600
|
||||||
|
+++ taylor1plus/t1p_fun.c 2023-07-27 08:45:57.813003179 -0600
|
||||||
|
@@ -14,7 +14,6 @@
|
||||||
|
|
||||||
|
#ifdef _USE_SDP
|
||||||
|
#include "declarations.h"
|
||||||
|
-#include "vSDP.h"
|
||||||
|
#endif
|
||||||
|
|
||||||
|
#include "ap_texpr0.h"
|
19
apron.spec
19
apron.spec
@ -1,9 +1,9 @@
|
|||||||
%global prerel beta1
|
%global prerel beta.2
|
||||||
|
|
||||||
Name: apron
|
Name: apron
|
||||||
Version: 0.9.14
|
Version: 0.9.14
|
||||||
Summary: Numerical abstract domain library
|
Summary: Numerical abstract domain library
|
||||||
Release: 0.3%{?prerel:.%{prerel}}%{?dist}
|
Release: 0.4%{?prerel:.%{prerel}}%{?dist}
|
||||||
|
|
||||||
# The entire package is LGPL-2.1-or-later WITH OCaml-LGPL-linking-exception
|
# The entire package is LGPL-2.1-or-later WITH OCaml-LGPL-linking-exception
|
||||||
# except newpolka/mf_qsort.c and ppl/*, all of which are GPL-2.0-or-later.
|
# except newpolka/mf_qsort.c and ppl/*, all of which are GPL-2.0-or-later.
|
||||||
@ -21,10 +21,13 @@ Source0: https://github.com/antoinemine/apron/archive/v%{version}%{?prere
|
|||||||
Patch0: %{name}-weak.patch
|
Patch0: %{name}-weak.patch
|
||||||
# Fix the OCaml build on bytecode-only architectures
|
# Fix the OCaml build on bytecode-only architectures
|
||||||
Patch1: %{name}-ocaml-bytecode.patch
|
Patch1: %{name}-ocaml-bytecode.patch
|
||||||
|
# Update CSDP support for CSDP 6.2.0
|
||||||
|
Patch2: %{name}-csdp.patch
|
||||||
|
|
||||||
# OCaml packages not built on i686 since OCaml 5 / Fedora 39.
|
# OCaml packages not built on i686 since OCaml 5 / Fedora 39.
|
||||||
ExcludeArch: %{ix86}
|
ExcludeArch: %{ix86}
|
||||||
|
|
||||||
|
BuildRequires: csdp-devel
|
||||||
BuildRequires: doxygen-latex
|
BuildRequires: doxygen-latex
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
BuildRequires: ghostscript-tools-dvipdf
|
BuildRequires: ghostscript-tools-dvipdf
|
||||||
@ -113,10 +116,11 @@ Java interface to the APRON library.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%autosetup -N -n %{name}-%{version}%{?prerel:-%{prerel}}
|
%autosetup -N -n %{name}-%{version}%{?prerel:-%{prerel}}
|
||||||
%autopatch -M 0 -p0
|
%patch -P0 -p0
|
||||||
%ifnarch %{ocaml_native_compiler}
|
%ifnarch %{ocaml_native_compiler}
|
||||||
%autopatch -m 1 -p0
|
%patch -P1 -p0
|
||||||
%endif
|
%endif
|
||||||
|
%patch -P2 -p0
|
||||||
|
|
||||||
# Fix library path for 64-bit installs
|
# Fix library path for 64-bit installs
|
||||||
if [ "%{_lib}" = "lib64" ]; then
|
if [ "%{_lib}" = "lib64" ]; then
|
||||||
@ -141,9 +145,10 @@ sed -i '/shared/s/\$(CXX)/$(CXX_APRON_DYLIB)/' apronxx/Makefile
|
|||||||
|
|
||||||
%build
|
%build
|
||||||
# This is NOT an autoconf-generated script. Do not use %%configure
|
# This is NOT an autoconf-generated script. Do not use %%configure
|
||||||
export CPPFLAGS='-D_GNU_SOURCE'
|
export CPPFLAGS='-D_GNU_SOURCE -I%{_includedir}/csdp'
|
||||||
export CFLAGS='%{build_cflags} -fsigned-char'
|
export CFLAGS='%{build_cflags} -fsigned-char'
|
||||||
export CXXFLAGS='%{build_cxxflags} -fsigned-char'
|
export CXXFLAGS='%{build_cxxflags} -fsigned-char'
|
||||||
|
export CSDP_PATH=%{_prefix}
|
||||||
%ifarch %{java_arches}
|
%ifarch %{java_arches}
|
||||||
export JAVA_HOME='%{_jvmdir}/java'
|
export JAVA_HOME='%{_jvmdir}/java'
|
||||||
export JAVA_TOOL_OPTIONS='-Dfile.encoding=UTF8'
|
export JAVA_TOOL_OPTIONS='-Dfile.encoding=UTF8'
|
||||||
@ -268,6 +273,10 @@ test/ctest1
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jul 27 2023 Jerry James <loganjerry@gmail.com> - 0.9.14-0.4.beta2
|
||||||
|
- Update to 0.9.14-beta2
|
||||||
|
- Enable csdp support
|
||||||
|
|
||||||
* Wed Jul 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.14-0.3.beta1
|
* Wed Jul 19 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.9.14-0.3.beta1
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (apron-0.9.14-beta1.tar.gz) = 116206a1a7731639a47ac3708352eb8323518ddd731a52fe061b47901f469be3f8fd2e5bd4e1e7e759af9a7c40d4c3508d40da66a93fd3b3993f836106477a33
|
SHA512 (apron-0.9.14-beta.2.tar.gz) = bc2cbcf601c0d6deb75028ef7da4b485350665a09c4f9ed9146107aeed65edb055207a02a52bc279c2b506e9c5922371035fb00d0ae2cbfec3a9a760ecebf1bd
|
||||||
|
Loading…
Reference in New Issue
Block a user