Merge branch 'master' into f19

Conflicts:
	appliance-tools.spec
This commit is contained in:
Dennis Gilmore 2013-05-12 16:05:23 -05:00
commit 63f95f8c29
2 changed files with 34 additions and 1 deletions

View File

@ -0,0 +1,28 @@
From a0feeeb6630ecc08c407255e15fa9dfbf00e1c44 Mon Sep 17 00:00:00 2001
From: Dennis Gilmore <dennis@ausil.us>
Date: Sun, 12 May 2013 15:58:48 -0500
Subject: [PATCH] couple of typo fixes in extlinux support from mattdm
---
appcreate/appliance.py | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/appcreate/appliance.py b/appcreate/appliance.py
index 54ac376..dbc66d7 100644
--- a/appcreate/appliance.py
+++ b/appcreate/appliance.py
@@ -307,9 +307,9 @@ class ApplianceImageCreator(ImageCreator):
extlinux += "ui menu.c32\n"
extlinux += "menu autoboot Welcome to %s. Automatic boot in # second{,s}. Press a key for options.\n" % (self.name)
extlinux += "menu title %s Boot Options.\n" % (self.name)
- extlinux += "menu hiddenmenu\n"
+ extlinux += "menu hidden\n"
extlinux += "timeout 1\n"
- extlinux += "totaltimeout 60\n\n"
+ extlinux += "totaltimeout 600"
versions = []
kernels = self._get_kernel_versions()
--
1.8.2.1

View File

@ -5,7 +5,7 @@
Summary: Tools for building Appliances
Name: appliance-tools
Version: 006.3
Release: 1%{?dist}.1
Release: 2%{?dist}
License: GPLv2
Group: System Environment/Base
URL: http://thincrust.org/
@ -16,6 +16,7 @@ URL: http://thincrust.org/
# git checkout appliance-tools-006.2
# make dist
Source0: appliance-tools-%{version}.tar.bz2
Patch0: 0001-couple-of-typo-fixes-in-extlinux-support-from-mattdm.patch
Requires: livecd-tools >= 020 curl rsync kpartx
Requires: zlib
Requires: qemu-img
@ -40,6 +41,7 @@ Tool that helps remove unwanted files from the appliance image.
%prep
%setup -q
%patch0 -p1
%build
make
@ -72,6 +74,9 @@ rm -rf $RPM_BUILD_ROOT
%{_bindir}/image-minimizer
%changelog
* Sun May 12 2013 Dennis Gilmore <dennis@ausil.us> - 006.3-2
- add patch for typo fixes in extlinux config from mattdm
* Fri May 10 2013 Dennis Gilmore <dennis@ausil.us> - 006.3-1.1
- BuildRequires: /usr/bin/pod2man