$supported_os and $JAVA_OS in configure do not always match

- on arches that override supported_os to be the arch we can not find headers
This commit is contained in:
Dennis Gilmore 2012-03-29 18:16:18 -05:00
parent 26facc3d85
commit 56d58edb23
2 changed files with 29 additions and 1 deletions

View File

@ -0,0 +1,22 @@
--- commons-daemon-1.0.10-src/src/native/unix/configure.orig 2012-03-29 18:11:47.739291747 -0500
+++ commons-daemon-1.0.10-src/src/native/unix/configure 2012-03-29 18:12:15.287452463 -0500
@@ -2818,7 +2818,7 @@
echo "${ECHO_T}jni_md.h found in $JAVA_HOME/$JAVA_INC" >&6
INCLUDES="$INCLUDES -I$JAVA_HOME/include -I$JAVA_HOME/$JAVA_INC"
else
- INCLUDES="$INCLUDES -I$JAVA_HOME/include -I$JAVA_HOME/include/$supported_os"
+ INCLUDES="$INCLUDES -I$JAVA_HOME/include -I$JAVA_HOME/include/$JAVA_OS"
fi
if test "$GCC" = "yes"
--- commons-daemon-1.0.10-src/src/native/unix/configure.in.orig 2012-03-29 18:11:18.244119358 -0500
+++ commons-daemon-1.0.10-src/src/native/unix/configure.in 2012-03-29 18:11:35.745221681 -0500
@@ -94,7 +94,7 @@
AC_MSG_RESULT([jni_md.h found in $JAVA_HOME/$JAVA_INC])
INCLUDES="$INCLUDES -I$JAVA_HOME/include -I$JAVA_HOME/$JAVA_INC"
else
- INCLUDES="$INCLUDES -I$JAVA_HOME/include -I$JAVA_HOME/include/$supported_os"
+ INCLUDES="$INCLUDES -I$JAVA_HOME/include -I$JAVA_HOME/include/$JAVA_OS"
fi
dnl -------------------------------------------------------------------------

View File

@ -4,13 +4,14 @@
Name: apache-%{short_name}
Version: 1.0.10
Release: 1%{?dist}
Release: 2%{?dist}
Summary: Defines API to support an alternative invocation mechanism
License: ASL 2.0
Group: Applications/System
URL: http://commons.apache.org/%{base_name}
Source0: http://archive.apache.org/dist/commons/%{base_name}/source/%{short_name}-%{version}-src.tar.gz
Patch0: 0001-execve-path-warning.patch
Patch1: apache-commons-daemon-JAVA_OS.patch
BuildRequires: java-devel >= 1:1.6.0
BuildRequires: jpackage-utils
BuildRequires: maven
@ -61,6 +62,7 @@ Obsoletes: jakarta-%{short_name}-javadoc <= 1:1.0.1
%prep
%setup -q -n %{short_name}-%{version}-src
%patch0 -p1 -b .execve
%patch1 -p1 -b .java_os
# remove java binaries from sources
rm -rf src/samples/build/
@ -132,6 +134,10 @@ rm -rf $(readlink -f %{_javadocdir}/%{name}) %{_javadocdir}/%{name} || :
%changelog
* Thu Mar 29 2012 Dennis Gilmore <dennis@ausil.us> - 1.0.10-2
- $supported_os and $JAVA_OS in configure do not always match
- on arches that override supported_os to be the arch we can not find headers
* Thu Jan 26 2012 Stanislav Ochotnicky <sochotnicky@redhat.com> - 1.0.10-1
- Update to latest upstream (1.0.10)
- Several bugfixes concerning libcap and building upstream