annobin/0001-llvm-plugin-Add-flegac...

28 lines
1.0 KiB
Diff

From bda340f0754972944ec115a72f1a8547ffa21f1c Mon Sep 17 00:00:00 2001
From: Tom Stellard <tstellar@redhat.com>
Date: Mon, 16 Aug 2021 18:04:53 +0000
Subject: [PATCH] llvm-plugin: Add -flegacy-pass-manager option to the test
case
The plugin does not work with the new pass manager yet.
---
llvm-plugin/Makefile.in | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/llvm-plugin/Makefile.in b/llvm-plugin/Makefile.in
index bdd8b19..92bcc9a 100644
--- a/llvm-plugin/Makefile.in
+++ b/llvm-plugin/Makefile.in
@@ -48,7 +48,7 @@ PLUGIN_TEST_OPTIONS = \
# -fcf-protection \
check: @srcdir@/hello.c
- @ $(CLANG) -Xclang -load -Xclang $(PLUGIN) $(PLUGIN_TEST_OPTIONS) -c @srcdir@/hello.c
+ @ $(CLANG) -flegacy-pass-manager -Xclang -load -Xclang $(PLUGIN) $(PLUGIN_TEST_OPTIONS) -c @srcdir@/hello.c
@ $(READELF) --wide --notes hello.o > llvm-plugin-test.out
@ grep --silent -e "annobin built by llvm version" llvm-plugin-test.out
@ grep --silent -e "running on LLVM version" llvm-plugin-test.out
--
2.26.2