Update RISC-V patch

Signed-off-by: David Abdurachmanov <david.abdurachmanov@sifive.com>
This commit is contained in:
David Abdurachmanov 2021-04-14 17:25:30 +03:00
parent 9934737a56
commit 9930fc7c9a
Signed by: davidlt
GPG Key ID: 8B7F1DA0E2C9FDBB
1 changed files with 28 additions and 0 deletions

View File

@ -1,3 +1,31 @@
diff --git a/configure b/configure
index 4ade97a..6028b72 100755
--- a/configure
+++ b/configure
@@ -17807,6 +17807,9 @@ case ${target} in
s390*-*-*)
target_plugin="s390.annobin.lo"
;;
+ riscv*-*-*)
+ target_plugin="riscv.annobin.lo"
+ ;;
*)
target_plugin="dummy.annobin.lo"
;;
diff --git a/configure.ac b/configure.ac
index acbf0a4..10cf53a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,6 +42,9 @@ case ${target} in
s390*-*-*)
target_plugin="s390.annobin.lo"
;;
+ riscv*-*-*)
+ target_plugin="riscv.annobin.lo"
+ ;;
*)
target_plugin="dummy.annobin.lo"
;;
diff --git a/gcc-plugin/Makefile.am b/gcc-plugin/Makefile.am
index 4df5c14..b3e061e 100644
--- a/gcc-plugin/Makefile.am