Add support for RISC-V

Author: David Abdurachmanov <david.abdurachmanov@gmail.com>
Signed-off-by: Nianqing Yao <imbearchild@outlook.com> and David Abdurachmanov <david.abdurachmanov@gmail.com>
This commit is contained in:
David Abdurachmanov 2022-05-11 12:26:42 +00:00 committed by Tux
parent e305a8053a
commit 6a039d67f0
2 changed files with 33 additions and 0 deletions

View File

@ -0,0 +1,28 @@
diff --git a/configure b/configure
index 4ade97a..6028b72 100755
--- a/configure
+++ b/configure
@@ -17807,6 +17807,9 @@ case ${target} in
s390*-*-*)
target_plugin="s390.annobin.lo"
;;
+ riscv*-*-*)
+ target_plugin="riscv.annobin.lo"
+ ;;
*)
target_plugin="dummy.annobin.lo"
;;
diff --git a/configure.ac b/configure.ac
index acbf0a4..10cf53a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -42,6 +42,9 @@ case ${target} in
s390*-*-*)
target_plugin="s390.annobin.lo"
;;
+ riscv*-*-*)
+ target_plugin="riscv.annobin.lo"
+ ;;
*)
target_plugin="dummy.annobin.lo"
;;

View File

@ -69,6 +69,8 @@ Source: https://nickc.fedorapeople.org/%{annobin_sources}
# Patch01: annobin-foo.patch
# Patch01: 0001-Compatibility-patch-for-llvm14.patch
Patch01: annobin-add-riscv-support.patch
#---------------------------------------------------------------------------------
# Make sure that the necessary sub-packages are built.
@ -484,6 +486,9 @@ fi
#---------------------------------------------------------------------------------
%changelog
* Thu May 10 2022 Nianqing Yao <imbearchild@outlook.com> - 10.70-2
- Add support for RISC-V.
* Mon May 09 2022 Nick Clifton <nickc@redhat.com> - 10.70-1
- Annocheck: Add another special case for glibc rpms. (#2083070)